Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: unable to add yahoo/google mail accounts

since upgrading to El Capitan I'm unable to add any yahoo or google account ...


when trying to add an account (gmail or yahoo) into mail an error message pops up stating:


Connection Insecure

Failed to verify the server certificate. This could be because of your network configuration or your proxy settings.


User uploaded file


when trying to access the accounts via web browser all goes ok, so there’s no network/internet connection or proxy issues. In fact, I'm using no proxy whatsoever.


The error is the same if trying to add the accounts using mail or the internet accounts system preference ... I imagine is something related to OAuth since for any of these two providers that is the authentication method used to configure them


any help would be greatly appreciated


Rgds

MacBook (13-inch Aluminum Late 2008), OS X El Capitan (10.11)

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Found the fix for this.


there're two verisign certs with a red mark "This certificate was signed by an untrusted issuer" in the Login/Certificates container in the keychain. You need to delete them, once removed the Connection Insecure message is gone and will be able to add the accounts.

Posted on

Question marked as Helpful

Oct 2, 2015 4:57 AM in response to oswjim In response to oswjim

Hi


be sure to look for Verisign certificates as in the image below .. check all of them for having the green check mark -- the ones to delete show a red x stating "This certificate was signed by an untrusted issuer" don't recall exactly but think mines were still valid (not expired)


User uploaded file

Question marked as Helpful

Oct 28, 2015 5:23 AM in response to jamiefromsawbridgeworth In response to jamiefromsawbridgeworth

OS: 10.11.1


I was experiencing the same issue as described in the first post of this thread. After investigating the issue in more detail I was able to narrow my problem down to the Avast Mail Shield. I was unable to disable the mail shield and had to completely remove the product. After removing Avast, I was able to add a Google Account to Internet Accounts.


I will be opening a support ticket with Avast regarding this issue.

Question marked as Helpful

Oct 2, 2015 2:37 PM in response to jhcook In response to jhcook

I have the same problem trying to add a Yahoo account to mail. I've looked at all the Verisign certs and all have the green check mark and have expiration dates in the future. I'm new at working resolving issues with Apples OS (I have El Capitan installed via update from Yosemite), and don't know how to delete the ~/Library/Keychains/* you mentioned, nor how to restore it after. Can someone tell me how to resolve this in a way that won't have me destroying my OS installation?

Question marked as Helpful

Oct 2, 2015 11:34 PM in response to Kepar In response to Kepar

Hi there. I should have spent a bit more time explaining that this is a certificate in keychain. However, you can go fishing and hopefully find the bad cert. But, this will take some time and/or a bit of luck. In my case, I removed all the bad certs that had expired or was revoked for whatever reason, and that did not work for me.


Since I have everything I care about in iCloud Keychain, I removed System Preferences > iCloud > Keychain, deleted ~/Library/Keychains/*, rebooted and then added my Google account accordingly. I then added System Preferences > iCloud > Keychain back.

There’s more to the conversation

Read all replies

Page content loaded

Question marked as Solved

Oct 1, 2015 12:33 AM in response to oswjim In response to oswjim

Found the fix for this.


there're two verisign certs with a red mark "This certificate was signed by an untrusted issuer" in the Login/Certificates container in the keychain. You need to delete them, once removed the Connection Insecure message is gone and will be able to add the accounts.

Oct 1, 2015 12:33 AM

Reply Helpful (37)
Question marked as Helpful

Oct 2, 2015 4:57 AM in response to oswjim In response to oswjim

Hi


be sure to look for Verisign certificates as in the image below .. check all of them for having the green check mark -- the ones to delete show a red x stating "This certificate was signed by an untrusted issuer" don't recall exactly but think mines were still valid (not expired)


User uploaded file

Oct 2, 2015 4:57 AM

Reply Helpful (34)
Question marked as Helpful

Oct 2, 2015 2:37 PM in response to jhcook In response to jhcook

I have the same problem trying to add a Yahoo account to mail. I've looked at all the Verisign certs and all have the green check mark and have expiration dates in the future. I'm new at working resolving issues with Apples OS (I have El Capitan installed via update from Yosemite), and don't know how to delete the ~/Library/Keychains/* you mentioned, nor how to restore it after. Can someone tell me how to resolve this in a way that won't have me destroying my OS installation?

Oct 2, 2015 2:37 PM

Reply Helpful (6)

Oct 2, 2015 3:49 PM in response to Bill Totman In response to Bill Totman

This turned out to be an expired/revoked Verizign cert for me as well.


You have to cycle through each of the Verisign certs to find out which one is bad and delete it... you may also have to reboot or restart Mail.

Oct 2, 2015 3:49 PM

Reply Helpful (2)
Question marked as Helpful

Oct 2, 2015 11:34 PM in response to Kepar In response to Kepar

Hi there. I should have spent a bit more time explaining that this is a certificate in keychain. However, you can go fishing and hopefully find the bad cert. But, this will take some time and/or a bit of luck. In my case, I removed all the bad certs that had expired or was revoked for whatever reason, and that did not work for me.


Since I have everything I care about in iCloud Keychain, I removed System Preferences > iCloud > Keychain, deleted ~/Library/Keychains/*, rebooted and then added my Google account accordingly. I then added System Preferences > iCloud > Keychain back.

Oct 2, 2015 11:34 PM

Reply Helpful (6)

Oct 4, 2015 8:18 AM in response to oswjim In response to oswjim

I have a similar problem but it only applies to a google .edu account. My personal gmail account was added just fine. Overtime I try to add my .edu google account to internet accounts in system preferences or mail's preferences I receive the following error...


Authentication Failed

Failed to authenticate with Google, please try again later.


User uploaded file

This also freezes System Preferences requiring a force quit.


All in all El Capitan won't add my google account. Anyone know how to get this to work?

Oct 4, 2015 8:18 AM

Reply Helpful
User profile for user: oswjim

Question: unable to add yahoo/google mail accounts