Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Intellitype Pro Keyboard Settings Don't Work in El Cap

I use a Microsoft Natural 4000 keyboard. Worked beautifully in Yosemite and works on my mini, but on my macbook pro, the settings are ignored. Specifically, I want to flip the Windows/Alt key and regardless if it's checked or not, El Capitan ignores it.


I've tried: Removing Intellitype Pro Keyboard via the uninstaller, rebooting, reinstalling, unchecking/rechecking...and it's still ignored.


Any advice? Really mentally confusing to have your keyboard remapped underneath you.

Posted on

Reply
Question marked as Apple Recommended
Answer:
Answer:

Go to System Preferences > Keyboard > Modifier Keys and switch command and option manually (this is what checking the box on the intellitype settings page does).

Posted on

Question marked as Helpful

Oct 14, 2015 9:08 AM in response to Kurt Lang In response to Kurt Lang

There is a way to get IntelliType 8.2 installed and working, and still have System Integrity Protection enabled.


1) Boot to the Recovery partition, or a flash drive El Capitan installer you've created. Click Utilities on the top menu bar, choose Terminal and enter:


csrutil disable


Restart normally back to El Capitan.


2) Install IntelliType. You'll be told it's an unsigned app if you double click the installer. So right click on it and choose Run. You'll notice part of the dialogue that goes by as it's installing is that components are being registered with the system. That's the important part. El Capitan now recognizes it as "okay". There of course is the restart the IntelliType installer does to finish.


3) Now that IntelliType is installed, once again boot to the Recovery partition and this time in Terminal enter:


csrutil enable


4) SIP has now been re-enabled, so you have the extra protection El Capitan brings with it, and IntelliType is still installed and functioning.

There’s more to the conversation

Read all replies

Page content loaded

Oct 3, 2015 4:30 AM in response to raindog308 In response to raindog308

For anyone who relies on a Microsoft ergonomic keyboard, either because they are a fast touch typist or they have RSI-type problems, upgrading to El Capitan is a bad idea. So far I have yet to see a single advantage or genuinely useful feature of the new OS, and having to revert to Apple's nasty membrane keyboards is hopeless. I'm wishing I'd never bothered.


I can't imagine Microsoft will ever update IntelliType.

Oct 3, 2015 4:30 AM

Reply Helpful (1)

Oct 5, 2015 7:02 AM in response to cerber0s In response to cerber0s

This is a good work-around. It was not working for me until I noticed a drop down at the top of the dialog that allows you to switch between the built-in keyboard and the MS keyboard.


At least now I can move on with the correct Command and Option key mappings. The rest of the custom keys do not work at all.


It will be interesting to see if MS even bothers to update this keyboard software.

Oct 5, 2015 7:02 AM

Reply Helpful (1)

Oct 5, 2015 9:44 AM in response to raindog308 In response to raindog308

I also use the MS 4000 keyboard and have for years. Give me an ergo keyboard any day over a straight one. Much more comfortable to use.


The problem is the new OS protection in El Capitan. Part of the Intellitype installer puts a .kext file in the /System/Library/Extensions/ folder, which is now a big no-no if it isn't a properly developer signed and installed item. On top of that, the System folder is now pretty much 100% off limits to third party vendors. Such .kext files are now supposed to be installed to the /Library/Extensions/ folder.


MS has ignored the Mac version of this software since Lion. To get it to work in Mountain Lion through Yosemite, you have to manually add the keyboard helper to your startup items. Not a big deal to do, and then it properly loads automatically on startup.


But now it's just plain dead until MS gets off their lazy butts and finally updates this software.

Oct 5, 2015 9:44 AM

Reply Helpful (1)

Oct 8, 2015 12:00 PM in response to WeeptheGreed In response to WeeptheGreed

I used the special keys all the time and this is horrible having lost them.

That may sound silly to some, but I completely agree. I can't remember the last time I opened Safari or Outlook from the Dock, or backed up a page in a web browser by mousing up to the top left of the browser window. Those extra keys are very handy, and much faster to use.

Oct 8, 2015 12:00 PM

Reply Helpful

Oct 8, 2015 12:04 PM in response to raindog308 In response to raindog308

I have been looking for days and finally found the answer:


http://answers.microsoft.com/en-us/windows/forum/windows_other-hardware/el-capit an-and-microsoft-mouse-intellipoint-not/…


Note: this does require disabling a security feature of the OS, so make sure you do your reading and know what you are signing up for.

Oct 8, 2015 12:04 PM

Reply Helpful
Question marked as Helpful

Oct 14, 2015 9:08 AM in response to Kurt Lang In response to Kurt Lang

There is a way to get IntelliType 8.2 installed and working, and still have System Integrity Protection enabled.


1) Boot to the Recovery partition, or a flash drive El Capitan installer you've created. Click Utilities on the top menu bar, choose Terminal and enter:


csrutil disable


Restart normally back to El Capitan.


2) Install IntelliType. You'll be told it's an unsigned app if you double click the installer. So right click on it and choose Run. You'll notice part of the dialogue that goes by as it's installing is that components are being registered with the system. That's the important part. El Capitan now recognizes it as "okay". There of course is the restart the IntelliType installer does to finish.


3) Now that IntelliType is installed, once again boot to the Recovery partition and this time in Terminal enter:


csrutil enable


4) SIP has now been re-enabled, so you have the extra protection El Capitan brings with it, and IntelliType is still installed and functioning.

Oct 14, 2015 9:08 AM

Reply Helpful (7)

Oct 14, 2015 8:54 AM in response to Kurt Lang In response to Kurt Lang

I will confirm that this is the correct method to enable IntelliType in El Capitan. It is very safe to do this. The security feature (it's called SIP) is designed to prevent malware from modifying deep system files without user consent. It is perfectly safe to disable it to install a program like IntelliType then re-enable it. It's designed to be a bit of a hassle so that it is never disabled accidentally or unintentionally.

Oct 14, 2015 8:54 AM

Reply Helpful
User profile for user: raindog308

Question: Intellitype Pro Keyboard Settings Don't Work in El Cap