Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Can't open system preference panes after upgrading to El Capitan

I ran the upgrade on my mid-2008 MacBook Pro to take it from Yosemite to El Capitan. I've had two major issues. First, El Capitan forgot all my e-mail passwords which I have tried to manually re-enter into Mail. But the more troubling problem is with System Preferences. When I try to change the loudness of sound on my MacBook Pro, it shows that the sound is muted and the screen flashes. I went to the Accessibility pane to try and turn off the flash and see if that would fix the sound, but the pane will not open. I click on it and after a period of several minutes, the OS responds that it cannot open the preference pane. I then tried to open the Sounds preference pane and the same thing happens...after several minutes, the OS says it cannot open the preference pane. I've tried re-starting the MacBook Pro to no avail. I see that system preferences cannot be repaired. I have no idea on how to fix the preference panes to open properly. I tried re-booting to the recovery partition and running Disk First AId. It found no problems, but it didn't fix anything either.


Any ideas on what I can try to get the functionality back on my machine?

MacBook Pro, OS X El Capitan (10.11), 4 Gb of RAM

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Thanks Carolyn, The finder option didn't work for me but the safe boot did. (Copied below for clarity)

If that didn't help, a Safe Mode boot deletes system caches that may help after an OS X upgrade.

Top left corner of your screen click the Apple > Shut Down.

After your Mac shuts down, wait 10 seconds, then press the power button.

Immediately after you hear the startup tone, hold down the Shift key. You should press the Shift key as soon as possible after you hear the startup tone, but not before.

Release the Shift key when you see the gray Apple logo and progress indicator.

Once you are in Safe Mode, go back to the Apple menu. From the drop down menu click: Restart

Posted on

Question marked as Helpful

Oct 1, 2015 1:43 PM in response to David Biddix In response to David Biddix

The problems with the System Preferences pane may be due to corrupted preferences due to the upgrade from Yosemite.



Open the Finder.


From the Finder menu bar click Go > Go to Folder


Type or copy paste the following:


~/Library/Preferences/com.apple.systempreferences.plist


Click Go then move the com.apple.systempreferences.plist file to the Trash.



Restart your Mac then try System Preferences.

If that didn't help, a Safe Mode boot deletes system caches that may help after an OS X upgrade.


Top left corner of your screen click the Apple > Shut Down.


After your Mac shuts down, wait 10 seconds, then press the power button.


Immediately after you hear the startup tone, hold down the Shift key. You should press the Shift key as soon as possible after you hear the startup tone, but not before.


Release the Shift key when you see the gray Apple logo and progress indicator.


Once you are in Safe Mode, go back to the Apple menu. From the drop down menu click: Restart

Then try System Preferences again.




About Safe Mode

Question marked as Helpful

Oct 8, 2015 7:09 AM in response to David Biddix In response to David Biddix

You may find the steps suggested in this discussion thread helpful:

https://discussions.apple.com/thread/4274415


You already performed the safe mode steps but these steps provided by Linc Davis seemed to resolve the issue for the individual who posted the discussion question:

  • In the Finder, press the key combination shift-command-A to open the Applications folder.
  • Select the System Preferences icon in that folder and press the key combination command-I to open the Info window.
  • There’s a checkbox in the Info window labeled Open in 32-bit mode. Uncheck it, if checked. Close the Info window and the Applications folder. Test.

There’s more to the conversation

Read all replies

Page content loaded

Question marked as Helpful

Oct 1, 2015 1:43 PM in response to David Biddix In response to David Biddix

The problems with the System Preferences pane may be due to corrupted preferences due to the upgrade from Yosemite.



Open the Finder.


From the Finder menu bar click Go > Go to Folder


Type or copy paste the following:


~/Library/Preferences/com.apple.systempreferences.plist


Click Go then move the com.apple.systempreferences.plist file to the Trash.



Restart your Mac then try System Preferences.

If that didn't help, a Safe Mode boot deletes system caches that may help after an OS X upgrade.


Top left corner of your screen click the Apple > Shut Down.


After your Mac shuts down, wait 10 seconds, then press the power button.


Immediately after you hear the startup tone, hold down the Shift key. You should press the Shift key as soon as possible after you hear the startup tone, but not before.


Release the Shift key when you see the gray Apple logo and progress indicator.


Once you are in Safe Mode, go back to the Apple menu. From the drop down menu click: Restart

Then try System Preferences again.




About Safe Mode

Oct 1, 2015 1:43 PM

Reply Helpful (12)

Oct 1, 2015 1:44 PM in response to David Biddix In response to David Biddix

The resolution found in the discussion thread below may be helpful for you.


Discussion Thread:

https://discussions.apple.com/thread/5290222?start=0&tstart=0


In the Finder, hold down the option key and select


Go > Library


from the menu bar. From the Library folder, delete the following item, if it exists:


  • "Caches/com.apple.systempreferences"
  • Move the following item to the Desktop: "Preferences/com.apple.desktop.plist"

  • Launch System Preferences and test. If you still have the issue, put the item on the Desktop back where it came from and post again. Otherwise, delete the item.

    Oct 1, 2015 1:44 PM

    Reply Helpful (3)

    Oct 2, 2015 11:54 AM in response to bren_nan In response to bren_nan

    I've tried the fixes and am still having problems. I tried trashing preferences and re-starting my computer. I could access the sounds and they started working fine on my Mac. But when I open Mail, the computer's sounds stop working, the screen flashes (a la Accessibility settings) and when I try to open the Sounds or the Accessibility panes in System Presences, the system hangs and eventually after a few minutes tells me that the preferences pane I've requested can't be opened.


    I also tried staring up in Safe Mode, then restarting the machine. Again, things work fine until I open the Mail program, then things stop working again.


    I've been using Macs for 25 years and I've never had anything happen like this. What else could I try to fix this?

    Oct 2, 2015 11:54 AM

    Reply Helpful
    Question marked as Helpful

    Oct 8, 2015 7:09 AM in response to David Biddix In response to David Biddix

    You may find the steps suggested in this discussion thread helpful:

    https://discussions.apple.com/thread/4274415


    You already performed the safe mode steps but these steps provided by Linc Davis seemed to resolve the issue for the individual who posted the discussion question:

    • In the Finder, press the key combination shift-command-A to open the Applications folder.
    • Select the System Preferences icon in that folder and press the key combination command-I to open the Info window.
    • There’s a checkbox in the Info window labeled Open in 32-bit mode. Uncheck it, if checked. Close the Info window and the Applications folder. Test.

    Oct 8, 2015 7:09 AM

    Reply Helpful (2)
    Question marked as Solved

    Oct 8, 2015 7:08 AM in response to Carolyn Samit In response to Carolyn Samit

    Thanks Carolyn, The finder option didn't work for me but the safe boot did. (Copied below for clarity)

    If that didn't help, a Safe Mode boot deletes system caches that may help after an OS X upgrade.

    Top left corner of your screen click the Apple > Shut Down.

    After your Mac shuts down, wait 10 seconds, then press the power button.

    Immediately after you hear the startup tone, hold down the Shift key. You should press the Shift key as soon as possible after you hear the startup tone, but not before.

    Release the Shift key when you see the gray Apple logo and progress indicator.

    Once you are in Safe Mode, go back to the Apple menu. From the drop down menu click: Restart

    Oct 8, 2015 7:08 AM

    Reply Helpful (5)

    Oct 8, 2015 7:17 AM in response to David Biddix In response to David Biddix

    Just as an update to everyone...


    I contacted Apple Support, and after testing with a new user account and trashing preferences, I think El Capitan has settled down and seems to be running better on my mid-2008 MacBook Pro. The machine does have issues after starting up from cold or via a reboot. System Preferences panes are sometimes unavailable for a period of time after the re-start, but they eventually work. I'm guessing that is due to the age of the machine. It is maxed out in RAM and has plenty of hard disk space, but it's still a seven year-old machine running a modern OS. I do have some software titles that have problems due to the new SIP settings to protect from malware, but I'm going to upgrade or change them out so I can use this new feature for protection.


    I am pleased for the most part with El Capitan on this Mac and I thank Apple for keeping this computer current in terms of the OS for so long. The machine works well considering its age. It was retired as my daily driver for a machine about a year ago, but an unfortunate accident with coffee has rendered its replacement out of service until I can get together the money to get it fixed. I pressed the machine back into service and it has responded well to its ramp-up in usage.


    Thanks to all who have given suggestions and assistance with this matter. I appreciate the Apple community for their commitment to helping each other with problems.

    Oct 8, 2015 7:17 AM

    Reply Helpful (1)

    Oct 18, 2015 11:14 AM in response to David Biddix In response to David Biddix

    David,


    I had the same problem today with Systems Preference after migrating to El Capitan. My steps were similar to the ones below, except that I have checked the 32 bit flag, close the systems preference, open it again, unchecked the box, close again, and on the 3rd time it worked, i.e. panes appearing:


    • In the Finder, press the key combination shift-command-A to open the Applications folder.
    • Select the System Preferences icon in that folder and press the key combination command-I to open the Info window.
    • There’s a checkbox in the Info window labeled Open in 32-bit mode. Uncheck it, if checked. Close the Info window and the Applications folder.
    • SO MAYBE DOING IN 3 TIMES, whatever was holding in, was deleted. System working ok now

    Oct 18, 2015 11:14 AM

    Reply Helpful (4)

    Oct 19, 2015 11:41 AM in response to David Biddix In response to David Biddix

    Thanks for the 32-bit idea. The computer seems to have settled down somewhat with El Capitan, so I'm just watching things closely now to see where I'm still having problems with the upgrade, but for now, things seem to be running OK on this old, old MacBook Pro.

    Oct 19, 2015 11:41 AM

    Reply Helpful

    Oct 19, 2015 4:27 PM in response to David Biddix In response to David Biddix

    David,


    I found a new bug today. The mail app is not working properly. It downloads the messages from my gmail and yahoo accounts but it is not possible to send any messages. It was working properly before the migration. The app says the box with SMTP info is not filled. Well, gmail is IMAP type and I had never experienced this bug.


    Also I have experienced some "frozen periods" today. I am not sure if this is caused by iCloud drive uploading. If it is, there is no info this is happening.


    cheers,

    Abe

    Oct 19, 2015 4:27 PM

    Reply Helpful

    Nov 10, 2015 5:45 PM in response to David Biddix In response to David Biddix

    i am also having problems with System Preference panes that will not load or if they load, freeze (Network, especially), so that the only solution is to force quit. I have tried rebooting into safe mode, tested different profiles so know it is a system issue not just me as a user. I have upgraded to El Capitan (sorry, no back-up before but do have Time machine back ups). I tried the 32 bit alternative for System Preferences more than three times -no joy. I am looking for any ideas to unfreeze, as multiple reboots have also done nothing at all. If I have a network problem, I am stuffed, as I cannot access that area of Preferences at all and my ISP has consistency issues, so a problem in the network is a real possibility. Any newer ideas or experience that may help, please?

    Nov 10, 2015 5:45 PM

    Reply Helpful

    Feb 22, 2016 10:09 AM in response to Baldie 752 In response to Baldie 752

    Did you find a solution? I seem to be in a similar position to you. I finally upgraded to El Capitan from Mountain Lion on a 2012 MBP a couple of days ago and after everything appearing to go fine, I now have System Preferences stuck in the Network pane. I've tried most of the solutions listed above - deleting Cache files, deleting plists, Safe mode boot, checking for the 32-bit checkbox in Finder (it wasn't checked) - and nothing has made any difference. If I open System Preferences, it reopens in the Network pane and then locks up. I can't test a guest account as I can't get to the User accounts section to create one.

    Feb 22, 2016 10:09 AM

    Reply Helpful
    User profile for user: David Biddix

    Question: Can't open system preference panes after upgrading to El Capitan