1 2 Previous Next 17 Replies Latest reply: Nov 11, 2007 10:32 PM by cledezma
monikag Level 1 Level 1 (0 points)
Sometimes when I turn on my macbook the number lock button is lit up. When I try to turn off the num lock I find I can't type anything - the keys are all screwed up and the letters are typing numbers instead! I have to keep the num lock on in order to type normally!

Its the same with the caps button - Its lit up right now, but when I turn it off, it types in ALL CAPS... Its like the buttons are working in reverse!

This has happened a couple times before and then went away by itself.. Now its back again.. Does anyone know what is causing this??

MacBook 60gb   Mac OS X (10.4.8)  
  • 1. Re: NUM LOCK ON
    allnodcoms Level 1 Level 1 (10 points)
    Not the faintest idea... But it happens to me too, so at least you're not alone

    Danny
  • 2. Re: NUM LOCK ON
    CHdB Level 1 Level 1 (5 points)
    My MacBook has the same problem. In addition the keyboard-layout switches als follows.
    - When I start up the MacBook and the num lock light is dimmed (50% chance), every things is normal;
    - When I start up the MacBook and the num lock light is burning (or glowing) the keyboard layout at the the login dialogbox is US e.g. I have to type a ";" to get a "+". After login the keyboard layout switchtes to dutch as defined by me in the system preferences. However when the administrator password is asked (for a priviledged action) the keyboard turns out to be US again.
    Apart from this the MacBook works fine but the num lock light lights up like a harddisk activity light. When I put out the light by pressing the num lock key the keyboard turns to numeric mode. So its function is inverted.

    I tried a PRAM reset. This worked initially but after a week the "50%-chance inverted num lock" showed itself again. Repeating the PRAM-reset did not work.

    Found nothing to resolve the problem yet. I thing about contacting Apple but I don't like to do without the MacBook which does its job apart from this weird num lock.


    Macbook   Mac OS X (10.4.8)  
  • 3. Re: NUM LOCK ON
    pajama Level 1 Level 1 (0 points)
    Did anybody found a solution to this by chance?
    I have exactly the same problem and I don´t feel like returning my MacBook for this tiny error...

    In my case it always happens as follows:
    I do a software update, the system crashes eventually and after reboot the Num Lock function is inverted. After letting the MacBook go empty on battery the problem resolves itself sometimes. Sometimes I have to wait 20 times for it to resolve...
  • 4. Re: NUM LOCK ON
    Bob20005_uk Level 1 Level 1 (0 points)
    I also get this problem. It boots up with num lock lit up.
  • 5. Re: NUM LOCK ON
    CHdB Level 1 Level 1 (5 points)
    The num lock issue of my macbook is solved by an Apple Service centre. They changed the keyboard and top: a 100% solution as they said. They told me it is a known problem, although nog recognised by Apple.

    Before that Apple Technical Support tried to help to solve it as a software-problem, making me doing one action after the other. 1,5 hour of supporttime wasted. Ultimately they directed me to a local servicecentre to get a firmware reinstall. The service centre however did not take any notice of the case and ordered the replacement keyboard instantly.
  • 6. Re: NUM LOCK ON
    smlevi Level 1 Level 1 (30 points)
    Well, I am not an expert, but I have an idea of what may help it (and if it doesn't then it's good to do anyway). What I would try first is a disk repair permissions and disk repair. This can be found in the disk utility (in utilities, just spotlight "disk utility"). You click your hard drive in the side box, then you
    verify disk permissions
    repair disk permissions
    verify disk
    and if theres anything that needs to be repaired; repair disk.

    Hope that helps, if it doesn't, I would call apple care or bring it into the apple store.
  • 7. Re: NUM LOCK ON
    Irwin Level 1 Level 1 (95 points)
    I get exactly the same symptom after turning on the Keyboard & Mouse "Use the F1-F12 keys to control software features" checkbox.

    I discovered this after a few hours of setting up a new MBP, the screen saver kicked in, and my password couldn't be entered as it uses some of the keypad letters. The same effect as turning on num-lock.

    Fortunately rebooting clears up the conflict and my password is accepted. I'll be calling Apple tomorrow.
  • 8. Re: NUM LOCK ON
    Irwin Level 1 Level 1 (95 points)
    Apple has confirmed this to be a software conflict. I'm hoping for a resolution soon...
  • 9. Re: NUM LOCK ON
    beerman Level 1 Level 1 (0 points)
    Any luck? I all of sudden have the same problem with my Powerbook 1.67GHz runnning 10.4.9. Both my num lock and caps lock come on when I boot up. I've tried zapping PRAM, but that didn't help. Went through every keyboard/universal access system preference - but to no avail.
  • 10. Re: NUM LOCK ON
    tele_player Level 5 Level 5 (5,380 points)
    Did you uncheck the "Use the F1-F12 keys to control software features" in keyboard prefs, as somebody mentioned above?
  • 11. Re: NUM LOCK ON
    beerman Level 1 Level 1 (0 points)
    Actually, after reading a dozen posts, I did uncheck the appropriate keyboard functions, force quit, zapped PRAM, and pulled the battery then held the power button for 10 seconds and it seems to have temporaily solved.

    I think I have some other issues and have scheduled some time to archive and completely rebuild this weekend.

    Thanks for your response.

    Greg
  • 12. Re: NUM LOCK ON
    rcmarcos Level 1 Level 1 (0 points)
    Anybody has any update on this issue? I've tried all of the recommendations in this page to no avail.

    Irwin: could you please point me to the page in which Apple confirms this issue as a software conflict?

    Thanks!
  • 13. Re: NUM LOCK ON
    loveanh Level 1 Level 1 (0 points)
    This just started happening to me tonight, really weird and frustrating because I can't type a darn thing. Good thing I have my iMac.

    When it turns on, the cap lock and the num lock are both lit then they turn off and the num lock won't turn on unless the cap lock is turned on. And I can't type at all, either it's blank or there are additional numbers or symbols added automatically when you type a letter. I made reservations for the Genius Bar tonmorrow, is this a wide known issue? I'm going to get really upset if they ask me whether liquid was spilled on the Macbook. Is that the first thing they are trained to ask? Had a problem with my iPhone and was asked the same question!!! Can't they just open the computer and see for themselves?
  • 14. Re: NUM LOCK ON
    daqieq Level 1 Level 1 (0 points)
    I just wanted to add that I was getting many of the same symptoms as the others here, but when I went to the Keyboard & Mouse preference panel, the "Use the F1-F12 keys to control software features" checkbox was unchecked. Checking it reversed all the symptoms I was previously seeing such as, not being able to type in my password correctly, not being able to type any text input, hitting the command key and being asked if I wanted to shutdown.

    I realize that this is counter to what some of you were describing, but it did solve my version of this problem. My USB keyboard and mouse certainly came in handy here, especially at the login screen!

    Oh, I also was not able to zap the pram or the open firmware while experiencing these problems, and repairing disk permissions did not work for me although I did read that it helped others with similar problems.

    Message was edited by: daqieq
1 2 Previous Next