Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Mail app opening by itself after installing El Capitan

Hello,


After installing OS X El Capitan (version 10.11) on both my iMac and MacBook Air, every time I wake or startup (even when not choosing to reopen apps while turning off the computer) my computers, the mail app (version 9.0) automatically opens. I don't care about my emails enough to check everyone and this is getting really annoying. I cannot find any way to make the mail app stop automatically opening after waking or starting up my computers. Is there anyway to make this stop? This never happened on OS X Yosemite. This is the only issue I'm having with El Capitan, so having this fixed would be great.

iMac, OS X El Capitan (10.11)

Posted on

Reply
Question marked as Helpful

Jan 20, 2016 7:11 PM in response to jonfromscottsdale In response to jonfromscottsdale

After much further investigation, I do not believe the Logitech Unifying receiver was causing Apple Mail to open automatically. The problem reappeared a few days later. None of the Login items in System Preferences Users & Groups or the Dock Options were set to automatically launch Mail. What I found was a setting in the Google calendar that was apparently opening Mail since the El Capitan upgrade.


Here are the steps I took to change the Google Calendar settings:

1. Open and login to Google Calendar (https://calendar.google.com)

2. Select the Setting gear icon (upper right-hand corner), then select "Setting" from the pull-down menu

3. Below the "Calendar Settings" header select the Calendars link

4. To the right of the calendar name under NOTIFICATIONS, select Edit notifications

5. There are five options in the section "Choose how you would like to be kept up-to-date:" - remove all of the checkmarks under the Email column

6. Click the "Save" button at the bottom of the page


Apparently these Email settings in Google Calendar cause Apple Mail to open in OS X. Also, my default Event notifications and All-day event notifications are set at "Pop-up" rather than "Email". I have not tested this a cause of Apple Mail opening by itself, but they were all set to "Pop-up" when Apple Mail was opening by itself before I unchecked the other Email options.

There’s more to the conversation

Read all replies

Jan 13, 2016 7:10 PM in response to MatthewK96 In response to MatthewK96

I had the same problem with the Apple Mail app opening by itself since upgrading to El Capitan. Using the Console app I believe I finally tracked the problem down to a Logitech wireless keyboard with the Unifying receiver plugged into the USB port. I tested this by placing my iMac to sleep then removed the Unifying Receiver from the USB port. A few hours later the computer opened by itself and displayed an error message that it was trying to locate a wireless keyboard, and the Mail app was open in the background. I no longer have the problem with the Apple Mail app opening on its own after removing the keyboard from the Unifying Software paring. This behavior does not seem to apply to the Logitech Unified mouse. The Logitech software does not seem to be compatible with El Capitan despite the version notes with the Unifying software, Options software and Logitech Control Center software.

Jan 13, 2016 7:10 PM

Reply Helpful

Jan 13, 2016 7:16 PM in response to MatthewK96 In response to MatthewK96

MatthewK96 wrote:


Hello,


After installing OS X El Capitan (version 10.11) on both my iMac and MacBook Air, every time I wake or startup (even when not choosing to reopen apps while turning off the computer) my computers, the mail app (version 9.0) automatically opens. I don't care about my emails enough to check everyone and this is getting really annoying. I cannot find any way to make the mail app stop automatically opening after waking or starting up my computers. Is there anyway to make this stop? This never happened on OS X Yosemite. This is the only issue I'm having with El Capitan, so having this fixed would be great.


Go to System Preferences --> Users & Groups. Click on your account name in the left-hand side, then click "Login Items." Do you see Mail there? If so, click it, then click the "-" at the bottom to remove it. When you shut down your computer, make sure to uncheck the box asking if you want previously opened windows/applications to reopen when you start it back up again.

Jan 13, 2016 7:16 PM

Reply Helpful
Question marked as Helpful

Jan 20, 2016 7:11 PM in response to jonfromscottsdale In response to jonfromscottsdale

After much further investigation, I do not believe the Logitech Unifying receiver was causing Apple Mail to open automatically. The problem reappeared a few days later. None of the Login items in System Preferences Users & Groups or the Dock Options were set to automatically launch Mail. What I found was a setting in the Google calendar that was apparently opening Mail since the El Capitan upgrade.


Here are the steps I took to change the Google Calendar settings:

1. Open and login to Google Calendar (https://calendar.google.com)

2. Select the Setting gear icon (upper right-hand corner), then select "Setting" from the pull-down menu

3. Below the "Calendar Settings" header select the Calendars link

4. To the right of the calendar name under NOTIFICATIONS, select Edit notifications

5. There are five options in the section "Choose how you would like to be kept up-to-date:" - remove all of the checkmarks under the Email column

6. Click the "Save" button at the bottom of the page


Apparently these Email settings in Google Calendar cause Apple Mail to open in OS X. Also, my default Event notifications and All-day event notifications are set at "Pop-up" rather than "Email". I have not tested this a cause of Apple Mail opening by itself, but they were all set to "Pop-up" when Apple Mail was opening by itself before I unchecked the other Email options.

Jan 20, 2016 7:11 PM

Reply Helpful (9)
User profile for user: MatthewK96

Question: Mail app opening by itself after installing El Capitan