6 Replies Latest reply: Nov 24, 2006 5:47 PM by Touch
Maler Hans Level 1 Level 1 (0 points)
Pages does show my typing very slowly and I'm not a very quick writer. Does anybody know a solution, that does not need to turn my whole system an other way? I thougth, making a dokument with graphics and several layout opinions is what Pages is made for - is'nt it?

Once I've been told, my machine beeing too week - now I got a CPU upgrade, but Pages does run very slow as well.

Please help!

lasslob@online.de

G4 Quicksilver, Mac OS X (10.4.8), new CPU 1,8 GHz Dual.Mac
  • FrankBe Level 4 Level 4 (1,605 points)
    Hello Hans,

    this was discussed a lot here in the forum and there appeared some reasons why that can happen (not on every Mac):

    1) Don't type while the zoom is on. Try to type at 100% document view size.
    2) If you are using inline objects (objects placed inside of text) try to work with contour text wrap, not with box wrap (the two image buttons at the bottom in the "Wrap" (Umbruch) inspector).
    3) Don't use PostScript fonts but TrueType fonts, and be sure all used fonts are okay. You can check fonts with the Fontbook (Schriftsammlung) located in your Applications (Programme) folder.

    Search for more in the forum and I am sure you will find a lot solutions. But not all solutions work for every Mac.

  • Magnus Lewan Level 4 Level 4 (3,655 points)
    Pages is slow on some people's machines, but for most of us, there is no problem. No one has a fool proof method of solving the problem, when it appears. These are some things people have found solved the problem. For some people, nothing has helped at all.

    1. Do you have any PostScript Fonts installed? Some people have reported problems with some PostScript Fonts.
    2. Do you have any missing fonts? When you open the document, does Pages complain that it cannot find one or several fonts?
    3. Do you have corrupt fonts? Open FontBook, select all fonts and then File > Validate Fonts.
    4. Corrupt pictures, songs and movies in your home folder's Movies, Music and Pictures folders can slow down the product through the Media Browser. AVI films in the Movie folder can slow things down, as QT usually cannot play them.
    5. Go to View > Hide > Layout. For some reason the layout slows things down.
    6. Don't view Thumbnails.
    7. Use the Text Fit option "follow contour" instead of "follow a square" in the bottom section of the wrap inspector.
    8. If an object is set to wrap, and a wrapped side squeezes out any possibility of text wrapping along that side - such as extending a text box to the margin, the extreme slowdown will occur. So don't.
    9. Use as few objects as possible Fixed on Page. Instead use Moves with Text.
    10. Reduce the resolution of your screen.
  • Skeskali Level 1 Level 1 (0 points)
    I'm sorry, but typing with zoom off to improve speed isn't a very good solution to this problem. I use Pages on a MacBook, and when I view a document at "actual size" the text is simply too small to see. What about those of us who need to be able to view a document larger, but who don't want to present our final document in large type?

    I'm trying to make the switch from Microsoft Word to Pages, and even under Rosetta, Word is more responsive than Pages.
  • FrankBe Level 4 Level 4 (1,605 points)
    Hello Skeskali,

    all the "solutions" you can read in this forum count for some users, but not all. I for instance, have no problems with Pages on my nearly seven years old G4 Sawtooth (upgraded to 1GHz) working on a 350+ page manual with 300+ images (most screen shots or vector illustrations). But most of my documents are brochures or flyers.

    Are you working with iWork'05? There is a remarkable speedbump (for me) from '05 to '06 and I bet in January 2007 we will see a '07 version of iWork with great enhancement in functionality and speed.

    So if you can wait a bit more, see what the next year will bring to you.

  • Brie Fly Level 5 Level 5 (7,925 points)
    If your document type is too small to read comfortably when zoomed to 100%, go to the Displays panel of System Preferences and choose a lower screen resolution for your display.
  • Touch Level 1 Level 1 (10 points)
    I am getting the same problem. Forget prcessor speed etc. ts got nothing to do with that. Pages just seems to lag behind typing. I have no idea why. Does anyone have a clue?

    (Don't talk about pictures, processors memory or iWork versions. The problem is simple: Just open a blank document and type - it is slow to appear on the screen. I am using all the lastest. Don't tell me I can do multitrack recording but my computer is too slow to type)