Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Spotify doesn't show up in Spotlight

I am running Mac os x 10.11.1

The bug was there already at Mac os x Yosemite


I have Spotify installed on my mac. But when I search for 'Spotify' in Spotlight, only system files will show up, not the Spotify application. So I have to manually start Spotify from the Dock (or from Launchpad). Is this a known bug?


I have now idea of what the problem is. Does someone have the same problem, or is it something wrong with my computer? Does someone have a fix that I can try? All other applications can be launched from Spotlight.User uploaded file

MacBook Air (13-inch, Early 2014), OS X El Capitan (10.11.1)

Posted on Nov 28, 2015 11:39 AM

Reply
Question marked as Solved
Answer:
Answer:

I was having the same problem for a while now, but I was too lazy to reset my Spotlight Index. You need to reset your Spotlight Index. Takes one minute total. Then 5 minutes to spotlight to reindex your file structures. Do it brah.

To reset your Mac’s Spotlight index, you can use Terminal-based approaches, but this adds complexity to a relatively easy way to rebuild your Spotlight index, which is to add your entire hard drive to Spotlight’s Privacy list, and then remove it:

  1. Go to System Preferences, Select Spotlight
  2. Go to the Privacy tab in the Spotlight system preferences
  3. Click the Plus button
  4. Press Shift-Command-C to reveal your hard drives (if they are not available otherwise), or simply navigate to your hard drive (most likely MacintoshHD)
  5. If you have more than one hard drive, hold the Command key and click your various drives to add them to your selection
  6. Click the “Choose” button to add them to the Privacy list
  7. Ignore the warning.
  8. Remove the hard drive by clicking the minus sign.
  9. Boom, no more sad days.

Props to http://www.macissues.com/2014/12/12/how-to-determine-when-your-spotlight-index-n eeds-to-be-rebuilt/ for the orginal solution.

Posted on Dec 6, 2015 11:42 PM

Question marked as Solved

Dec 6, 2015 11:42 PM in response to CMDJojo In response to CMDJojo

I was having the same problem for a while now, but I was too lazy to reset my Spotlight Index. You need to reset your Spotlight Index. Takes one minute total. Then 5 minutes to spotlight to reindex your file structures. Do it brah.

To reset your Mac’s Spotlight index, you can use Terminal-based approaches, but this adds complexity to a relatively easy way to rebuild your Spotlight index, which is to add your entire hard drive to Spotlight’s Privacy list, and then remove it:

  1. Go to System Preferences, Select Spotlight
  2. Go to the Privacy tab in the Spotlight system preferences
  3. Click the Plus button
  4. Press Shift-Command-C to reveal your hard drives (if they are not available otherwise), or simply navigate to your hard drive (most likely MacintoshHD)
  5. If you have more than one hard drive, hold the Command key and click your various drives to add them to your selection
  6. Click the “Choose” button to add them to the Privacy list
  7. Ignore the warning.
  8. Remove the hard drive by clicking the minus sign.
  9. Boom, no more sad days.

Props to http://www.macissues.com/2014/12/12/how-to-determine-when-your-spotlight-index-n eeds-to-be-rebuilt/ for the orginal solution.

Dec 6, 2015 11:42 PM

Reply Helpful (22)

Aug 11, 2017 6:40 AM in response to CMDJojo In response to CMDJojo

I had the same issue, but with Safari instead of Spotify. The chose solution didn't work, but this did:


  1. Go to System Preferences, Select Spotlight
  2. Go to the Privacy tab in the Spotlight system preferences
  3. Remove Applications check mark
  4. Close Spotlight Settings window
  5. Again, go to System Preferences, Select Spotlight
  6. Again, go to the Privacy tab in the Spotlight system preferences
  7. Select Applications again


User uploaded file

Aug 11, 2017 6:40 AM

Reply Helpful (2)
User profile for user: CMDJojo

Question: Spotify doesn't show up in Spotlight