1 2 Previous Next 18 Replies Latest reply: Nov 20, 2006 2:31 PM by intarwab
Bob Abbate Level 1 Level 1 (25 points)
Ran Software Update today and it asked me to install a Remote Desktop Client update. Ran the update, then tried to lauch Remote Update. Got the message "the Remote Desktop Administrator software does not match the installed Client software version". Dowloaded the Remote Update Admin update, and when I attempt to install I get a message that says "You cannot install Remote Desktop Admin Update on this volume. This update could not find Remote Desktop administrator program. Prior to these updates I was able to use Remote Desktop perfectly. Now I can't even open the application. Any ideas why?

PowerBook G4, Mac OS X (10.4.8)
  • 1. Re: Remote Desktop Update Problem
    MustardPlug Level 1 Level 1 (0 points)
    Sorry I can't offer any help other than to say I had exactly the same problem today.

    I further compounded my trouble by trying to un-install ARD 3.0. Now when I try to re-install 3.0 it says "a newer version of this package is already installed" yet when I try to run the 3.1 update it tells me it can't find the administrator program.

    I'm stuck in a loop. Any help on this issue would be greatly appreciated!
  • 2. Re: Remote Desktop Update Problem
    showsley Level 1 Level 1 (5 points)
    I had exactly the same problems with the Remote Desktop updater. Here's how I got it working:

    Disabled Remote Desktop: Uncheck Remote Desktop in System Preference -> Sharing Preferences

    Follow these Remote Desktop uninstall instructions:

    http://docs.info.apple.com/article.html?artnum=108021

    You DO need to go through EVERY step.

    Then I re-installed Remote Desktop from the Remote Desktop CD.

    When I launched Remote Desktop it failed with the identical message.

    So I re-installed the 3.1 updater. Now Remote Desktop 3.1 looks like it is working...

    iMac Core Duo   Mac OS X (10.4.8)  
  • 3. Re: Remote Desktop Update Problem
    Mark Haycock Level 1 Level 1 (10 points)
    I also had this problem and cured it by:

    (Go to bottom and see "Note 1:" first to see if you've done this then continue)

    Going to "System/Library/CoreServices" then made a copy and removed "RemoteManagement" folder which removes the ARDAgent 3.1.
    Then:
    Just to be on the safe went to "Library/StartupItems" then made a copy and removed "RemoteDesktopAgent"

    Restarted and re-installed ARD, updated ARD via "RemoteDesktopAdmin310.dmg".

    Everything works fine now.

    Note 1: Don't move ARD out of the Applications folder or into another folder in your Applications folder as the updater can't find it.
    Note 2: Client 3.1 is installed by default by 3.1 updater.

    Mark

    G5 Duel 2.3GHz, iMac 2.66GHz intel   Mac OS X (10.4.8)  
  • 4. Re: Remote Desktop Update Problem
    Bob Abbate Level 1 Level 1 (25 points)
    OK, I'm in need or "Terminal For Idiots" instruction. Turned off ARD in System Prefs. I deleted ARD applications, emptied the trash. I'm up to the point where I have to execute these commands in Terminal (http://docs.info.apple.com/article.html?artnum=108021). Terminal is a playground I've never played in before. How do I execute these commands? Where do I paste them? Do I paste them in line by line, or all at once? How will I know that the command "worked"?
    Thanks,
    Bob
  • 5. Re: Remote Desktop Update Problem
    Bob Abbate Level 1 Level 1 (25 points)
    Figured out how to run a command, ran the first line of the listed commands, this is what I see. Is this what I'm SUPPOSED to see?

    Last login: Fri Nov 17 10:41:41 on ttyp2
    $ rm -r ~/Library/Application\ Support/Remote\ Desktop/
    $ sudo rm -rf /var/db/RemoteManagement
    ; exit
    Welcome to Darwin!
    [Bob-Abbates-PowerBook-2:~] bobabbat% $ rm -r ~/Library/Application\ Support/Remote\ Desktop/
    tcsh: $: Command not found.
    [Bob-Abbates-PowerBook-2:~] bobabbat% $ sudo rm -rf /var/db/RemoteManagement
    tcsh: $: Command not found.
    [Bob-Abbates-PowerBook-2:~] bobabbat% ; exit
    logout
    [Process completed]












    PowerBook G4   Mac OS X (10.4.8)  
  • 6. Re: Remote Desktop Update Problem
    Lee Evans Level 1 Level 1 (0 points)
    Try it again without the '$' in front of each command - it should work for you then.

    Lee



       
  • 7. Re: Remote Desktop Update Problem
    Brian Nesse Level 4 Level 4 (2,780 points)
    My guess is that you didn't install the Remote Desktop Admin software into the Applications folder, or moved it after installation.

    I recall this being a problem with software update in the past.
  • 8. Re: Remote Desktop Update Problem
    showsley Level 1 Level 1 (5 points)
    I'm in need or "Terminal For Idiots" instruction.


    OK the $ represents the 'prompt' waiting for input when you open up the Terminal window.

    Copy the text AFTER the $ [one line at a time] and paste in the terminal window eg

    sudo rm -rf /var/db/RemoteManagement

    then hit Return after you have pasted each line

    [NB you'll be asked for your admin password]

    How will I know that the command "worked"?


    Actually there's no feedback if it worked just the $ prompt waiting for the next line to be pasted in.

    Didn't install the Remote Desktop Admin software into the Applications folder, or moved it after installation?


    No. Remote Dektop was in the Applications folder and never got moved. My guess is the updater just didn't get chance to finish up after other updates were downloaded.

    If that was the cause of the problem it might be worth running this Remote Desktop updater seperate from any other software updater.

    iMac Core Duo   Mac OS X (10.4.8)  
  • 9. Re: Remote Desktop Update Problem
    MarkPatterson Level 1 Level 1 (0 points)
    I had exactly the same problem. Fixed by:

    Checking existing ARD Admin application was in /Applications (I had to move it out of the AppleRemoteDesktop3 folder within /Applications).

    Downloading but not running ARD 3.1 Admin update.
    http://www.apple.com/support/downloads/

    Restarting machine.

    Running ARD 3.1 Admin update.




      Mac OS X (10.4.8)  
  • 10. Re: Remote Desktop Update Problem
    azdesertman Level 1 Level 1 (0 points)
    I had today the same problem. Called Apple. The support person told me that the updater would be missing the "original install receipt" and that I should re-install 3.0 first and then run the updater again. He also told me that I would not lose any of my settings by doing this.

    It worked. I could update to 3.1 and all of my settings were still there.

    azdesertman

      Mac OS X (10.4.8)  
  • 11. Re: Remote Desktop Update Problem
    gmolzar Level 1 Level 1 (0 points)
    I had just the same problem installing RD 3.1

    For my problem it was easy to resolve:
    I had the RD-Admin software placed in a subfolder in the applications folder.
    I just moved the application file one level higher in the application folder and the update for the admin file worked correctly (download the "RemoteDesktopAdmin310.dmg from the apple homepage).

    Good look for oll that have the same problem.
  • 12. Re: Remote Desktop Update Problem
    rebee Level 1 Level 1 (0 points)
    Thanks to the helpful hints here, I finally got ARD 3.0 reinstalled and this time I updated the ARD via Software updatses (as opposed to downloading and installing). It isn't working again! Guess I'll go through the steps again and re-install for the third time ARD 3.0 and forget about the update.
  • 13. Re: Remote Desktop Update Problem
    mechista Level 1 Level 1 (0 points)
    This was the EXACT problem. My ARD Program was not in the Utilitiesz folder. All I had to do was move it into Applications and run the update again and it worked just fine.

    All the other complicated solutions are not required.

    Thanks Brian!
  • 14. Re: Remote Desktop Update Problem
    lo_tech Level 1 Level 1 (55 points)
    Thanks Everyone, you really got me out of a hole! I am running 3.0 again, don't want to risk doing the upgrade again until I have the time to correct the potential problems.

    Thanks again for the help!
1 2 Previous Next