Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: How to change font size in Safari?

Why is it when I set my fonts inside Safari to say, 18 for standard and 18 for fixed. It doesn't display that way. I keep getting the tiny font that I've always used.

G4/1.4Ghz, Mac OS X (10.4.3), ATI Radeon Pro/1.2G RAM

Posted on

Reply
Question marked as Solved
Answer:
Answer:
Andy's recommendation to set the font in Safari preferences, Advanced tab should do the trick..setting it to 18 there however will render the look improperly i have mine set to 15 [ just highlight the second digit if your preferred is not there as an option] it appear perfectly.

In The Safari preferences, Appearance tab mine are set to standard 20 & fixed width-font 23. Large font; ) that i can go up to, using the [AA]bigger smaller buttons on the Safari toolbar.

Eme'~[)

Posted on

Question marked as Helpful

Dec 17, 2010 11:19 AM in response to R D Salinas In response to R D Salinas

Hi

One possibility is the setting in Safari-Preferences-Advanced tab "Universal access - never use font sizes smaller than...."

Failing that, Quit Safari and use the Finder to drag the file com.apple.safari.plist from Home/Library/Preferences/ to the desktop. If your font changes work ok now, then you can trash the file you moved. When Safari starts it will create a new 'default' preferences (plist) file. So you will need to re-do any changes you have made previously.

Question marked as Helpful

Dec 17, 2010 11:19 AM in response to R D Salinas In response to R D Salinas

The font size you specify in the Preferences (18 for standard) will be used only if the font size is not specified by the web page. Nowadays most of webpages (including this Discussions) specify fonts and sizes to use in the CSS file, and the setting in the Preferences will be ignored.

As andyBall writes, you can set the minimum size of fonts in Safari-Preferences-Advanced. But the results may not satisfy you (wrong line spacings etc.).

In the same Preferences, you can specify your own CSS file, as explained in the following post by Tom Gewecke:

Re: Setting default font size doesn't stick

But here again, line spacings etc. are not adjusted correctly. To write a detailed personal CSS file by yourself is very tedious, if not impossible.

As you might know, you can enlarge the fonts (and spacings) by hitting "command +" (press-hold the command key and hit the + key, or the = key; it seems you need not to press the shift key). I will be very pleased if someone tells me how to make this "enlarged" state the default.

PowerMac G4 Mac OS X (10.4.8)

There’s more to the conversation

Read all replies

Page content loaded

Question marked as Helpful

Dec 17, 2010 11:19 AM in response to R D Salinas In response to R D Salinas

Hi

One possibility is the setting in Safari-Preferences-Advanced tab "Universal access - never use font sizes smaller than...."

Failing that, Quit Safari and use the Finder to drag the file com.apple.safari.plist from Home/Library/Preferences/ to the desktop. If your font changes work ok now, then you can trash the file you moved. When Safari starts it will create a new 'default' preferences (plist) file. So you will need to re-do any changes you have made previously.

Dec 17, 2010 11:19 AM

Reply Helpful (1)
Question marked as Helpful

Dec 17, 2010 11:19 AM in response to R D Salinas In response to R D Salinas

The font size you specify in the Preferences (18 for standard) will be used only if the font size is not specified by the web page. Nowadays most of webpages (including this Discussions) specify fonts and sizes to use in the CSS file, and the setting in the Preferences will be ignored.

As andyBall writes, you can set the minimum size of fonts in Safari-Preferences-Advanced. But the results may not satisfy you (wrong line spacings etc.).

In the same Preferences, you can specify your own CSS file, as explained in the following post by Tom Gewecke:

Re: Setting default font size doesn't stick

But here again, line spacings etc. are not adjusted correctly. To write a detailed personal CSS file by yourself is very tedious, if not impossible.

As you might know, you can enlarge the fonts (and spacings) by hitting "command +" (press-hold the command key and hit the + key, or the = key; it seems you need not to press the shift key). I will be very pleased if someone tells me how to make this "enlarged" state the default.

PowerMac G4 Mac OS X (10.4.8)

Dec 17, 2010 11:19 AM

Reply Helpful (1)
Question marked as Solved

Dec 17, 2010 11:19 AM in response to R D Salinas In response to R D Salinas

Andy's recommendation to set the font in Safari preferences, Advanced tab should do the trick..setting it to 18 there however will render the look improperly i have mine set to 15 [ just highlight the second digit if your preferred is not there as an option] it appear perfectly.

In The Safari preferences, Appearance tab mine are set to standard 20 & fixed width-font 23. Large font; ) that i can go up to, using the [AA]bigger smaller buttons on the Safari toolbar.

Eme'~[)

Dec 17, 2010 11:19 AM

Reply Helpful

Dec 17, 2010 11:20 AM in response to R D Salinas In response to R D Salinas

Thanks everyone. That did the trick. I couldn't figure out how to set the "smaller than" to 15. It wasn't a choice. Until I did the "highlight the 2nd digit" trick.

CSS are nice. But they can be annoying too. I like the way the "command - +" works. That makes it perfect. But THAT never says...:(

Oh, well. This is sufficient.

Dec 17, 2010 11:20 AM

Reply Helpful
User profile for user: R D Salinas

Question: How to change font size in Safari?