Previous 1 2 3 Next 192 Replies Latest reply: Nov 11, 2008 5:12 PM by Lokesh Nara
George Haritonidis Level 1 Level 1 (0 points)
Hey everyone,

I have been experiencing some weird locking up/freezing/hanging when using my Core 2 Duo. The first couple of days after I got my MacBook Pro and after using the Migration Assistant I would get locking up -- the machine would go in a state where some functions are working (like the mouse, you could move it around) but everything else would not be available to use.

This meant that I could move my mouse around but can't click on any windows, any buttons, can't type anything in and the dock doesn't magnify, nor do its icons work. Since I can't click on the Apple menu to log out/restart/shut down, I have no option but to force a shut down by holding onto the power button.

This happened twice within 4 days of owning the machine, so I reformatted and moved everything over from my old PowerBook G4 manually -- reinstalled all my apps manually, copied my mail over manually, all my data over etc.

This freezing or whatever hasn't occurred until 15 mins ago, so there has been about 2 weeks between lock-ups. Up until now, I put the previous lock-ups down to something that perhaps was copied over from the PPC side of things over to the Intel side that the MBP C2D didn't like.

But now this is really weird. I can't remember what I was doing the first time the machine locked up, and I think I was command-tabbing through open apps the second time it happened and as I released the keys it froze then. The third time this happened (today), I was doing the same thing as the 2nd time.

When it did this today, I was listening to a podcast, and when the machine froze the podcast was still playing! So clearly half the machine is unresponsive, while some other parts of the OS and apps are still working. Unfortunately I didn't have Activity Monitor open during any of the locking up, so I can't see if there are any wayward applications.

Could this be a graphics problem? Maybe the drivers or the video card is a little dodgy? I sometimes get graphics corruption as well, either in Safari with the tabs showing up as black rectangles, or once when I woke up the machine from sleep the usual black background for the Username and Password dialog box was "coloured random static". I also sometimes get graphic rendering bugs in pages in Safari -- there would be a "line" missing from the browser screen, but scrolling up and down again usually corrects this.

This has never happened to me on my PowerBook G4, and find this rather odd. Anyone got any ideas? If anyone needs more information I'll be more than happy to provide.

15" MacBook Pro Core 2 Duo 2.16GHz, 15" PowerBook G4 1.67GHz, Mac OS X (10.4.8)
  • George Haritonidis Level 1 Level 1 (0 points)
    For the time being, after advice from a friend, I have enabled SSH in my firewall and I'll tap into it from another machine next time it hangs.
  • Adrift Level 1 Level 1 (110 points)
    I have this same problem on my MBP Core Duo. Everything just slows to a crawl, applications freeze, menu's stall, dock won't magnify. Mouse still works. Seems like it's busy doing something for many minutes on end. I used Migration assistant also, and haven't gone back and done a re-install manually except for running the 10.4.8 combo update again and trashing some Airport preferences.

    Sometimes I get frustrated and reboot, but most of the time I wait and it returns to normal. My TI powerbook feels faster than this thing.
  • infinite vortex Level 7 Level 7 (21,400 points)
    Without knowing exactly what software, especially system additions, that have been installed it's hard to say what could be causing your problems.

    Personally, I'd spend the time and effort in starting over again but this time do not install anything but the bare minimum of software. Then over time build up and you'll probably find your culprit somewhere.

    Otherwise, if you're not interested in doing this, you might have a look in your console and system logs using the Console utility and see df there's anything that stands out that's having a problem. You might be able to gleam information from there.
  • George Haritonidis Level 1 Level 1 (0 points)
    Hi Ned,

    Thanks for your reply. This machine is a work machine (I am a web developer) so I'd rather not reformat and start afresh with a minimal install.

    I had installed an extra 1GB of RAM about a week ago, but I doubt this is the culprit since it was locking up before the RAM addition.

    Originally I thought it could have been a Rosetta problem, since when I used the Migration Assistant it transferred some PPC-specific apps across, however I didn't have any PowerPC processes running the last time the machine locked up.

    I guess I'll have to wait until it happens again, SSH into the machine and 'top' to see if there are any wayward processes. The thing that is quite annoying is that this problem happens so few times and with large amounts of time between hangs, so it's not like I can bring the machine to an Apple store to get them to have a look, since it probably wouldn't hang!

    I'll keep everyone updated.
  • George Haritonidis Level 1 Level 1 (0 points)
    That's quite interesting Adrift. I don't think however, that my problem is exactly the same as yours. My applications are running fine, it just abruptly hangs sometimes (not very often).

    I can't say if the machine will "wake up" and start working again, I haven't had the machine running in this hung state for very long before I turn off the machine.
  • infinite vortex Level 7 Level 7 (21,400 points)
    Even though there are no apparent PPC processes running there's no reason to assume a PPC library isn't the cause of your problems. This is the problem with the Migration Assistant is that it sometimes replaces Intel libraries with PPC one which actually causes instability and problems. This is what I think your issue is. Unfortunately, there are few ways to identify this.

    I good scour of your system and console logs in the Console utility may help you.
  • George Haritonidis Level 1 Level 1 (0 points)
    Hi Ned,

    Fair call on the PPC library. I may have been a little confusing in my original post, I had formatted the machine and migrated things over manually (ie. just my data, all applications were reinstalled with Universal Binary versions, except for MS Office), yet the hanging still occurred.

    Examining the logs didn't show up anything interesting, in fact nothing was recorded in the system or console logs with the timestamp of when the hanging occurred.

    Thanks for your input.
  • George Haritonidis Level 1 Level 1 (0 points)
    Sorry, I forgot to say, since I had reformatted and reinstalled everything manually, surely a PPC library couldn't have been transferred over in the process? Or am I missing something fundamental here...?
  • infinite vortex Level 7 Level 7 (21,400 points)
    No, it's highly unlikely for PPC libraries to be causing issues if you manually migrate. While application installations can do this I haven't come across anything specific when installing them from the original installers.

    Have you notice any pattern at all to your problem?
  • George Haritonidis Level 1 Level 1 (0 points)
    Not really Ned, it seems to hang though as I said in my first post when I am command-tabbing through open apps and once the bezel fades out from screen it would lock up. This arouses my suspicion to something with video, however since it happens so randomly and so seldomly it is a very difficult problem to diagnose.

    I command-tab all the time, these keys are almost worn out on my keyboard! But it has only happened two or three times. Very odd.
  • infinite vortex Level 7 Level 7 (21,400 points)
    Probably what I would do from here it to document the issue as carefully as you can, everything you've done to date and all the things you tried. Once you have all that together contact AppleCare Australia and see what they can do for you.

    By documenting everything you both save time on the phone as they'll ask you to do stuff, most of which you would have done.

    By the way, have you tried resetting PRAM and the SMC?
  • Ian Searle Level 1 Level 1 (20 points)
    Not really Ned, it seems to hang though as I said in
    my first post when I am command-tabbing through open
    apps and once the bezel fades out from screen it
    would lock up. This arouses my suspicion to
    something with video, however since it happens so
    randomly and so seldomly it is a very difficult
    problem to diagnose.

    I command-tab all the time, these keys are almost
    worn out on my keyboard! But it has only happened
    two or three times. Very odd.


    Heh, I have been experiencing this EXACT problem for some months now. My MBP freezes most often when I cmd-tab too (I am a cmd-tab junkie). Likewise, the problem happens once every couple a weeks or so. But, there have been a few times where it happened repeatedly in the same day. Very frustrating cause it means a power-cycle and sometimes lost work. Here is a brief summary of what I and the MBP have been through to try and resolve this:

    - reset PMU
    - reset NVRAM
    - run Disk-Repair ad-nauseum
    - Apple replaced the MLB at which time I got a fresh install of Tiger. BTW, I've never used the migration assistant. I move stuff over manually.
    - I've been able to ssh into mine. But, don't see any processes consuming the CPU. I've noticed that if I kill windowserver I can login in again and everything seems to be OK. Though, this is nearly as destructive to applications as they are all children of windowserver.
    - I've never found anything incriminating in the logs. No panics or anything that hasn't been around/documented for a while.
    - I've run the hardware diagnostics in loop mode overnight. No problems identified.
    - I have 2GB of apple RAM (installed when I bought it).
    - I've been to the genius bar, and they sent it to the Apple repair center. They could not repeat the problem. Re-installed Tiger. No help.

    So, at this point I am trying to figure out a way to make the problem repeatable. If they can witness the problem at the repair-center they can fix it (theoretically). I'm also documenting every instance of freezing in the hope that will help me spot some common theme.

    MBP 2.0 GHz   Mac OS X (10.4.8)  
  • infinite vortex Level 7 Level 7 (21,400 points)
    Just wondering… do you have your issues when your RAm is fully saturated?
  • Ian Searle Level 1 Level 1 (20 points)
    No, i don't believe the RAM is fully saturated. I don't have measurements cause I haven't been able to ssh into my laptop every time. But, the times I have been able to ssh in, there is still unused memory left.

    I've written some simple programs that do use up all the RAM in an attempt to see if that condition would trigger the problem. But, it hasn't.

    My wild guess is that my usage somehow tickles a bug in windowserver that didn't exist on the PPC arch. I say that because I have experienced the same problem with two different MBP MLB and I never experienced this in 3 years of using two different powerbooks. But, that is a complete guess on my part.

    MBP 2.0GHz   Mac OS X (10.4.8)  
Previous 1 2 3 Next