Previous 1 2 3 4 Next 192 Replies Latest reply: Nov 11, 2008 5:12 PM by Lokesh Nara Go to original post
  • George Haritonidis Level 1 Level 1 (0 points)
    No, I have not tried resetting PRAM or SMC. I will do these first before documenting whatever I can and calling AppleCare.

    It could be weeks though before it happens again!

    Thanks for your help so far Ned.
  • George Haritonidis Level 1 Level 1 (0 points)
    OK this has just happened again about 15 minutes ago.

    I had a few apps open, and I was about to command-tab into another app when everything locked up again, just like how I first described it.

    I tried SSHing into my machine from another machine, nothing seems like its going haywire -- in fact some of the apps that would be taking up a percentage or two of CPU time was taking up 0% (probably because the machine was kind of frozen).

    I have just resetted the PRAM, so we'll see how we go. However, I have found something a little interesting in my logs in Console:

    Nov 29 20:10:20 Endoxius /Applications/jEdit 4.2/ removeDisplayMapping: _CGSUnmapFramebuffer returns -536870206

    This is just a sample of the error reported in system.log -- this error is repeated for every application that was in memory at the time, including loginwindow,,, (repeated many times, I assume once for each widget), iTunes, Mail, Safari, other apps, SystemUIServer, Little Snitch.prefPane, Salling Clicker.prefPane, even and Microsoft AU is the last app.

    All up there are 27 log records like this for this particular timestamp. Endoxius is the name of my machine. Anyone got any idea what _CGSUnmapFramebuffer is, and why it's returning -536870206?
  • Ian Searle Level 1 Level 1 (20 points)
    I see that log too when my MBP freezes up. I've googled that log message until I'm blue in the face and have found nothing helpful. Maybe someone in here will know what it means?

    MBP 2.0GHz    
  • infinite vortex Level 7 Level 7 (21,400 points)
    Would you happen to be using the SMCFanControl? If you are then uninstall it and see if the problem goes away.
  • Ian Searle Level 1 Level 1 (20 points)
    Nope, I am using FanControl. Also, I have been having this problem for a long time. Since June at least. Long before FanControl or SMCFanControl existed.

    MBP 2.0GHz    
  • nancygarden Level 1 Level 1 (10 points)
    i was reading this post and saw that you are using fan control, i had the same problems that you arre having and i read tha youi had the problem before you installe , btu just for giggles did you try a proper uninstall?? getting rid of all files including sleepwatcher?. that is what seems to be the problem, the if you still want a fancontrol i would reccommend
    it doesnt attach itself to anything, and doent create any lock up issues.

    the problem with the other fancontrol is that you have to perform three things
    killalldaemon...and they dont tell you the killall in their uninstall but thats the only way to get rid of it
  • Ian Searle Level 1 Level 1 (20 points)
    I'm a little confused. You responded to the guy who is using SMCFanControl. I am using FanControl (, but I stated that I had the problem before I ever began using it. Also, I looked around (source files and installed files) and did not see anything called sleepwatcher, so I'm not sure what you are referring to there. Lastly, both of us have a problem with the MBP freezing, usually during a cmd-tab operation. Again, not sure what sleepwatcher might have to do with this?

    MBP 2.0GHz    
  • nancygarden Level 1 Level 1 (10 points)
    i replied to both posts i guess, and i realize as i aid in my post , that you did have the problem before hand, just wondering if you still are using the program or just to see, get rid of it and see if it just might have been agrivating the problem.

    the original fancotrol was called fanspeed, and it had an attachment when you downloaded called sleepwatcher. it was a 2 part download, and that controls the the sleep mode for the computer, if you looked at the whole "sticky Post" with all the posts about both fanspeed which has the threshholds and attachs to files and smcfancontrol which just sits on desk top, you would see that many people had problems with their sleep modes and lock ups from fanspeed. and if you dont completly get rid of it, as it tends to hide in a few places, it still controls sleepmode.

    i was just making a suggestion, just happened upon this thread. sometimes for me the complicated problems are the easy ones to fix and the obvious issues tend to get overlooked while looking for deeper issues. (did that makes sense?)

    since your problem started before you downloaded this app, perhaps there was some other app that had something like sleepwatcher attached??
  • George Haritonidis Level 1 Level 1 (0 points)
    I'm even more confused. What is SMCFanControl? What is FanControl? What are the differences between the two? AFAIK, I have not installed any third party apps or drivers that control or throttle any fans in my MBP.

    I had downloaded CoreDuoTemp but only used it once and I set it to not start upon login. Does ths have to do with anything?

    I am quite confused.
  • nancygarden Level 1 Level 1 (10 points)
    if you have not installed any fan control apps then there is nothing to be confused about, this would not be your problem then, and i can offer no further help. i just know that there are problems with one of these apps that are exactly like the problems you are having, thats why i asked.
  • Ian Searle Level 1 Level 1 (20 points)
    Ah, OK, I understand now. Thanks for clarifying. So, yes, I have un-installed FanControl (last time it came back from Apple Repair center it has a fresh new Tiger image on it. I did not reinstall FanControl right away) and it made no difference. Which, is what I would expect as I haven't had any problem with sleep/wake cycles.

    Thanks for the suggestion. At this point, I am willing to entertain anything that makes sense. Unfortunately, I've already tried it.

    MBP 2.0GHz    
  • Ethanee Level 2 Level 2 (350 points)
    Sorry, dumb question , edited away...

    Okay instead I read somewhere that CGS = Core Graphics Services. Perhaps the hardware test doesn't test the graphics card fully?
  • Jensen Jun Level 1 Level 1 (25 points)
    it isn't weird... it happens on all Core Duo MBP too.
  • Ethanee Level 2 Level 2 (350 points)
    I did a grep for the error function _CGSUnmapFramebuffer, and the binaries that have this are in

    /System/Library/Frameworks/ApplicationServices.framework/Frameworks/CoreGraphics .framework
    /System/Library//Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ CoreGraphics.framework
    /System/Library//Frameworks/ApplicationServices.framework/Versions/Current/Frame works/CoreGraphics.framework/

    These directories are also found in the installation disks.

    1. If the hardware test doesn't signal a problem, perhaps the issue is with the libraries, maybe they're corrupted.

    2. A more general question is: is it possible to simply copy the files from the install disk into their corresponding location on the drive? Or is there some way to reinstall only certain parts of the OS X kernel?
  • Ian Searle Level 1 Level 1 (20 points)
    I suppose you could find the OSX package that contains these files, then remove it's receipt and then do a reinstall of just that package.

    Though, in my case, I have had 3 different installs of OSX, all fresh, all done by different people. With each install I have had the same problem. That, IMO, eliminates a corrupt library as a suspect. A buggy library is not ruled out however


Previous 1 2 3 4 Next