Previous 1 2 Next 20 Replies Latest reply: Nov 27, 2006 8:01 PM by themask
CNS Level 1 Level 1 (0 points)
Has anyone else seen this :-

I start to type a URL into Safari, which I viewed only the day before, yet it doesn't autocomplete. It does however, try to complete the URL with entries I made weeks or even months ago.

Why is this, and how can I get it to stop this bizarre behaviour ? I have tried the 'Empty cache' command, but this made no difference. In fact, the empty cache doesn't seem to remove old URL entries at all. Checking or unchecking the autofill options under Safari preferences also has no effect.

20" iMac Core Duo, Mac OS X (10.4.8)
  • Macbook91 Level 1 Level 1 (25 points)
    You may have the other day when you typed it you may have been privet browsing. And has this happend befor. You also should try unchecking it then reboating then rechecking it and reboot it and maby that will help. And also i have herd that some websites dont work with that not sure. I hope this helps.
  • themask Level 4 Level 4 (3,050 points)
    CNS,
    I think you are choosing the wrong command.

    When you visit a web page, Safari stores a copy of that page in the cache to make subsequent loads faster. "Empty Cache" resets that cache, not the history of URLs.
    Also, "Autofill" is about filling forms, not URLs.

    The command you want to use is "Clear History" in the History menu.

    For future reference, you can also use "Reset Safari..." (in the Safari menu) if you want to reset your history, your cache, your cookies, your download history, your Autofill entries and the history of Google searches in one shot.

    MacBook91, IMHO you don't have to reboot Macs that often, even when you troubleshoot issues.

    Hope this helps!
  • CNS Level 1 Level 1 (0 points)
    Tried both emptying cache and clearing history, but it makes no difference.

    If I start to enter a URL, it tries to complete the address with entries I made months ago, but not with URLs I entered only a few minutes ago.

    What's going on ?
    It seems to have stored browsing history from months ago, which can't be removed, yet it can't remember history from minutes ago.
    What a rubbish browser !
  • themask Level 4 Level 4 (3,050 points)
    CNS,
    don't get too frustrated. I have worked with software since 20 years ago, Unix, Windows and Mac, and I still have to find an application without bugs or quirks.

    Try deleting the History.plist file in your home folder/Library/Safari.

    Does that do the trick?
  • CNS Level 1 Level 1 (0 points)
    Tried that, no difference.
    It still has ancient autofill entries, but not recent ones.

    The question is, just where is it storing these entries ? Wherever it is, the file/folder is presumably full.

    Incidentally, just tried Firefox 2, and that works perfectly !
  • themask Level 4 Level 4 (3,050 points)
    CNS,
    I am really surprised. The place where Safari stores those entries is the History.plist file. Removing that should have taken care of the problem.

    Other things to try:
    1. Check your bookmarks list. If you bookmarked a site, autocomplete proposes its name when you type. If you find what you are looking for, just delete the bookmark(s) and you should be OK.
    2. "Reset Safari" from the Safari menu. Do note that it will clear everything (cookies, cache etc) except bookmarks.

    I was going to mention other browsers like Firefox, Camino or Opera as a last resort. Glad you found out about it yourself.

    Please post back, I am curious now!
  • CNS Level 1 Level 1 (0 points)
    Some of the URLs it suggests as I type are not in my bookmarks, even though history plist has been removed.

    There must be some hidden history store !
  • CNS Level 1 Level 1 (0 points)
    Just tried reseting Safari, still get the problem !

    It suggests URLs that are not in my bookmarks, and ones that I don't remember ever visiting !!
  • themask Level 4 Level 4 (3,050 points)
    CNS,
    can you post some of the URLs in question?
  • CNS Level 1 Level 1 (0 points)
    It happens with any new URL.

    If I type in a new address today, it will have forgotten it by tomorrow.
  • themask Level 4 Level 4 (3,050 points)
    CNS,
    that is not what I meant. I wanted to know some of the old URLs that Safari remembers from months ago.
    Although, what you just say makes me wonder if there is a problem with permissions of the History.plist file.
    Try repairing permissions. Open Disk Utility (in Applications, Utility), select the main hard drive on the left pane, then the First Aid tab, and select Repair permissions.
    Let's see what happens. And don't forget to post some of the old URLs.
  • David Amies Level 2 Level 2 (265 points)
    I, too, am having Safari autofill problems.

    I have reset Safari, removed the plist fronm the library but I cannot get Safari to autofill forms on the web in my main account. It will however do so on other accounts on the same computer.

    What is going on?

    By the way, I have been using my new iMac for about six weeks and am becoming less and less impresseed by the day. What a buggy and slow machine. It may be heretical to say this but it reminds of the wWindows PCs I used at the University before I retired three months ago. My PowerBook is much more responsive and faster than this large, pretty but Oh! so frustrating machine.

    I just wonder if there is something inherently malign about Intel processors!

    David Amies
  • themask Level 4 Level 4 (3,050 points)
    David,
    for the records, your problem is with Autofill; CNS's is with Autocomplete (despite the title). Two different issues.

    In your case, I would first try checking Safari-Preferences-Autofill and make sure that everything is checked. If that doesn't work, I suggest you open a new, separate post. You are more likely to get help that way.
  • David Amies Level 2 Level 2 (265 points)
    Thank you for your reply but I am not sure that I understand you.

    What is CNS? And what is Autocomplete?

    What I do know is that I am now using my PowerBook and as soon as I go to Safari Preferences and click on the Autofill tab and then on the Edit button, my Address Card comes into view at once and I can make changes. On the iMac nothing happens.

    As I said it is long on looks but short on utility!

    Many thanks, anyway.

    David Amies
Previous 1 2 Next