Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: iPhone connects to wifi but won't connect to internet

I have an iPhone 6s running iOS 9.3.2 (latest update).

The phone will connect to the wifi network but even though it is showing good signal strength, the phone will not load any internet content (weather, FaceBook, email, etc). If I disconnect from wifi and use data it works fine. We have no problem connecting the computer or smart TVs to the wifi network and connecting to the internet.

This is also happening with my daughter's iPhone 5s and with my son's iPad.


Sometimes it will be working fine on wifi and then a little while later I can't get anything to load. And it can be like right now when I am the only one home so it's not like there is a big load on our wifi.


We have high speed cable internet (25 Mbps download speed) and a Lynksys EA3500 router. The encryption is set to WPA (not WEP).


I have tried to go into my phone settings and reset the network. Still having problems.


This is really frustrating because we end up switching to our cellular data and using that instead of our "free" wifi data. And then going over our data on our phone plan 😟





iPhone 6s, iOS 9.3.2

Posted on

Reply
Question marked as Helpful

Jun 14, 2016 9:48 AM in response to dlinglis In response to dlinglis

Below is a User Tip about Wi-Fi issues. Suggest starting from the top and working down. Maybe one of them will help.


1) Perform a Forced Restart: Hold down the Home and Wake/Sleep buttons at the same time for about 15-20 seconds until the Apple logo appears. Allow device to restart.

2) Reset Network Settings: Settings > General > Reset > Reset Network Settings. Rejoin the Network again.

3) Reboot Router/Modem: Unplug from power for 2 minutes and plug again. Update Router Firmware (check manufacturer’s support website for a newer FW). Also try different bands (2.4 GHz and 5 GHz) and different bandwidths (20 MHz recommended for the 2.4 band).

4) Change to Google's DNS: Settings > Wi-Fi > Click on the Network, Delete all numbers under DNS and enter 8.8.8.8 or alternatively 8.8.4.4

5) Disable device prioritization on the router if this feature is available. Also disable any VPN apps and test Wi-Fi again.

6) Determine if other Wi-Fi devices on network are working well (other iOS devices, Macs, PCs).

7) Try device at another Network, i.e., neighbors’, public coffee house, etc.

8) Backup and Restore the Device using iTunes (ask for additional for details if desired).

https://support.apple.com/en-us/HT201252

9) Go to an Apple Store for hardware evaluation.


User Tip: https://discussions.apple.com/docs/DOC-9892

Question marked as Helpful

Jun 14, 2016 9:48 AM in response to dlinglis In response to dlinglis

Hi.

If a network resetting doesn't help, you can try to switch on Airplane mode: temporarily switch on Airplane mode and then turn it off to see if the Wi-Fi issues be solved. Swipe up from the bottom to bring the Control Center > Toggle Airplane mode on for 10 seconds > Toggle it to off.


This step can also help you: disable Wi-Fi Networking in System Service:

Go to Settings, choose Privacy, tap Location Services, tap System Services, turn off Wi-Fi Networking. This does not turn off wireless networking in iOS entirely, only relates to your location being used for Wi-Fi Networking.


As a final step:

Change DNS Settings to Google: Settings > Wi-Fi > Tap on the (I) button to the right of the router name, then scroll down to DNS and tap the numbers, then enter "8.8.8.8".

There’s more to the conversation

Read all replies
Question marked as Helpful

Jun 14, 2016 9:48 AM in response to dlinglis In response to dlinglis

Below is a User Tip about Wi-Fi issues. Suggest starting from the top and working down. Maybe one of them will help.


1) Perform a Forced Restart: Hold down the Home and Wake/Sleep buttons at the same time for about 15-20 seconds until the Apple logo appears. Allow device to restart.

2) Reset Network Settings: Settings > General > Reset > Reset Network Settings. Rejoin the Network again.

3) Reboot Router/Modem: Unplug from power for 2 minutes and plug again. Update Router Firmware (check manufacturer’s support website for a newer FW). Also try different bands (2.4 GHz and 5 GHz) and different bandwidths (20 MHz recommended for the 2.4 band).

4) Change to Google's DNS: Settings > Wi-Fi > Click on the Network, Delete all numbers under DNS and enter 8.8.8.8 or alternatively 8.8.4.4

5) Disable device prioritization on the router if this feature is available. Also disable any VPN apps and test Wi-Fi again.

6) Determine if other Wi-Fi devices on network are working well (other iOS devices, Macs, PCs).

7) Try device at another Network, i.e., neighbors’, public coffee house, etc.

8) Backup and Restore the Device using iTunes (ask for additional for details if desired).

https://support.apple.com/en-us/HT201252

9) Go to an Apple Store for hardware evaluation.


User Tip: https://discussions.apple.com/docs/DOC-9892

Jun 14, 2016 9:48 AM

Reply Helpful (3)
Question marked as Helpful

Jun 14, 2016 9:48 AM in response to dlinglis In response to dlinglis

Hi.

If a network resetting doesn't help, you can try to switch on Airplane mode: temporarily switch on Airplane mode and then turn it off to see if the Wi-Fi issues be solved. Swipe up from the bottom to bring the Control Center > Toggle Airplane mode on for 10 seconds > Toggle it to off.


This step can also help you: disable Wi-Fi Networking in System Service:

Go to Settings, choose Privacy, tap Location Services, tap System Services, turn off Wi-Fi Networking. This does not turn off wireless networking in iOS entirely, only relates to your location being used for Wi-Fi Networking.


As a final step:

Change DNS Settings to Google: Settings > Wi-Fi > Tap on the (I) button to the right of the router name, then scroll down to DNS and tap the numbers, then enter "8.8.8.8".

Jun 14, 2016 9:48 AM

Reply Helpful (3)

Jun 14, 2016 2:08 PM in response to D.Cohen In response to D.Cohen

Hi there, I just wanted to congratulate you on making it to level 6! 🙂


We have started a virtual party in your honour over in the level 6+ lounge. This link should get you there once the bouncers have been handed your name by the management. See you there soon.


tt2

Jun 14, 2016 2:08 PM

Reply Helpful
User profile for user: dlinglis

Question: iPhone connects to wifi but won't connect to internet