Announcement: Update to iOS 12

Enjoy a faster and more responsive experience as well as fun new features, like Memoji and Camera Effects.
Get iOS 12 > https://support.apple.com/ios/update

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Unable to Install Update - iOS 9.3.5

I am having problems updating my iPad Air 32Gb


It is running iOS 9.3.3 and would not update to iOS 9.3.4. Now it won't update to 9.3.5 either.


When I tried to update to 9.3.4, I received messages saying that the verification of the update had failed. For 9.3.5, it just says "An error occurred installing iOS 9.3.5" but doesn't specify what.


For for both updates, I deleted the downloaded update files and redownloaded them multiple times, to no avail. It won't update via iTunes either. The only advice I can see anywhere about these problems are to 1) download the update again - done and failed. 2) refresh or restart the device - done and failed. 3) update via iTunes - won't work either.


I have several GB of free space and the problem occurs even when fully charged and whether plugged in or not.


My iPhone updated fine, apart from some glitches (with contacts and app crashing) that seemed to resolve themselves. I understand these updates are important security ones, so am keen to get it sorted out.


I would appreciate any ideas. Other than suggestions to do what I already have done!


Thanks.

iPad Air Wi-Fi, iOS 9.3.3

Posted on

Reply

There’s more to the conversation

Read all replies

Page content loaded

Sep 14, 2016 2:34 AM in response to sgshields In response to sgshields

Exactly the same problem is happening with iOS 10. Having no indication whatsoever what the problem is is not helpful.

Sep 14, 2016 2:34 AM

Reply Helpful (1)

Sep 14, 2016 5:59 AM in response to lpsandaruwan In response to lpsandaruwan

After reinstalling the Apple Mobile Device Driver in Windows and updating iTunes, it finally detected my iPad and completed the install. I feel bad for those without a computer as there doesn't seem to be any fix for those without one.


The installer must know what the problem is and is seems just lazy not to enable it to give an error code or explanation to users.


Happy I solved my issue, but hope a more effective solution that works without needing to connect to a computer is found.

Sep 14, 2016 5:59 AM

Reply Helpful
Question marked as Helpful

Sep 19, 2016 1:51 PM in response to sgshields In response to sgshields

Who writes software that fails without any sort of information as the source of the error. Even a cryptic error message would be better than this nonsense. For a company that used to pride itself on the quality of its software, this is a sad state of affairs .

Sep 19, 2016 1:51 PM

Reply Helpful (2)

Sep 19, 2016 2:59 PM in response to sgshields In response to sgshields

Apparently, my last comment was inappropriate. So, I'll try to be super-civil.

Thanks for the replies.

Just so that other users can use their time efficiently, I would point out that whether or not iOS 9.3.5 is currently available or not isn't relevant to to my query and and doesn't seem to be relevant to the other comment about having the same issue.

I was able to solve the problem with my iPad's iOS update (which I note was to iOS 10.0.1 in the end), by updating the Apple Mobile Device Driver in Windows 10 and installing via iTunes. In the original listing for the device in the System control panel, it stated that it was something different, I think it was 'Apple USB device/controller'.

What would be helpful to those of us who don't have computers is if anyone has any tips other than the 'restart, delete and redownload update, install via iTunes and check battery/storage levels' (that didnt work for me or some of the other people who noted they are struggling), it would be wonderful if they could share them.


If my comment is unhelpful, I personally will not take offence at someone pointing that out in a non-abusive manner. Indeed, it is only by knowing when I get something wrong that I can stop making the same mistakes.

Sep 19, 2016 2:59 PM

Reply Helpful

Sep 19, 2016 3:32 PM in response to Briansyddall In response to Briansyddall

iOS 10.1 doesn't exist yet (not as a public download anyway).


Thanks for the suggested fix, but I explained that I have now resolved my issue.


The proposed solution would not have worked though - as I mentioned, I was able to download the update directly (and note that I had done a backup), but it wouldn't install. As I also mentioned, I was only able to install the update via iTunes and as I have now updated, don't need further instructions myself.


It may be helpful to other users however if someone has tips on how to solve the problem I experienced without using a PC/Mac to share them. For example, if there is an error log somewhere that might have had useful info on the cause of the installation failure.


I won't be replying further on this thread as the last comments haven't been relevant to me.

Sep 19, 2016 3:32 PM

Reply Helpful

Sep 28, 2016 4:23 AM in response to mintsalad In response to mintsalad

mintsalad wrote:


There is no option to upgrade to 10 - the only message is the failure one. So it's Catch 22 with no sign of a fix.

After powering off (for a while... and on again) my iPad Air 2, the repetitive error, "An error occurred installing iOS 9.3.5" (currently on 9.3.4) has gone since iOS 9.3.5 no longer seems to be available (as MichelPM suggested above)!? Going into Settings > General I am offered to "Download and Install" iOS 10 - which I have not tried yet.


As already stated, very bad, meaningless error message on Apple's part!

Sep 28, 2016 4:23 AM

Reply Helpful

Oct 14, 2016 3:17 AM in response to sgshields In response to sgshields

I found the solution to this problem on this website: http://osxdaily.com/2015/09/23/fix-wrong-ios-software-update-version-showing/


Basically, go to:

Settings --> General --> Storage & iCloud Usage --> Manage Storage (in storage section, not iCloud section) --> delete existing update file --> turn on airplane mode --> close settings via 'swipe up' after double tap --> turn off airplane mode --> go back to updates and a new update file is found


Turns out the old update file was changed and is therefore not available anymore and this seems to confuse the system. Re-download and install should sort out the problem without the need for a computer.

Oct 14, 2016 3:17 AM

Reply Helpful (4)

Oct 14, 2016 5:09 AM in response to amadferret78 In response to amadferret78

Thanks for the reply, but this isn't relevant to the specific issue I raised.


As I noted, in my case deleting and downloading the file again did *not* help. This was stated very clearly in my original post and I asked for *different* solutions to those I had already tried.


I had said that I wouldn't reply further but felt I had to as once again, a suggested solution has been posted that appears to ignore what I stated in my query. Redownloading the update file would be a helpful suggestion for someone who hasn't tried that. Suggesting it to someone who has stated that they have tried that already is not helpful. I have no reason to believe the reply was meant to be unhelpful, so please take this response as constructive criticism aimed at all of us as something to learn from, not a personal attack.


What is valid to suggest is that future update files may not have the same problem, so it is worth trying the 'delete update file and redownload' solution when new versions of iOS are released.


As I get an email each time a reply is added, I implore other users of the forum to read what has already been said before posting further replies that aren't relevant to this specific situation - namely, that updates fail and all suggested solutions fail (other than in my case updating via iTunes). It still seems that there is no solution for those who don't have a PC/Mac, so please do add a comment if you have a *different* solution to suggest.


I hope this message does not come across as being a 'rant', I am merely trying to prevent the time of other users and me being wasted and unnecessary annoyance being caused.

Oct 14, 2016 5:09 AM

Reply Helpful
User profile for user: sgshields

Question: Unable to Install Update - iOS 9.3.5