Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: 4 finger swipe does not work in macOS Sierra!!

Hey all, I upgraded to macOS Sierra and noticed that one of my most regularly used feature on Mac OS, 4 finger swipe, for switching between desktops is not working! Mine is a April 2011 MacBook Pro.


Earlier, 2 finger swiping back and forth in folders, similar to switching back and forward for webpages in Safari, was discontinued for no fathomable reason. I hope it's not the same fate for 4 finger swipe for switching between desktops.


I probably use it hundreds of times every single day for switching between desktops since I have safari, MS Word and Mail apart from iTunes open on separate desktops. I hope a fix is released soon!


Apple, don't bite away useful features!!



Ravi Reddy

MacBook Pro, OS X Yosemite (10.10), Early 2011 MacBook Pro

Posted on Sep 22, 2016 7:31 AM

Reply
Question marked as Helpful

Sep 26, 2016 2:27 AM in response to Ravi Reddy In response to Ravi Reddy

Inspired by LuisMataPop's comment, I finally found a solution (at least it works for me). In the System Preferences, trackpad options, I set the "Change between full screen apps" button to "4 finger swipe" (the other choice being a three finger swipe). That re-enabled the 4 finger swipe between desktops (not just full screen apps). However, it also disabled the possibility to select text with 3 fingers. In order to re-enable that, I had to go to the Accessibilty panel, Mouse and trackpad options, further click on "Trackpad options" and choose the 3 finger selection there.


Apple, please fix this in 10.12.1 !


(My system is not in English, so I may have mistranslated the names of some buttons.)

Sep 26, 2016 2:27 AM

There’s more to the conversation

Read all replies

Sep 23, 2016 1:02 AM in response to Ravi Reddy In response to Ravi Reddy

I have the same problem as Ravi. I tried 3 finger swipe as well, it doesn't work. Also, no switching between full screen apps.


In System Preferences, the 4 finger swipe does not show up on the Trackpad control panel. Neither in the Accessibility options.


The funny thing is, last night the 4 finger swipe suddenly worked again for an hour or so! But now it's gone again. Very strange. The problem started after upgrading to Sierra.

Sep 23, 2016 1:02 AM

Reply Helpful
Question marked as Helpful

Sep 26, 2016 2:27 AM in response to Ravi Reddy In response to Ravi Reddy

Inspired by LuisMataPop's comment, I finally found a solution (at least it works for me). In the System Preferences, trackpad options, I set the "Change between full screen apps" button to "4 finger swipe" (the other choice being a three finger swipe). That re-enabled the 4 finger swipe between desktops (not just full screen apps). However, it also disabled the possibility to select text with 3 fingers. In order to re-enable that, I had to go to the Accessibilty panel, Mouse and trackpad options, further click on "Trackpad options" and choose the 3 finger selection there.


Apple, please fix this in 10.12.1 !


(My system is not in English, so I may have mistranslated the names of some buttons.)

Sep 26, 2016 2:27 AM

Reply Helpful (9)

Sep 26, 2016 7:49 AM in response to Ravi Reddy In response to Ravi Reddy

I found another iteration of this bug (and others). Using Microsoft Remote Desktop for Mac on a MBPr connecting to a Windows 10 PC. Previously on both Yosemite and El Capitain I had each Display as a Separate Space and would connect in full screen. I have three external monitors and Microsoft RDP would be full screen on all four (including the MBPr screen). Each display had it's own space so I could swipe left/right with 3 (or 4) fingers to swap between my native OSX/macOS.


This functionality was amazing. It was much better than running Fusion, more seamless, faster response, everything was amazing. Was.


Unfortunately, after upgrading to macOS Sierra I can no longer produce this same workflow. If I have each display in it's own space, Microsoft Remote Desktop does not recognize the other displays and only shows up on my MBPr screen (which because of Microsoft's Windows 10 Anniversary Update the resolution is skewed horribly). If I disable each display having it's own space, the swipe left/right affects the entire virtual Desktop making it all or none.


Before, I could have 3 monitors showing Windows applications and 1 showing my Mac apps, or 2 and 2, or 3 mac 1 windows, and 0/4 or 4/0, whichever I wanted, it worked. It made my life coexisting between two platforms amazing. Using Cloud Storage I was able to keep my file system in sync and it was like having one amazing super computer (the Windows PC is my lab system running VMware Workstation, has 32gb of RAM, quad proc, dual RAID1 SSD, the works.


Unfortunately I think the issue resides on both the changes to macOS Sierra (for the spaces and swipe left/right issue) and the Microsoft Anniversary update (for the skewed resolution showing up as 1440x900 as opposed to the MBPr resolution, wether scaling is enabled or disabled). I am just hoping this gets resolved sooner than later so I don't have to keep jumping through hoops to get my work done.

Sep 26, 2016 7:49 AM

Reply Helpful

Sep 26, 2016 8:13 AM in response to Ravi Reddy In response to Ravi Reddy

GUYS, the suggestion of LouisMataPop worked for me - I disabled the option in setting and to be sure restarted the system once and enabled the 4 finger swipe option and voila! the 4 finger swipe started working again. Can't tell how much of a headache it was switching between active desktops without 4 finger swipe!!


Thanks for the input guys!


Ravi Reddy

Sep 26, 2016 8:13 AM

Reply Helpful (1)

Sep 27, 2016 12:39 PM in response to Ravi Reddy In response to Ravi Reddy

Something similar here . Not trackpad but via mouse two fingered swip to scroll through desktops results in my iMac reverting to its login page. In fact, the machine resets losing data. I've disabled or deleted the other desktops and the machine seems stable now.

Sep 27, 2016 12:39 PM

Reply Helpful

Sep 29, 2016 1:06 PM in response to LuisMataPop In response to LuisMataPop

Signed in just to say thank you. I was soooo bummed when this feature stopped working and there did not appear to be the appropriate settings to fix it.


you disable and then re-enable 4 finger swipe for full-screen apps on trackpad options the function is restored

Sep 29, 2016 1:06 PM

Reply Helpful (1)
User profile for user: Ravi Reddy

Question: 4 finger swipe does not work in macOS Sierra!!