12 Replies Latest reply: Jul 6, 2007 10:58 AM by J_Oliver
daves-fl Level 1 Level 1 (0 points)
I find my Safari refuses to now open any site with "https" in the URL. Anyone else experience this problem or have an idea how to repair it? Thanks in advance. Currently using Safari v2.0 in this eMac.

eMac 800mhz; 768mb RAM; 160GB Seagate to spin the tunes, Mac OS X (10.4.6)
  • Hawaiian_Starman Level 7 Level 7 (21,405 points)
    Do you have any 3rd party firewall program in your system such as NetBarrier?

    If not, have you contacted your Internet Provider about the problem?
  • 28Clipper Level 1 Level 1 (5 points)
    I find my Safari refuses to now open any site with
    "https" in the URL. Anyone else experience this
    problem or have an idea how to repair it? Thanks in
    advance. Currently using Safari v2.0 in this eMac.


    Amazingly enough I spent 4-6 weeks trying to solve exactly the same problem. Short answer bottom line: extension conflicts were occurring within the system somewhere. Since figuring THAT out is very very difficult, I did an Archive and Install. Voila! The HTTPS problem was totally totally gone. Nothing at all bad happened. Had to reload some apps. I just did this, so am still feeling thrilled.

    In my case Safari worked PERFECTLY in every other respect. Also, there were no problems with my system and apps. So I was very reluctant to do the Archive and Install—seemed like terrible overkill. Well, it wasn't. Of the many many things I tried . . . only that solved it. If this were to come up again in the future, for sure I would IMMEDIATELY do an Archive and Install. The procedure is straightforward but somewhat tedious. But not at all tedious compared to the time I wasted on every other possibility.

    If you're not familiar with Archive and install, be sure to look up how it works. Especially be sure to back up your important files, if not your entire machine before proceeding.

    Did this do you any good—or have you fixed the problem by now?



    G5 iMac 20" 2.0Ghz (2nd gen, non-Intel)   Mac OS X (10.4.8)   2GB RAM

    G5 iMac 20" 2.0Ghz (2nd gen, non-Intel)   Mac OS X (10.4.8)   2GB RAM
  • Eme Level 5 Level 5 (5,635 points)
    Hi Daves-fi,

    Do this Quit Safari, click on he Finder icon in your Dock
    Go to Home~Library/Preferences folder locate the com.apple.security.revocation.plistfile and move it to the trash.
    Do Not empty unless you you know this works.

    Launch Safari and try the site[s] if it doesn't help run disk permissions repair using the Disk Utility. If any errors are reported run it again & do a restart of your computer and try it again.

    Hope this helps and you have not yet done an A & I, please let me know; )

    Eme'~[ )
  • Steven W. Riggins Level 3 Level 3 (980 points)
    This solved many Safari/Omniweb/Mail issues. Thanks!
  • Eme Level 5 Level 5 (5,635 points)
    Hello Steven,

    This solved many Safari/Omniweb/Mail issues. Thanks!

    You are welcome ! I am happy to know it helped you get sorted. thanks very much for letting me/us know, I appreciate it : )

  • JessicaE Level 1 Level 1 (0 points)
    After much searching and reading, I have found an approach that solved this problem and another problem I was having connecting to the iTunes store.

    It appears to be a problem for people running Mac OS 10.3.9.

    The solution is to:
    1. Open Finder
    2. Choose your Hard Drive
    3. Find the folder called Keychains in the Library folder of your hard drive
    4. Drag this Keychains folder to your Trash
    5. Restart computer.

    I found this solution in a post by Swooz in this thread: http://discussions.apple.com/thread.jspa?messageID=787244&#787244

    Prior to trying this I did all the Keychain and Disk repair things that had been suggested, to no avail.

    I hope this works for you.

    iBook G4   Mac OS X (10.3.9)  
  • LarryBGood Level 1 Level 1 (0 points)
    My PowerBook G4 would not connect via AirPort to any secure sites (https sites) and also Mail (Mail.app) could not longer connect to any of my mailboxes.

    After trying some other connections I discovered that other wireless networks were working and also if I connected to Ethernet everything worked.

    I followed all of the suggestions in this forum article and could not get things to work. Finally, I got it to work by doing this:

    1. Go to System Preferences...>Network>Show: Network Port Configurations
    2. Highlight the offending connection (in my case AirPort) then choose Delete
    Confirm Deletion
    3. The computer then will recreate any standard connection (e.g. Airport) with it unchecked.
    4. Recheck the connection (I also re-moved it to the top of the list)

    After that, I had to re-establish my AirPort connection and then suddenly everything worked. (One of my secure sites did have to download a new certificate which may point to a similar angle to the solution.)

    I hope this helps someone get past this problem.
  • mrsbud Level 1 Level 1 (0 points)
    I'm hoping I can get some help in this topic. For some reason I can't start a new one.

    I have a new secure login that requires I use Safari and Java 1.4.

    I loaded Java 1.4.1 and enambled, but for some reason it isn't loading the new Java scripts. Everything still shows up as 1.3.

    Earlier up this thread, someone suggested move this file to the trash from library/prefs:


    I didn't see this particular file, but there were other similarly named ones.

    I then tried running disk permission repair and still no luck.

    Does anyone have any other suggestions?

    Much appreciated!
  • Rachel R Level 6 Level 6 (18,700 points)
    I'm hoping I can get some help in this topic. For some reason I can't start a new one.

    I don't know the answer to your Safari question, but I think I know what the problem is with posting.

    I'm guessing you're looking at this page:


    That's the Safari category page. To post in the actual forum, all you need to do is click on the Safari forum link listed on that page:

    Safari category page with Safari forum link circled

    Click on the circled link and then, on the next page (the forum page) you should see the "Post New Topic" link towards the top left.

    Many of the forums here have that setup: first a category page, which lists the forums; then the forums themselves, which is where you can actually create new posts. It's a little confusing at first.
  • Melly 5B Level 1 Level 1 (5 points)
    Hiya. I foolishly did the software update for Security Updater 2007-004 this weekend and have been having nothing but headaches since. The biggest problem has been signing onto HTTPS sites. I have tried the following:

    -Clearing the cache and trashing the Safari preference file (com.apple.safari.plist) and restarting (but still didn't work)
    -Installing the combo updater (no change -- would I need to reinstall the Security Updater too? I am a bit confused by this one)
    -Running disk utility/Running disk utility after downloading the combo updater
    -Trashing HD keychain and restarting (nothing changed)

    I would like to try trashing com.apple.security.revocation.plist but I can't find it in my Library -- is this only in newer operating systems? I'm on 10.3.9.

    I did manage to log into secure sites by following LarryBGood's suggestion in http://discussions.apple.com/thread.jspa?messageID=3718779

    BUT I am still having trouble getting into the iTunes store, which gives me an error message of -9813.

    I am about to try replacing the X509 Anchors file but to be honest I don't really know what I'm doing and am concerned these actions are going to have repercussions down the line. Has anyone else had success with any of the fixes?

    Thanks for any advice!

    Best wishes,

    Powerbook G4   Mac OS X (10.3.9)  
  • snoho Level 1 Level 1 (35 points)
    I have been having similar problems getting to https sites. I have found that changing my location (eg. >Location>Broadband) and then changing it back to original location then allows me to access https sites. This is only a temporary work around as the problem will come back.

    One would think Apple would be hard at work on this issue since it affects nearly all enterprise/corporate users.
  • J_Oliver Level 1 Level 1 (0 points)
    THIS WORKS! First a thanks to JessicaE who saved me from what could have been hours of searching for a solution. In my case, after receiving the following updates on June 23, 2007:

    - Java for Mca OS X 10.3, Update 5 (v 5.0);
    - QuickTime (v 7.1.6)
    - iTunes (v 7.2)
    - Security update 2007-005, 006 & 002 (v's 1.0)
    - Daylight Savings Time Update (v 1.0)

    I was no longer able to connect to HTTPS sites, could not log on to my .Mac account or purchase music from iTunes (ultimately needing to use my PC to fully log into .Mac to solve the problem).

    By simply dragging the keychain folders as mentioned by JessicaE and re-booting, all was solved.

    Note - when I did this, the folders were only copied to the trash and remained in the Keychain / Library folder.

    iMac   Mac OS X (10.3.9)   G4; Safari 1.3.2 (v312.6)

    iMac   Mac OS X (10.3.9)   G4; Safari 1.3.2 (v312.6)