Related Article

Change the default browser or email client on your Mac

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: How to change default phone app on Mac

How do I change default phone application in Mac OSX Capitan/Sierra?


I do not want to use Facetime. I want to use a different app, say Skype or Uno to make phone calls. I already tried changing default app in Facetime/Settings but it doesn't stick, it immediately changes back to Facetime again.

MacBook Pro, iOS 8.1.3

Posted on

Reply
Question marked as Helpful

Nov 27, 2016 5:09 AM in response to zemlan In response to zemlan

"Funny" - I have the exact opposite question. I have Skype for Business installed on my MacBook Pro running MacOS Sierra and after the install my default call making app is Skype for Business - I DO NOT WANT THAT!


It prevents me from making calls using handover with my iPhone 😟.


Any solutions?

Question marked as Helpful

Mar 21, 2017 2:31 PM in response to shardphoenix In response to shardphoenix

I ran into this "opposite" problem too after installing Skype. As usual, Apple don't make it easy to find these settings!


1. start the "Facetime" application

2. "FaceTime" → "Preferences…" menu item (or ⌘+,)

3. in the "Settings" tab that opens, down the bottom, change "Default for calls" from "Skype for Business" to "FaceTime".


After that, calling from the "Messages" app went through my iPhone again like it used to.


PS: boo to Microsoft for silently changing this default!

There’s more to the conversation

Read all replies
Question marked as Helpful

Nov 27, 2016 5:09 AM in response to zemlan In response to zemlan

"Funny" - I have the exact opposite question. I have Skype for Business installed on my MacBook Pro running MacOS Sierra and after the install my default call making app is Skype for Business - I DO NOT WANT THAT!


It prevents me from making calls using handover with my iPhone 😟.


Any solutions?

Nov 27, 2016 5:09 AM

Reply Helpful (13)
Question marked as Helpful

Mar 21, 2017 2:31 PM in response to shardphoenix In response to shardphoenix

I ran into this "opposite" problem too after installing Skype. As usual, Apple don't make it easy to find these settings!


1. start the "Facetime" application

2. "FaceTime" → "Preferences…" menu item (or ⌘+,)

3. in the "Settings" tab that opens, down the bottom, change "Default for calls" from "Skype for Business" to "FaceTime".


After that, calling from the "Messages" app went through my iPhone again like it used to.


PS: boo to Microsoft for silently changing this default!

Mar 21, 2017 2:31 PM

Reply Helpful (10)

Jul 14, 2017 12:43 AM in response to lnelson.au In response to lnelson.au

Hmm...but if I don't want to use facetime, this isn't possible to archive: The Preferences-Menu is greyed-out as long as you don't register a facetime-account.

I have to set the default telephone app on 10 iMacs and don't want to register 10 iCloud-accounts just to do the facetime login and being able to open the preferences there. That's ridiculous.


Installed RCDefaultApp and set the default telephone app there but the phone-icon in contacts application is still greyed-out. So it's not possible to start phone calls from within contacts application.

Jul 14, 2017 12:43 AM

Reply Helpful

Jul 15, 2017 6:43 AM in response to shardphoenix In response to shardphoenix

I exactly have same problem.

In Facetime preference, my default for calls in FaceTime but whenever I click some phone number on Safari for call, it returns message "Do you want to allow this page to open “Skype”?" and nothing after that.


Please advise.

Jul 15, 2017 6:43 AM

Reply Helpful
User profile for user: zemlan

Question: How to change default phone app on Mac