Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Hot corners not working in macOS Sierra

I just upgraded today to macOS Sierra 10.12.1. I immediately noticed that my hot corner (System Preferences > Desktop & Screen Saver > Hot Corners > Start Screen Saver) is no longer working. It was working fine before I upgraded today. Anyone else seeing this? Anyone have a fix?

iMac, OS X El Capitan (10.11.5)

Posted on

Reply
Question marked as Solved

Oct 25, 2016 12:10 PM in response to pomme4moi In response to pomme4moi

Hello pomme4moi.

If I’m understanding you right, your screen saver hot corners are no longer working after updating to macOS Sierra 10.12.1. I know how convenient hot corners are, so let’s get yours working again!

First, go to System Preferences > Desktop & Screen Saver > Hot Corners, and remove all of your current hot corners so they are blank. After that, restart your Mac and then go back into System Preferences and re-enable your previously set hot corners again. Allow your Mac to go to sleep to test to see if the issue is still happening. If it is, reset your Macs SMC. You can find the steps on how to do the reset here: Reset the System Management Controller (SMC) on your Mac Test out your screen saver hot corners again after the reset is completed.

If the issue persists, the next steps would troubleshoot the issue, as well as help narrow down what's causing it. Complete the steps below:
  1. Create a new admin user account on your Mac, log into that user account, set the screen saver hot corners, and test while logged into that user account.- macOS Sierra: Set up users, guests, and groups on your Mac.
  2. Boot your Mac into safe mode and test out the hot corners again.- macOS Sierra: Start up in safe mode
  3. Restart your Mac like normal and test again.
Thanks for using Apple Support Communities.

Take care.

Oct 25, 2016 12:10 PM

Reply Helpful (4)

Oct 25, 2016 6:16 PM in response to pomme4moi In response to pomme4moi

Try the solution suggested in this post

Re: Screensaver "start time" option grayed out


Back up all data. Quit System Preferences if it's running.

Triple-click anywhere in the line below on this page to select it, then copy the text to the Clipboard (command-C):

~/Library/Preferences/ByHost

In the Finder, select

Go Go to Folder...

from the menu bar. Paste into the box that opens (command-V), then press return. A folder should open. If it does, look for a file with a long name that begins "com.apple.screensaver". There may be two such files. Move the one without the word "slideshow" in the name to the Trash.

Test. If the problem is resolved. recreate your settings in the Screen Saver tab.

My experience - On top of it I had to quit "System Preference" and open it again, only then it started to work.

Oct 25, 2016 6:16 PM

Reply Helpful

Aug 15, 2017 7:49 AM in response to pomme4moi In response to pomme4moi

I am running macOS Sierra 10.12.6 and this method worked fast and simple for me! Changing your hot corner to "Disable Screen Saver" and then back to the original action seems to work:


  1. Change the hot corner of "Start Screen Saver" to "Disable Screen Saver" and click [ OK ]
  2. Then roll over the hot corner (of course nothing happens)
  3. Click back into [Hot Corners...] options, change it back to "Start Screen Saver" and click [ OK ]
  4. Screen Saver should activate as expected :-)

Aug 15, 2017 7:49 AM

Reply Helpful (4)

Nov 15, 2017 5:36 PM in response to Corrie84 In response to Corrie84

I am having the same problem in High Sierra. I use Hot Corners a lot!

Your solution is great BUT no way can I teach my grandparents to do that!

The option below - 'disable' then 'enable' screensaver - did not work either.

I have sent Feedback to Apple.

Any others having this problem?

Nov 15, 2017 5:36 PM

Reply Helpful
User profile for user: pomme4moi

Question: Hot corners not working in macOS Sierra