Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Stop receiving "Your disk is almost full" notification

I'm receiving a "Your disk is almost full" notification, and I'm desperate for a method to turn it off. Every time I close it, it pops back up within 10 seconds. Every time. I'm running with about 3GB of free space on a 128GB hard drive, and I'm fine with that. I've been managing for the past 3 years with 1-5 GB of free space and I have no performance issues. I just want to stop receiving the notification. Anyone know how?

MacBook Pro, macOS Sierra (10.12.1)

Posted on Nov 1, 2016 12:29 PM

Reply
Question marked as Apple recommended
Answer:
Answer:

When that message appears, it should not be ignored. The only way to stop it from appearing is to increase available storage space so that your Mac can continue to work normally. To learn how to do that please read macOS Sierra: Increase disk space.


macOS "Sierra" offers additional options for offsite storage. Please read Free up storage space on your Mac - Apple Support.

Posted on Nov 1, 2016 2:40 PM

Question marked as Helpful

Nov 16, 2016 8:36 AM in response to ngartke In response to ngartke

There has to be a way to turn off this annoying notification. there is nothing wrong to use the disk that I bought to its full potential.


Also people responding like "just clear some space out" you guys are just as annoying as the notification. There is a clear question to how to turn off a boolean value to stop this notif to appear.

Nov 16, 2016 8:36 AM

Question marked as Helpful

Nov 1, 2016 12:35 PM in response to Csound1 In response to Csound1

There's nothing dangerous about it. 3GB free is where I'm running with a sizeable swap file. I've been managing my macbook with a low amount of headroom for years with no problems. I don't want to have to free up several GB of space. I just want to know if there's a way to independently turn off the notifications.

Nov 1, 2016 12:35 PM

Question marked as Helpful

Dec 15, 2016 4:42 PM in response to ngartke In response to ngartke

Drives me insane, too. Apple has always had the tendency to assume the user doesn't understand the risks and consequences of doing things it doesn't like, which is absurd to me. Get out of my way and let me hang myself if I want to. Anyway... I found something that may help, though I'm still testing it out to see if the change sticks.


Note to anyone who stumbles across this: DO NOT DO THIS. YOU WILL KILL ALL THE PUPPIES. If you actually understand what I'm describing below and realize that tweaking internal system settings can result in HORRIBLE THINGS HAPPENING, well, you'll understand why I added this note. DON'T DO IT. (Or, ya know, whatever.)


Take a look at the output from `defaults export com.apple.ncprefs - | grep -2 diskspaced` -- com.apple.diskspaced is part of the StorageManagement framework, and can be found at /System/Library/PrivateFrameworks/StorageManagement.framework/Versions/A/Resourc es/diskspaced.


I tried toggling notifications for one of my apps and watching the flags value for it, but (seriously) after changing notification settings then changing back, the flags value is not the same. So, I have no idea if changing the flags value will actually result in no more notifications, this is wildly outside normal documented stuff to dig into, but hey, if you're up for doing things that will upset half the people who replied to this thread... 🙂


I set my com.apple.diskspaced flags to 4117, based on values I found for other disabled apps. This is probably entirely wrong, but worst case scenario it just doesn't stop notifying. Kinda hard to imagine notification center not gracefully handling an unexpected value here, seeing as how that's Developer 101.


Good luck!

Dec 15, 2016 4:42 PM

Question marked as Helpful

Jan 2, 2017 6:52 AM in response to ngartke In response to ngartke

Thanks ngartke for asking this very important question. It's been so frustrating with MacOS Sierra's notification. I mean for someone who has been managing his hard disk drive for over 2 years between 3GB to 5GB. I can see the implication of running low on disk drive and very fine with mine but gosh how to turn this off so I stop getting the notifications. I can't believe it's so hard to find how to. Please if you've found a way, let me know. And I had the warning intuition not to turn on iCloud storage optimization for since being with apple from 2008, they have never been the best with anything connected with internet services. Anyway paying the price :-D. Next time will just leave it alone. I've turned off "store in the cloud, and reduce clutter" recommendations but don't know how to turn off optimize storage and empty trash automatically. You know, these are the areas I see why people are so mad with apple but hey i'll take these caveats over the so many other problems I get when running Windows.


Anyway I hope there's a way to turn this off or maybe in a new update.



Thanks mate.

Jan 2, 2017 6:52 AM

There’s more to the conversation

Read all replies
Question marked as Helpful

Nov 1, 2016 12:35 PM in response to Csound1 In response to Csound1

There's nothing dangerous about it. 3GB free is where I'm running with a sizeable swap file. I've been managing my macbook with a low amount of headroom for years with no problems. I don't want to have to free up several GB of space. I just want to know if there's a way to independently turn off the notifications.

Nov 1, 2016 12:35 PM

Reply Helpful (29)
Question marked as Apple recommended

Nov 1, 2016 2:40 PM in response to ngartke In response to ngartke

When that message appears, it should not be ignored. The only way to stop it from appearing is to increase available storage space so that your Mac can continue to work normally. To learn how to do that please read macOS Sierra: Increase disk space.


macOS "Sierra" offers additional options for offsite storage. Please read Free up storage space on your Mac - Apple Support.

Nov 1, 2016 2:40 PM

Reply Helpful (4)

Nov 2, 2016 3:07 PM in response to ngartke In response to ngartke

Apple have always recommended you have more free space than you seem to think is OK, this one is from 10.8…

OS X Mountain Lion: If you see a gray screen at startup

…make sure your computer has at least 1 GB of memory and 9 GB of available disk space.

Os's do not need fewer resources over time, they need more.


You need to heed the warning that the OS is throwing at you. Eventually you can lose data or get into an unbootable state. That is why there is no option to turn off the dialog.


You could be better off fitting a larger disk compared to looking for ways to circumvent the warning if the Mac supports user replaceable storage. Post the model info if you want help with that but the answer to this problem is the one that you do not want to hear – remove some data.

Nov 2, 2016 3:07 PM

Reply Helpful (3)
Question marked as Helpful

Nov 16, 2016 8:36 AM in response to ngartke In response to ngartke

There has to be a way to turn off this annoying notification. there is nothing wrong to use the disk that I bought to its full potential.


Also people responding like "just clear some space out" you guys are just as annoying as the notification. There is a clear question to how to turn off a boolean value to stop this notif to appear.

Nov 16, 2016 8:36 AM

Reply Helpful (41)

Nov 16, 2016 11:50 AM in response to guney can In response to guney can

Apples OS disagrees with your opinion — tell them your feelings on the dialog…

http://www.apple.com/feedback/


The 'defaults system' should contain the setting you claim exists, there are commands to search for functioning values…

https://developer.apple.com/legacy/library/documentation/Darwin/Reference/ManPag es/man1/defaults.1.html


Unfortunately no sites have a setting listed for the disk full dialog (probably because it does not exist).

http://www.defaults-write.com, there are many others that list defaults values for OS X.


It is anoying to you because you are wrong and the answer is to free some space. Take it to an Apple Store as you clearly do not believe the sound advice already given here.

Nov 16, 2016 11:50 AM

Reply Helpful (1)

Nov 16, 2016 11:57 AM in response to guney can In response to guney can

macOS is a UNIX operating system, and needs 10 - 12% of total storage for the operating system to function properly — over and above swap space. Those messages that you want to turn off are from the operating system itself telling you that you have dipped into its reserved space requirements. There will be no turning those messages off until you free up sufficient storage.


This was true 25 years ago with multiple, other UNIX solutions too, and the same customer advice to free space has not changed since.

Nov 16, 2016 11:57 AM

Reply Helpful
Question marked as Helpful

Dec 15, 2016 4:42 PM in response to ngartke In response to ngartke

Drives me insane, too. Apple has always had the tendency to assume the user doesn't understand the risks and consequences of doing things it doesn't like, which is absurd to me. Get out of my way and let me hang myself if I want to. Anyway... I found something that may help, though I'm still testing it out to see if the change sticks.


Note to anyone who stumbles across this: DO NOT DO THIS. YOU WILL KILL ALL THE PUPPIES. If you actually understand what I'm describing below and realize that tweaking internal system settings can result in HORRIBLE THINGS HAPPENING, well, you'll understand why I added this note. DON'T DO IT. (Or, ya know, whatever.)


Take a look at the output from `defaults export com.apple.ncprefs - | grep -2 diskspaced` -- com.apple.diskspaced is part of the StorageManagement framework, and can be found at /System/Library/PrivateFrameworks/StorageManagement.framework/Versions/A/Resourc es/diskspaced.


I tried toggling notifications for one of my apps and watching the flags value for it, but (seriously) after changing notification settings then changing back, the flags value is not the same. So, I have no idea if changing the flags value will actually result in no more notifications, this is wildly outside normal documented stuff to dig into, but hey, if you're up for doing things that will upset half the people who replied to this thread... 🙂


I set my com.apple.diskspaced flags to 4117, based on values I found for other disabled apps. This is probably entirely wrong, but worst case scenario it just doesn't stop notifying. Kinda hard to imagine notification center not gracefully handling an unexpected value here, seeing as how that's Developer 101.


Good luck!

Dec 15, 2016 4:42 PM

Reply Helpful (6)
Question marked as Helpful

Jan 2, 2017 6:52 AM in response to ngartke In response to ngartke

Thanks ngartke for asking this very important question. It's been so frustrating with MacOS Sierra's notification. I mean for someone who has been managing his hard disk drive for over 2 years between 3GB to 5GB. I can see the implication of running low on disk drive and very fine with mine but gosh how to turn this off so I stop getting the notifications. I can't believe it's so hard to find how to. Please if you've found a way, let me know. And I had the warning intuition not to turn on iCloud storage optimization for since being with apple from 2008, they have never been the best with anything connected with internet services. Anyway paying the price :-D. Next time will just leave it alone. I've turned off "store in the cloud, and reduce clutter" recommendations but don't know how to turn off optimize storage and empty trash automatically. You know, these are the areas I see why people are so mad with apple but hey i'll take these caveats over the so many other problems I get when running Windows.


Anyway I hope there's a way to turn this off or maybe in a new update.



Thanks mate.

Jan 2, 2017 6:52 AM

Reply Helpful (5)
User profile for user: ngartke

Question: Stop receiving "Your disk is almost full" notification

Welcome to Apple Support Community
  • A forum where Apple customers help each other with their products. Learn more.
  • Sign up with your Apple ID to get started.