Announcement: Upgrade to macOS Catalina

Experience dedicated apps for music, TV, and podcasts, plus smart new features like Sidecar. Learn how to upgrade >

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Ethernet via wifi internet sharing not working in Sierra

I have used wifi sharing (internet coming in via ethernet) for years and years on my old iMac (circa late 2006) and it was one of the things I liked best about it. Simple and elegant. I never had any problem with any other device connecting through the wifi sharing. However, I just bought a new iMac, running Sierra with all available updates, and internet sharing (from ethernet using wifi) simply does not work.


All sharing boxes are ticked correctly. The light is green. The desktop shows the gray wifi arrow pointing upward, indicating that it is sending out SOME kind of signal. My devices can see my computer/network. But when I try to connect them, they show "no internet connection" for my computer/network. But I DO have perfectly good connection coming in to my iMac on ethernet, as evidenced by the fact that I am here on the internet now typing this question.


There seems to be some sort of technical glitch or disconnect with what the iMac is putting out through the wifi signal. I have seen numerous other complaints about this, most without answers.


I have already spent close to two hours (total) on the phone with two different AppleCare people, and now they are seeking help from "the engineers." All I can say is that this appears to have been an issue for at least six months, based on my online searches for suggestions; so if the engineers pretend that it is something new, shame on Apple.


Has anyone ever gotten this corrected? I do not want to be chained to my desk nor have to buy a router!

iMac (21.5-inch, Late 2015), macOS Sierra (10.12.3), null

Posted on

Reply

Feb 18, 2017 9:57 AM in response to nmlhats In response to nmlhats

You already have a router don't you? That is what the new iMac is connected to (via WiFi or Ethernet), correct? So rather than use the iMac why not use the same router for the other devices? Does the box that provides internet not have wifi (very uncommon)? What model and make is the box that is connected to your internet provider (the router)? How old is it?

Feb 18, 2017 9:57 AM

Reply Helpful

Feb 18, 2017 9:25 PM in response to dot.com In response to dot.com

It appears to be just a modem....its setup page (the series of numbers or IP address you type into a browser to set it up) does not show anything related to network, etc. It is a Zyxel P-660-F1 and is probably circa 2009. In fact, at some point in the long ago past, probably around that time, I think my ISP tried to sell me a router when I first inquired about setting up a home network. Then the next day I found out about sharing and never needed a router. I feel like this is an important attribute that Apple offers and that Apple should be able to make its software work properly without my having to acquire equipment I should not need to buy.

Feb 18, 2017 9:25 PM

Reply Helpful

Feb 19, 2017 9:14 AM in response to nmlhats In response to nmlhats

Is that the exact model number? Found mention of several similar models like P660R-F1, but not the P660-F1. Anyway, since there is no mention of WiFI in the router setup web interface internet sharing seems like your only option unless you can talk your ISP into exchanging the existing non-wifi router with a newer one that has WiFi (Zyxel makes many models with WiFi as do many others). Are you paying for your router rental from your ISP? If so, would think they would be able to exchange your ancient non-wifi with another one that does have WiFi for no additional fee just to keep you happy and not looking for another ISP who is able to provide you with service that includes a WiFi model if you let them know how the difficulties you're having with getting a second computer working.


in any event how about some screen-shots of your Network and Sharing System Preferences panes so we can make suggestions about what to try to get the internet sharing working?


Good luck...

Feb 19, 2017 9:14 AM

Reply Helpful

Feb 23, 2017 10:41 AM in response to dot.com In response to dot.com

SO sorry, typo! It is P-660R-F1.


Even though I have been a customer of my ISP for 19 years and have never had to pay for a modem in the past, they won't send me another one without my paying (rent or buy).


Anyway, here are some pictures of my settings. Anything typed in or ticked or not ticked is based on imported settings from my old iMac or on something that someone from Apple or my ISP told me to do.

User uploaded fileUser uploaded fileUser uploaded fileUser uploaded fileUser uploaded fileUser uploaded file

Feb 23, 2017 10:41 AM

Reply Helpful

Feb 23, 2017 2:31 PM in response to nmlhats In response to nmlhats

Just came across this little tidbit of how to use your Ethernet internet connection by sharing the WiFi interface which is what you are trying to do:


macOS Sierra: Share the Internet connection on your Mac


Note the little statement after step 4 about:


If you share your Internet connection using Wi-Fi, deselect the Internet Sharing

checkbox, click Wi-Fi Options, give your network a name and password, then

select the Internet Sharing checkbox again.


This step allows you to name your shared network and a channel, select what type of security (suggest WPA2 Personal) and give the network a password. Otherwise you never get a chance to define these parameters which all the other things will need to know to connect. After doing this do things work now or is this already something you've been thru?


Good luck...

Feb 23, 2017 2:31 PM

Reply Helpful

Feb 23, 2017 3:41 PM in response to dot.com In response to dot.com

Unfortunately, been there, done that, multiple times (on my own volition and then at the behest of AppleCare). Apple even had me change that password and I also tried different channels. Nothing worked. Devices still say "no internet connection" on my iMac network.

Feb 23, 2017 3:41 PM

Reply Helpful

Feb 23, 2017 4:28 PM in response to nmlhats In response to nmlhats

You never did say what kind of device you're trying to connect on the WiFi network. Whatever it is, does it show you the network specifics of it's connection to the iMac that you're sharing? What does it say for it's IP address and router and DNS settings? What does your iMac show for these Terminal commands:


ifconfig -a

netstat -rn


You might want to change MAC/Ethernet addresses, but all the IP addresses should be of the non-routable type IP addresses like 192.168.x.y or 10.x.y.z or 169.254.x.y or one of those ilk, so that would not be anything of any use to hackers since they can't get to those addresses from the internet. Basically we're looking for some sort of network routing issue or conflict or other issue that might be incorrect.

Feb 23, 2017 4:28 PM

Reply Helpful

Feb 23, 2017 4:33 PM in response to nmlhats In response to nmlhats

Also I just setup my Sierra MacBook to do internet sharing via my WiFi thru my Ethernet to the outside, and it works fine, so it's certainly doable. Tried connecting an iPad to this new WiFi network and works fine and MacBook still working fine.

Feb 23, 2017 4:33 PM

Reply Helpful

Feb 24, 2017 11:10 AM in response to dot.com In response to dot.com

The devices I am trying to connect are my iPad Mini, my husband's iPhone (not here right now) and my Brother printer' all of which connected fine to my old iMac with Snow Leopard.


On my Mini, the fields for my iMac network details are all blank!


I am afraid I will need some help to locate the info you are asking for in Terminal, sorry. I have not used that utility before and do not want to mess something up. Which Terminal menu should I be looking in?


Thank you!

Feb 24, 2017 11:10 AM

Reply Helpful

Feb 24, 2017 2:17 PM in response to nmlhats In response to nmlhats

Terminal is what's called a command line app - not a GUI app like most Mac apps. It opens a window and then you type commands like the ones above. The first command ("ifconfig -a") lists all your network interfaces and prints out stuff like IP address and MAC/Ethernet address, etc.


The second command ("netstat -rn") prints out the routing table.


From these we can try and determine if there is some sort of misconfiguration of the networking stuff and where to go from there.


You should be careful what you type, as the wrong command can do things you might not have meant to do. You can read about these two commands by typing "man ifconfig" or "man netstat" (without the quotes) if you wish to see exactly what all the parts of the command do.


Good luck...

Feb 24, 2017 2:17 PM

Reply Helpful

Aug 23, 2017 12:56 PM in response to nmlhats In response to nmlhats

I am having this exact same issue with my new MacBook Pro! Did you ever find a solution? I've been looking for answers for 4 hours now. So frustrated! You pay all this money and still end up with equipment that doesn't do what it's supposed to. I've had less issues with the $200 Asus I bought off of Amazon! I've been unhappy with my last 3 MacBooks, from melting batteries to wifi issues... Apple has gone downhill. Not worth the price.

Aug 23, 2017 12:56 PM

Reply Helpful

Aug 24, 2017 5:59 AM in response to nmlhats In response to nmlhats

Read the article and click on sub articles in bottom end : macOS Sierra: Share the Internet connection on your Mac

Also , an another article : Non-responsive DNS server or invalid DNS configuration can cause long delay before webpages load - Apple Support

Try with google DNS server settings and keep as 8.8.8.8 and 8.8.4.4

Open DNS server settings are sometimes ..

Aug 24, 2017 5:59 AM

Reply Helpful

Sep 12, 2017 3:38 AM in response to nmlhats In response to nmlhats

To help you get your Internet Sharing in a working state, we will need you to run a

few commands through Terminal.

Here is how to proceed:

Open Spotlight (the small looking glass on the right of your menu bar) and type:

Terminal

this will locate the application Terminal on your disk:User uploaded file. Double-click on the Terminal icon to start it. This application will open you a new window which will permit you

type command lines just as we did on terminal of old computers 30 years ago.

Grab the right down corner of the Terminal window and drag it so as to get a large enough window:

100x60. This will permit you to get all the information needed within one window.

Within the Terminal window, type the following command (beware there is a meaningfull space before the -a):ifconfig -a

and then type the return key on your keyboard (this return key has the function to tell

your iMac: "execute this command!").

  • Make a screen capture of the output of this command. To achieve this, use the keyboard combination: [cmd]+[shift]+[4], then hit the space bar and select the Terminal window.
  • Then type [command]+[Q] to exit the Terminal application.

If this procedure terminated correctly, do the same thing with the next command:

netstat -r

. Beware to the space before the -r, and the return at the end of the command.

Then put these 2 screen captures within your reply and we will try to help you.

Sep 12, 2017 3:38 AM

Reply Helpful

Nov 21, 2017 12:23 PM in response to nmlhats In response to nmlhats

I was bothered by the exact same problem for like, months or so, and I somehow fixed it just a few minutes ago, by following the steps here: https://www.xarg.org/2017/07/set-up-internet-sharing-on-mac-osx-using-command-li ne-tools/

However, I didn't follow all the steps (I only did the things in "Enable IP forwarding on OSX"), and I don't really know which step is it that fixed the problem. Maybe you should still give it a try...

Nov 21, 2017 12:23 PM

Reply Helpful
User profile for user: nmlhats

Question: Ethernet via wifi internet sharing not working in Sierra