Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Formatting Failed: Compiler File Error

Hello...
Yesterday I got my crossgrade disks from Apple, so I upgraded my G4 Powerbook with the full Studio Pro upgrade, then made sure I had all current patches.

When I opened up one of my DVD Studio Pro projects and clicked Burn, It failed with a dailog box that said "Formatting failed, Building was not successful, See log" so I looked at the log and it said in red "Compiler File Error"

This project worked fine before I upgraded... So, for grins, I started from scratch and rebuilt the project and reimported the assets. Now I had just recompressed the video/audio with the new compressor as well... Anyway, same result. Also, when it fails, the OS-X window pops up that you normally get once you insert a blank DVD and you can choose an app or hit ignore.

Can't figure this out... Any help would be greatly appreciated.

Dave

Powerbook G4 Mac OS X (10.4.3)

Posted on

Reply

Page content loaded

Dec 28, 2006 6:50 AM in response to APPLE27 In response to APPLE27

Once I upgraded, I recompressed the video (its about 14 min, and uses Dolby, not AIFF)... When I opened DVD Studio Pro, it prompted me that assets had changed, I said ok, then tried to burn and go the error. I then tried deleting the PAR folder, no help. So, I just closed the project, hit NEW and recreated the project (it was rather simple) and then tried to burn... Same error.

I burned this same DVD two days ago under the old pre-universal version and it worked fine. I only recompressed because I heard that the new version performed much better.

Sorta lost on this one... I don't see any reason why it shouldnt work. The log only says the one line and gives no other help.

Dec 28, 2006 6:50 AM

Reply Helpful

Dec 28, 2006 9:42 AM in response to APPLE27 In response to APPLE27

It occurs within seconds of clicking "burn" and like I mentioned earlier, with the error, the "blank disc has been inserted" window pops up from OSX, even though the disk has been in for a while. I even tried other blanks thinking maybe it was a bad disk... Nope...

Dec 28, 2006 9:42 AM

Reply Helpful

Dec 28, 2006 10:16 AM in response to APPLE27 In response to APPLE27

I only use Taino Yuden (SP)... I have used hundreds of them with few to no coasters... And it is a superdrive in the 17" G4 Powerbook. The only change was I went from the PowerPC only version of FCStudio, to the universal 2.1 version that was mailed to me yesterday... I then ran system update to get all the patches. So all my FCStudio apps are completely up to date...

Dec 28, 2006 10:16 AM

Reply Helpful

Mar 13, 2007 6:28 PM in response to APPLE27 In response to APPLE27

I tried a Build and Formt command, then defined a target subdirectory Source/Location field.

This reolved my initial "Compiler File Error" problem. But Then I received a new error

"Language codes for 'English' and 'English-2' must differ"

I'm starting to research that now.


Michael

Mar 13, 2007 6:28 PM

Reply Helpful
User profile for user: David Christie1

Question: Formatting Failed: Compiler File Error