6 Replies Latest reply: Jan 2, 2007 1:05 AM by MikeAustwick
MikeAustwick Level 1 Level 1 (0 points)
For a while I've been running a wireless network between my iMac and daughter's iBook. My iMac800 (OS10.2.8) is connected by ethernet to a Netgear DG834G ADSL modem/router; the Ibook (OS10.3.9) connects wirelessly from an airport card. For security measures I'm using WPA-PSK and SSID hiding.

I've just added a new IMac Core Duo2 17" (OS10.4.8) to the network. Life is fine if I disable SSID hiding but if I hide the SSID the Intel Mac can't find the network.

Is this an Intel Mac problem, an issue with 10.4.8 or something else? I'm hoping that my network is still adequately secure with WPA encryption, but having to broadcast the SSID seems a step backwards for the newest Mac!!

Any help or suggestions pse?

Happy New Year to all,
Mike

iMac800 Mac OS X (10.2.x)

iMac800 Mac OS X (10.2.x)

iMac800, Mac OS X (10.2.x)
  • 1. Re: SSID Hiding In Wireles Network
    Lalit Dhiri Level 2 Level 2 (190 points)
    The aim of hiding or not broadcasting the SSID is so the name of the wireless network can not simply be scanned for.

    When not broadcasting a user needs to enter the details manualy ie in the case of the iMac if you choose the other option (Airport settings on the top bar) and enter the details things should work.

    Going to the network settings in the System Prefernces you can select the Airport settings and use the drop down menu to choose prefered networks instead of automatic which tends to prove more reliable (refer to some of the wireless related posts).

    Happy new year
  • 2. Re: SSID Hiding In Wireles Network
    Alex Dawson Level 4 Level 4 (2,515 points)
    The other thing to remember is that SSID hiding doesn't actually work against any of the major scanners out there. WPA-PSK with a secure password is much better.
  • 3. Re: SSID Hiding In Wireles Network
    MikeAustwick Level 1 Level 1 (0 points)
    Thanks Lalit,

    I've already got Preferred Networks set in Airport Prefs but if SSID broadcast is off, the iMac won't connect.

    Is this a settings problem on my part - i.e. has anyone got their iMac connecting with SSID hidden???

    thanks,
    M
  • 4. Re: SSID Hiding In Wireles Network
    Lalit Dhiri Level 2 Level 2 (190 points)
    I am not suggesting a user should not encrypt just stating the aim of hiding SSID.

    Best option right now for end user would probably be to use hidden SSID and WPA2 with AES. Could go further and use MAC filtering too...

    Forget the server admin bit but the rest is pretty good info:

    http://docs.info.apple.com/article.html?path=ServerAdmin/10.4/en/c6od.html
  • 5. Re: SSID Hiding In Wireles Network
    Lalit Dhiri Level 2 Level 2 (190 points)
    There are problems with the Intel Core 2 Duo wireless software; should be plenty of info on the discussions.

    You could try moving the following to the desktop (resets the system config eg network, power etc):

    Macintosh HD > Library > SystemConfiguration

    Reboot

    Set up the Network settings by choosing network ports and putting Airport at the top (simply drag to do this).

    Then manualy setting your wireless as the preferred network. Also try the following:

    - wireless G only mode on your router

    - WPA2 with AES instead of PSK if all your computers work with it

    - check for firmware updates for router
    http://kbserver.netgear.com/products/DG834G.asp

    - switch off Airport and turn back on

    I doubt this is a settings problem on your part though do suggest you try the above.
  • 6. Re: SSID Hiding In Wireles Network
    MikeAustwick Level 1 Level 1 (0 points)
    Thanks, I'll have a look later 2day.

    all the best,
    Mike