5 Replies Latest reply: Jan 6, 2007 5:03 PM by Rachel R
Zachary Morgan Level 1 Level 1 (0 points)

I have recently upgraded to a MacBook from an iBookG4, and although I'm finding it loads better there are a few things that are different that I can't figure out how to change.

I'm using Safari now, whereas before I used Internet Explorer more. One of these little niggling issues is predictive text. Obviously there are many sites/things I look up regularly - and it's good that they come up - often I'm just looking up something once, or trying to find the same thing in slightly different ways (spelling for example) and then having to wade through them all every time I type the letter 'A'.

Is there a way of still using predictive text, but getting rid of all the ones I don't want to keep? Or if not - just how to turn the bloody thing off completely???

Many thanks, in advance...

MacBook   Mac OS X (10.4.8)   iPod Nano 1st Gen/iPod 4th Gen
  • Hawaiian_Starman Level 7 Level 7 (21,405 points)
    Hi Zachary,

    Are you referring to the automatic prompts that appear when typing in a URL in the address window? If you are, pressing the spacebar once before typing in the URL eliminates the prompts. This is the only easy workaround at the moment.

    If you are referring to something else, please be more specific about where you see the "predictive text" appearing.

    Post back
  • Zachary Morgan Level 1 Level 1 (0 points)
    Hello, thanks for your prompt reply.

    The text appears in any of the web browsers I use. For example in Google - I'll type in "A" and everything I've ever searched for beginning with A will appear in a box underneath the bar. It is the same in Wikipedia, or eBay, or any other site when I use the search option.

    I know it's not life or death, but it is annoying. and it meant everybody could see what each other was searching for in regards to buying Xmas presents for one another off of eBay!

    MacBook   Mac OS X (10.4.8)   iPod Nano 1st Gen/iPod 4th Gen
  • Hawaiian_Starman Level 7 Level 7 (21,405 points)
    I don't see the search-engine "suggestion" prompts in Safari, however, I'm using AcidSearch, rather than Safari's Google default. Acid Search shows a list of recent searches rather than potential prompts relative to what I'm typing. These searches can be cleared at one's discretion.

    In Firefox, the prompts do appear. If you click on the small triangle next to the G, a drop down menu appears. Select "manage search engines" at the bottom of the list. In the ensuing panel, uncheck "show search suggestions".

    Don't see any such selection in Camino.

    Let me know if you are looking for further clarification.
  • Zachary Morgan Level 1 Level 1 (0 points)
    Thanks for the help, I think I've sorted it out now - it was in the Safari preferences. I can't seem to keep the ones I use though - it's all or nothing...
  • Rachel R Level 6 Level 6 (18,700 points)
    It's true that with Safari it's all or nothing, as in you either have autofill turned on for all web sites or for none. But you can selectively delete autofill entries after they've been saved.

    Go to Safari in the menubar, select Preferences, and select the Autofill tab. Make sure the box next to "Other forms" is selected. The click on "Edit" next to "Other forms." There you can click on any web site that has autofill entries and click "Remove" to delete those entries.

    I do this periodically, deleting all but a few web sites where I prefer to keep my autofill entries.