Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Red Exclamation Point on AirPods

Hi ,

I have this new AirPods i bought it since 1 week it was amazing and work well

thin yesterday i don't know what happen the lift one doesn't work !!

and I do every steps to make sure it have charge i connect it with cable and charge it.


I press that button behind it , I try another device nothing change same problem.


when i open case charge and connect it with my i phone 7 plus with 10.3.3 software

the lift one show me red circle and exclamation mark ( ! ) and i did screen shoot to show you

I'm in Saudi Arabia unfortunately we don't have Apple shop we take our devise to Arab computer who is contact with Apple … actually it bad place I hate it and I hate apple Products because of it : (




so please help me ,!!




​[Re-Titled by Moderator]

Posted on

Reply
Question marked as Apple recommended
Answer:
Answer:

Open the case and check the bottom connector to ensure there is no debris interfering with charging it. The check the connection end on the AirPod and clean if necessary. Charge them again and then try a reset again.

Posted on

There’s more to the conversation

Read all replies
Question marked as Apple recommended

Sep 7, 2017 8:15 AM in response to Aziiiiz In response to Aziiiiz

Open the case and check the bottom connector to ensure there is no debris interfering with charging it. The check the connection end on the AirPod and clean if necessary. Charge them again and then try a reset again.

Sep 7, 2017 8:15 AM

Reply Helpful (13)
User profile for user: Aziiiiz

Question: Red Exclamation Point on AirPods