Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Can't change media kind of multiple items

iTunes 12.7.0.166 will not allow me to change the media kind of multiple items. I can change each one individually from "music" to "audiobook," but it won't allow me to change twenty, ten, five, or even two at the same time! It's something I did all the time—download ten CDs of an audio book, then change all ten from "music" to "audiobook."



Please help me figure out how to do it in the new iTunes!



—Bardfilm

OS X Mavericks (10.9.2)

Posted on

Reply
Question marked as Helpful

Nov 8, 2017 7:56 AM in response to mfeb1012 In response to mfeb1012

That's bizarre, but it works. For my situation, I downloaded the CDs of the audiobooks that I bought into iTunes. Then I found them in the finder and copied them into a new folder. After that, I deleted the files from iTunes. Then I dragged the copied files into iTunes . . . and then it would let me change multiple tracks.


Thanks for the workaround . . . and, Apple? Get to work!


kj

Question marked as Helpful

Nov 8, 2017 7:54 AM in response to mfeb1012 In response to mfeb1012

Ok - trying again, without the many typos!


I found a working solution, for use until Apple (re)fixes the problem for High Sierra.


The problem: after import from an mp3 cd, the imported tracks can only have their type changed to Audiobook one at a time, but not for 2 or more selected tracks. A big pain when there are many tracks to convert. Another curious and possibly related behavior is that when you select two or more of the imported tracks and right click, there's no "Show in Finder" option.


Here's what I did to be able to select multiple tracks and change their types to Audiobook:


Copy the files from the mp3 CD directly onto the Mac's disk drive, not going through iTunes. Then select all of the copied tracks and drag them onto iTunes. After this completes, you can use the normal method of selecting the Audiobook option.


Hope that works for you.

There’s more to the conversation

Read all replies

Page content loaded

Sep 15, 2017 6:14 AM in response to Bardfilm In response to Bardfilm

Note: If you drag the songs to an iPhone, you can then change multiple items on the iPhone, but you can't change multiple items in iTunes.


Here are the options when you change one item:


User uploaded file


Here are the options when you try to change more than one item:


User uploaded file


Again, you can do it on an iPhone (right now), but I would like to be able to do it in iTunes (like we could before).


Thanks!


—Bardfilm

Sep 15, 2017 6:14 AM

Reply Helpful

Sep 15, 2017 1:06 PM in response to Bardfilm In response to Bardfilm

Update:


If you have multiple files that already have the media kind of audiobooks, you can change them all to music all at once. But if you want to change the media kind from music to audiobook, you have to do it one at a time.


Here are the options for changing multiple audiobooks:


User uploaded file


Thanks!


—Bardfilm

Sep 15, 2017 1:06 PM

Reply Helpful (1)

Sep 19, 2017 2:24 PM in response to Bardfilm In response to Bardfilm

Will no one rid me of this troublesome bug?


In other words, are there no suggestions out there on how to fix this? Am I the only one suffering this indignity?


—Bardfilm

Sep 19, 2017 2:24 PM

Reply Helpful

Oct 4, 2017 6:54 AM in response to Bardfilm In response to Bardfilm

I've been talking to Apple Support, and they say this:


It looks like we are having reports of this issue with the media keys and the cases have been forwarded up to our engineers.


and


That is pretty similar to the cases that we have already received so this is something we are aware of.


So I'm hopeful that they will fix the bug in the next release.


Thanks!


—kj (Bardfilm)

Oct 4, 2017 6:54 AM

Reply Helpful (1)

Nov 5, 2017 5:38 PM in response to Bardfilm In response to Bardfilm

This looks like an old problem that's been solved and then re-broken with the High Sierra upgrade. Very annoying, especially for mp3 audiobook discs that have 100+ tracks.


It also used to be the case that one could import from the filesystem rather than the disc and then see the other options in the pulldown menu.


No luck. Sheesh

Nov 5, 2017 5:38 PM

Reply Helpful (1)

Nov 5, 2017 8:31 PM in response to Bardfilm In response to Bardfilm

Ok - Here's a working solution, until Apple - refixes it for High Sierra.


It seems that the track as imported from the mp3 disc aren't seen as being in the filesystem, even after import. They can be converted to Audiobook en masse, and they can be multi-selected and shown in the finder.


So, here's what I did:


Copy the files from the mp3 CD onto the Mac's disk drive. Then select them all and drag them onto iTunes. After this, you can then select Audiobook option.


Hope that works for you.

Nov 5, 2017 8:31 PM

Reply Helpful (1)
Question marked as Helpful

Nov 8, 2017 7:54 AM in response to mfeb1012 In response to mfeb1012

Ok - trying again, without the many typos!


I found a working solution, for use until Apple (re)fixes the problem for High Sierra.


The problem: after import from an mp3 cd, the imported tracks can only have their type changed to Audiobook one at a time, but not for 2 or more selected tracks. A big pain when there are many tracks to convert. Another curious and possibly related behavior is that when you select two or more of the imported tracks and right click, there's no "Show in Finder" option.


Here's what I did to be able to select multiple tracks and change their types to Audiobook:


Copy the files from the mp3 CD directly onto the Mac's disk drive, not going through iTunes. Then select all of the copied tracks and drag them onto iTunes. After this completes, you can use the normal method of selecting the Audiobook option.


Hope that works for you.

Nov 8, 2017 7:54 AM

Reply Helpful (2)
Question marked as Helpful

Nov 8, 2017 7:56 AM in response to mfeb1012 In response to mfeb1012

That's bizarre, but it works. For my situation, I downloaded the CDs of the audiobooks that I bought into iTunes. Then I found them in the finder and copied them into a new folder. After that, I deleted the files from iTunes. Then I dragged the copied files into iTunes . . . and then it would let me change multiple tracks.


Thanks for the workaround . . . and, Apple? Get to work!


kj

Nov 8, 2017 7:56 AM

Reply Helpful (5)
User profile for user: Bardfilm

Question: Can't change media kind of multiple items