Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: ios 11 - stop asking me to add apple pay

Possible fix for the persistent, annoying notification: "Complete your set up, by adding Apple Pay".


Thanks, but no thanks. I've reset my phone, turned off notifications, and yet, I still get the prompt... over, and over again. I may have found a fix for this but need some confirmation.


Tap Settings - Toggle "Airplane Mode ON" > Tap Settings - General - "Software Update" > Tap Settings - Toggle "Airplane Mode OFF" - Notification removed.

iPhone 7, iOS 11.0.1, Possible Fix?

Posted on

Reply
Question marked as Helpful

Dec 18, 2017 9:50 AM in response to ideafactories In response to ideafactories

This is what worked for us:


  1. Went to Settings/Notifications/Wallet, turned on "Allow Notifications", set "Show Previews" to NEVER, then went back and set "Allow Notifications" to OFF.
  2. Went to Settings/Wallet & Apple Pay and set to OFF
  3. Went to Settings/Finish Setting Up iPhone/Set Up Apple Pay/ then chose "Set Up Later in Wallet"


So far it hasn't come back again. Not sure if #1 did anything, but I saw someone else suggest this, so went with it.

There’s more to the conversation

Read all replies

Dec 5, 2017 1:48 PM in response to ideafactories In response to ideafactories

That didn't work for me, but I just clicked the settings suggestion to set up Apple Pay. Tried to enter a fake card number a few times. When that didn't work I clicked Set Up Later and the notification is now gone. I also turned off notifications for Wallet. I'm guessing it will be back, but here's hoping its gone for good.

Dec 5, 2017 1:48 PM

Reply Helpful

Dec 16, 2017 5:47 AM in response to Mweltz88 In response to Mweltz88

What I found to make most of the insanity stop was to go in to Settings and scroll down to “Wallet & Apple Pay”. Under that I turned off “Apple Pay Cash”. The relentless popup stopped but there is still a red 1 on my Settings icon and a line under my name in settings prompting me. These are relatively east to ignore though. Hope this helps.

Dec 16, 2017 5:47 AM

Reply Helpful (1)
Question marked as Helpful

Dec 18, 2017 9:50 AM in response to ideafactories In response to ideafactories

This is what worked for us:


  1. Went to Settings/Notifications/Wallet, turned on "Allow Notifications", set "Show Previews" to NEVER, then went back and set "Allow Notifications" to OFF.
  2. Went to Settings/Wallet & Apple Pay and set to OFF
  3. Went to Settings/Finish Setting Up iPhone/Set Up Apple Pay/ then chose "Set Up Later in Wallet"


So far it hasn't come back again. Not sure if #1 did anything, but I saw someone else suggest this, so went with it.

Dec 18, 2017 9:50 AM

Reply Helpful (10)
User profile for user: ideafactories

Question: ios 11 - stop asking me to add apple pay