Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: After upgrading to MacOS High Sierra: The selected network backup disk does not support the required capabilities

Hi folks,


After upgrading to MacOS 10.13, from 10.12 clients and 10.12 Server, Time Machine stopped working on ALL upgraded clients with this error: The selected network backup disk does not support the required capabilities


Nothing else changed, backup disk is still the same but as some of you know, Apple removed Time Machine from MacOS Server 5.4 and integrated it into MacOS 10.13 software. It is so unapple to brake so much connectivity with those major upgrades. FTP is gone, client side and server side too, telnet terminal gone, and AFP is being ditched a little at a time.


Thing is I can't narrow it down to what gives this error. Looked into Console, and backupd doesn't give many clues about what is going on.


Drive is a hardware RAID array, connected to the Server via Thunderbolt and formatted HFS+. The backup folder is shared both AFP and SMB.


BR

MacBook Pro (15-inch, 2017), macOS Sierra (10.12.6)

Posted on

Reply
Question marked as Solved
Answer:
Answer:

I managed to make it work by creating a new folder on the SAME shared drive, moved the sparsebundle backups to that folder, shared it via MacOS preference pane in File Sharing, right click on folder - Advanced Options - Set as Time Machine destination, added the client users manually with read & write permissions and then pointed the client software to the newly shared folder. Inherited the backups and it all worked.


I lost patience and stamina to troubleshoot the old share point.


This is so stupid and the new way of Time Machine sharing is less intuitive than before. Maybe my above solution will help others that come into contact with this same situation. I'll keep an eye on this thread in case someone truly debugs the error.

Posted on

Page content loaded

Question marked as Solved

Oct 3, 2017 12:20 AM in response to AndreiD In response to AndreiD

I managed to make it work by creating a new folder on the SAME shared drive, moved the sparsebundle backups to that folder, shared it via MacOS preference pane in File Sharing, right click on folder - Advanced Options - Set as Time Machine destination, added the client users manually with read & write permissions and then pointed the client software to the newly shared folder. Inherited the backups and it all worked.


I lost patience and stamina to troubleshoot the old share point.


This is so stupid and the new way of Time Machine sharing is less intuitive than before. Maybe my above solution will help others that come into contact with this same situation. I'll keep an eye on this thread in case someone truly debugs the error.

Oct 3, 2017 12:20 AM

Reply Helpful (4)

Oct 3, 2017 1:30 AM in response to AndreiD In response to AndreiD

Haha partially solved. The message returned after a complete backup was performed. So that solution was only for one backup. After that: "The network backup disk does not support the required capabilities" error returns.

Oct 3, 2017 1:30 AM

Reply Helpful

Oct 14, 2017 9:52 AM in response to AndreiD In response to AndreiD

I just wanted to add that, for me, the key part of the solution was not just to update user read/write permissions to the TM backup device as @AndreiD suggested, but then to right click on the shared folder and select "Apply Permissions to Enclosed Items".


I agree that this is one of the worst UI decisions I've seen from Apple (or anyone, really) in a long time.

Oct 14, 2017 9:52 AM

Reply Helpful (2)

Oct 18, 2017 11:05 AM in response to AndreiD In response to AndreiD

I seem to have fixed the problem on our machine, I hope. I ran into this problem yesterday after I updated my wife's laptop (with a MacSales SSD) to High Sierra. The TM backup over the network to the external disk on my iMac failed with that error message. Before I tried the steps outlined by AndreiD I disconnected her connections to the shared drive and double-checked that sharing was being done by SMB, which it was. I checked and her SSD did get converted to APFS. I then rebooted her machine in Safe Mode (holding down the shift key). After it fully booted I shut it down and restarted it again normally. This time TM worked correctly, although it said that it needed to back up 27 GB to the drive, taking over 7 hours. It didn't actually take that much space, more like 15-20 GB, but that does seem large. Guess it was due to the OS upgrade number of changed files.

Oct 18, 2017 11:05 AM

Reply Helpful (1)

Oct 26, 2017 10:41 AM in response to AndreiD In response to AndreiD

My external shared drive/TM destination worked fine after High Sierra upgrade once I stopped/removed the volume share and then re-added it plainly: in System Preferences > Sharing > with File Sharing [active],

using "+" under "Shared Folders:" list, added 'theVolume' then

control-clicked 'theVolume' name/shared-drive icon in list for > Advanced Options

in dialog I deselected 'Allow guest users' and selected 'Only allow SMB encrypted connections' and 'Share as a Time machine backup destination' [no limit set in my instance], then "OK"

n.b., I left untouched the new share's DEFAULT "Users:" list,

'Systems Administrator' & 'Administrators' with 'Read & Write' and 'Everyone' with 'Read Only' privileges.

Curiously: in the listing the shared-drive icon became a shared-folder icon.


I started the local machine backup from menubar and it worked fine -- even though the 'tmutil backupdestination' ID for the local machine destination had changed, it apparently inherited/associated the correct sparsebundle/backup image.

On a local subnet Mac I selected the newly 'shared-folder' as an 'other destination' and it connected the correct sparsebundle and has been backing up without error or re-duplication [I did have to re-enter credentials as expected].

Oct 26, 2017 10:41 AM

Reply Helpful

Nov 13, 2017 5:39 AM in response to AndreiD In response to AndreiD

I have a virtually identical set up using a mac mini as a server with a raid box attached to it over usb-c to take the network's time machine back ups. All machines are updated to high sierra but not all have this problem. Sometimes the backup works, sometimes I get the same error message as you. Sometimes a restart makes it work just once, other times it works for longer (I have on the present cycle had two days of regular backups) can't see a pattern or logic. I wish they had left time machine in the server app! This definitely seems like an issue either with either High Sierra or the new file system

Nov 13, 2017 5:39 AM

Reply Helpful (1)

Nov 30, 2017 7:21 AM in response to AndreiD In response to AndreiD

I have solved this problem by creating a new Timemachine.sparsebundle with 128-bits AES-coding, Mac OS journaled.

Moved the sparsebundle to the network drive, activated it and in the terminal app entered:

"

sudo tmutil setdestination /Volumes/TimeMachine
"

After this my Time machine was working again. Don't know how to code existing backups <:(

Nov 30, 2017 7:21 AM

Reply Helpful

Dec 13, 2017 9:58 AM in response to AndreiD In response to AndreiD

Did you verify that it works on subsequent backups?


Doing that (and/or converting the drive to AFPS) resulted in the same: inheriting/the first backup runs fine, but the subsequent incremental backups fail again with the “does not support the required capabilities” error message. I assume now that “required capabilities” have something to do with figuring out incremental backups.

Dec 13, 2017 9:58 AM

Reply Helpful

Jan 7, 2018 4:30 PM in response to AndreiD In response to AndreiD

I run backups for all of the Macs in my home (we have quite a few) to a Mac Mini connected to two Drobo USB3 arrays. This problem has been driving me crazy for a while, until I tried upgrading one of the USB volumes to APFS.


Disclaimer:

If you are not comfortable performing these steps, DO NOT DO IT. You can lose data easily by messing around in "diskutil" command line... I cannot be responsible for your individual configuration. This is what worked for me:


1. Delete the share point that was in use by Server for Time Machine

2. You may have to force unmount the drive (Terminal -> diskutil unmountDrive /dev/disk2s2 (or whatever your volume happens to be)
3. Re-mount the drive and using Disk Utility UI, select the volume and from the Edit menu, select Convert to APFS


This is very unlike Apple to make such enormous changes and not publish documentation (or easy to find documentation). In this case, APFS was the only thing that worked for me.

Jan 7, 2018 4:30 PM

Reply Helpful

Jan 13, 2018 11:42 AM in response to ChrisBennettGA In response to ChrisBennettGA

Hi Chris,


Did not try your solution yet to the same problems I have but I noticed a very strange issue. When I connect my Macbook Time machine to my Mac mini with the shared folder, it wants me to log in. Whatever I type in, the response is the same! So no wrong password animation, just "the selected network backup ......"


Looks like there are more strange bugs in High Sierra with passwords i guess. At work we have an issue where the finder crashes when accessing a shared folder on a Windows server through smb3. Apple has so far no solution yet.

Jan 13, 2018 11:42 AM

Reply Helpful
User profile for user: AndreiD

Question: After upgrading to MacOS High Sierra: The selected network backup disk does not support the required capabilities