Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Auto Capitalization in iOS 11

Ever since I upgraded to iOS 11, a lot of non name words that are saved as Contacts are auto capitalised. For e.g. I save a contact called 'John Tennis', simply because he is my tennis buddy. Whenever I happen to type 'tennis' in my text, it gets capitalised to 'Tennis', which is very frustrating. This is just one of the many examples such as:


- AIA Call Centre (Both 'call' and 'centre' get capitalised in my texts)

- Cindy Cleaner ('Cleaner' gets capitalised)

- and many many more.


Is there a way I can stop this without disabling 'Auto Capitalisation' in my settings? It never happened in earlier version of iOS.

iPhone 7, iOS 11.0.1

Posted on

Reply
Question marked as Helpful

Nov 12, 2017 2:46 AM in response to xaviertee In response to xaviertee

My phone was capitalising “Just Home”. I have a contact called “Home Improvements” (a building company) with Hone as first name and Improvements as last name. So iOS was capitalising what it thought I had recorded as a proper name (or given name).


Solution: I set the Company name to Home Improvements and left first and last name blank. Auto-capitalisation of “Home” has now stopped!!


So if you move “Tennis” to be the company name of your John Tennis contact, iOS will stop capitalising “Tennis”.

Question marked as Helpful

Jan 16, 2018 7:26 AM in response to xaviertee In response to xaviertee

Come on @apple! This is ridiculous, this is just one of the many issues with the new ios 11, i keep thinking the next update will fix these annoying bugs. My phone keeps capitalizing "your"......I have NO CONTACTS WITH "your" in them.

There’s more to the conversation

Read all replies

Oct 17, 2017 9:36 AM in response to xaviertee In response to xaviertee

Same thing is happening to me. I didn't realize it was only words that are included in contacts' names. How can we fix this? Turning off the "Auto-Capitalization" function under keyboard settings also prevents the first word in sentences from being capitalized. Kind of a PITA.

Oct 17, 2017 9:36 AM

Reply Helpful
Question marked as Helpful

Nov 12, 2017 2:46 AM in response to xaviertee In response to xaviertee

My phone was capitalising “Just Home”. I have a contact called “Home Improvements” (a building company) with Hone as first name and Improvements as last name. So iOS was capitalising what it thought I had recorded as a proper name (or given name).


Solution: I set the Company name to Home Improvements and left first and last name blank. Auto-capitalisation of “Home” has now stopped!!


So if you move “Tennis” to be the company name of your John Tennis contact, iOS will stop capitalising “Tennis”.

Nov 12, 2017 2:46 AM

Reply Helpful (10)

Dec 29, 2017 12:41 PM in response to xaviertee In response to xaviertee

I just fixed this issue on my phone, based on someone else's comment, but their solution wasn't the ideal answer.


My own name was being auto capitalized when I would type it (example: responding to an email) but apparrently my name was ALL CAPS in Contacts. I edited my own contact info to standard capitalization and ta-da! Problem solved. So look for your friend's name in the contacts and edit how it's capitalized. I don't think you need to move his name to the company field. Good luck!

Dec 29, 2017 12:41 PM

Reply Helpful

Jan 12, 2018 3:02 PM in response to xaviertee In response to xaviertee

I have a ton of contacts and most of them are actual names. It absolutely insane that auto-capitalisation assumes that every word in my contacts equals a proper noun/name while typing. I really hope Apple changes this soon. It is definitely a complete PITA.

Jan 12, 2018 3:02 PM

Reply Helpful (4)

Jan 14, 2018 12:51 PM in response to dmonkee70 In response to dmonkee70

This technique does not work for me. My phone keeps capitalziting “Grave” for me.... look it just happened. I have no contacts with the word Grave at all. I also hate that I will type a word exactly how I want it and when I get 4-6 words past the word, it autocorrects to something out of left field. It always happens with food or good. I also have to fight my auto correct when I want to say “k,” it always corrects to capital I and it takes around 5 times of erasing then retyping until I can get it. Is it time to switch to Android? 😱

Jan 14, 2018 12:51 PM

Reply Helpful (1)

Jan 14, 2018 1:28 PM in response to xaviertee In response to xaviertee

I'm a little late to this party but I honestly don't understand the problem.


The default is initial caps, which is a logical default for the Name field. When you're entering names, you will see the shift key highlighted for the first character in a name field and for the first character after a space. All that is necessary is to tap the shift key to turn it off whenever you wish to over-ride the default.


I created a test contact. The first name is

John tennis


The second name is

baseball


Consequently, the full name is

John tennis baseball


Is that what you're unable to do?

Jan 14, 2018 1:28 PM

Reply Helpful

Jan 14, 2018 1:43 PM in response to Philly_Phan In response to Philly_Phan

No. Sorry, not the issue at all.


While I’m typing a text or email iOS autocorrect decides to capitalise random words. It literally tried to capitalise the word “random” as I was typing this. WHY? There is zero reason for that word to be capitalised.

Jan 14, 2018 1:43 PM

Reply Helpful (2)

Jan 14, 2018 3:49 PM in response to dmonkee70 In response to dmonkee70

dmonkee70 wrote:


While I’m typing a text or email iOS autocorrect decides to capitalise random words. It literally tried to capitalise the word “random” as I was typing this. WHY? There is zero reason for that word to be capitalised.

Because it's not working correctly. Turn off that function and make the decision manually.

Jan 14, 2018 3:49 PM

Reply Helpful
Question marked as Helpful

Jan 16, 2018 7:26 AM in response to xaviertee In response to xaviertee

Come on @apple! This is ridiculous, this is just one of the many issues with the new ios 11, i keep thinking the next update will fix these annoying bugs. My phone keeps capitalizing "your"......I have NO CONTACTS WITH "your" in them.

Jan 16, 2018 7:26 AM

Reply Helpful (5)
User profile for user: xaviertee

Question: Auto Capitalization in iOS 11