Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Emoji window keeps appearing

Not sure if this is a High Sierra bug or something my niece did when she randomly hit keys on my Mac. I keep having the emoji window appear frequently and at random, to the point where it's becoming annoying. I click in a text field and it pops out, I switch apps and it appears on screen, I switch open windows within apps and it appears.


It seems everything I do makes the emoji window open and I've got fed up with having to close it all the time. Is there a reason why this is appearing and any way to stop it?

MacBook Pro with Retina display, macOS High Sierra (10.13), 2GHz, 8GB RAM, 256GB, 13 inch

Posted on Oct 11, 2017 1:33 AM

Reply

Oct 15, 2017 4:17 AM in response to daniellefromrichmond In response to daniellefromrichmond

Annoying isn't it. The best thing you can do is restart your machine, that's what I do whenever it crops up. Avoid using emoji in Messages or anything else too, so far I haven't had it happen as long as I steer clear of them. I've reported it to Apple so hopefully it gets fixed.

Oct 15, 2017 4:17 AM

Reply Helpful (2)

Nov 22, 2017 8:02 AM in response to TJ Skywasher In response to TJ Skywasher

To disable that, first of all head over to Keyboard in System Preferences. Click Input sources tab.

User uploaded file

Check the box that says, "Show input menu in menu bar".User uploaded file

Most likely in your menu bar, a blank menu will appear, click that and click Hide(null) , so that it turns to Show(null).User uploaded file

User uploaded file

That's it. Problem Solved.

Nov 22, 2017 8:02 AM

Reply Helpful (1)
User profile for user: TJ Skywasher

Question: Emoji window keeps appearing