Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Final Cut Pro X

Just upgrade to OS 10.13.1 and noticed the Final Cut Pro X was crossed out and said had to upgrade the version .

Downloaded it from the apple store and installed it but it will not run and again asks the same to download the newest ver.?Anyone else having problems?

Larry

IMAC (RETINA 5K, 27-INCH, LATE 2015), OS 10.13.1

Posted on

Reply

Page content loaded

Nov 11, 2017 11:29 AM in response to UrQlr In response to UrQlr

So did you redownload the trial version? I don’t understand. The links in some countries I know are for earlier trial versions like 10.3.1 or 2 and we’re not updated. The trial version on the US FCP page I know is the current version 10.3.4.

Nov 11, 2017 11:29 AM

Reply Helpful

Nov 11, 2017 2:58 PM in response to Tom Wolsky In response to Tom Wolsky

Tom, I tried your suggestion, still the same with requester asking to upgrade to newest version, deleted all files and application that are related ,rebooted the computer and re-downloaded the trial version with the same results with the Final Cut Pro X Trial icon having X across it's face.

I'll just have to wait and put my test project on hold until the problem is solved and put off buying the full version not knowing if it works with OS 10.13.1

Thanks Tom

Larry

Nov 11, 2017 2:58 PM

Reply Helpful
User profile for user: UrQlr

Question: Final Cut Pro X