Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: when I import videos from my video camera, the videos appear to get imported, and I can put them in my timeline. When I re-open iMovie at a later date, the videos are "missing". Repeating the process gives the same result.

It appears as if the import is only saving placeholders and the video camera has to be connected all the time for the import to work. I am using iMovie 10.1.8 and MacOs 10.13.1. I didn't have the problem importing still photos from my video camcorder.

Posted on

Reply
Question marked as Apple Recommended
Answer:
Answer:

Hi, Bob,


As a troubleshooting procedure, check one of these links that explain in detail the import process:


If your camera is file based:


http://help.apple.com/imovie/mac/10.1/#/movbc953953e


If your camera is tape based:


http://help.apple.com/imovie/mac/10.1/#/mov6af9c94c1


-- Rich

Posted on

Page content loaded

Question marked as Apple Recommended

Nov 11, 2017 1:38 PM in response to Bob Cebulski In response to Bob Cebulski

Hi, Bob,


As a troubleshooting procedure, check one of these links that explain in detail the import process:


If your camera is file based:


http://help.apple.com/imovie/mac/10.1/#/movbc953953e


If your camera is tape based:


http://help.apple.com/imovie/mac/10.1/#/mov6af9c94c1


-- Rich

Nov 11, 2017 1:38 PM

Reply Helpful

Nov 13, 2017 11:31 AM in response to Bob Cebulski In response to Bob Cebulski

I have a similar or exact same issue.

For years I have imported form a sony hand held (HDR-SR1) and the files would land nicely in Imovie where projects could be made. Now I get the import screen with the clips from the Sony, it looks as if they have transferred (after a time) , but if I disconnect the Sony video camera the files are gone.


I have a very kluggy workaround of moving the files directly to a mac folder and then importing to Imovie, however the files come as MTS files with no sound.....


I looked at the reference and have tried to ensure all those steps are followed.

Nov 13, 2017 11:31 AM

Reply Helpful
User profile for user: Bob Cebulski

Question: when I import videos from my video camera, the videos appear to get imported, and I can put them in my timeline. When I re-open iMovie at a later date, the videos are "missing". Repeating the process gives the same result.