Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Home folder permissions reset on high sierra missing

Hello. I started a fresh SSD by installing High Sierra. Due to the size of the libraries on my hdd, i chose not to use the migration assistant. This also allowed me to skip a bunch of stuff I no longer wanted.


As a result, file permissions are pretty messed up. For example, if i copied files from my old hdd under the Jason account, and moved them to the ssd under documents, any changes i make such as rename or delete require admin password prompt. I can read and open files only.


I have attempted several things. The two most relevant are resetting the owner in finder and cascading to enclosed items. What looked like might work is resetting home folder permissions found in recovery disk utility, reset password. But under High Sierra, there is no option to find the reset home folder permissions. When typing reset password, it brings up a popup of all users, and one time i went ahead and went thru the process to see if this option was just on another screen. Instead it just did a password reset.


I am comfortable with terminal, but not so great with file permissions. My family's files are the ones I need fixed, and thus I will log in to their accounts to do so. I think i got some failure permissions when trying chown.


Looking at other articles, and trying other things, i spent about 2 hours. I am not sure what home folder reset does under the covers, but surely there is a way under terminal.


Please can someone help?

iMac, macOS High Sierra (10.13.1)

Posted on

Reply
Question marked as Solved
Answer:
Answer:

If you haven't yet, try as explained in this Apple Support article:

https://support.apple.com/en-us/HT203538

Posted on

Page content loaded

Nov 11, 2017 5:17 PM in response to ishrugged In response to ishrugged

Thank you kindly for the response! I tried this, and it said successful. After i closed terminal, i tried renaming one of the files and again received the admin password prompt 😟.


It's really strange, IMHO. I can clearly see the proper owner of the files. I've even tried setting the owner to a different user and then coming back and setting them back to the original user.


If I look from ls -l in terminal, it says -rw-r--r--@ 1 MyUserName Staff.......


Is this a clue to the underlying permissions issue?

Nov 11, 2017 5:17 PM

Reply Helpful
User profile for user: JasonIAm

Question: Home folder permissions reset on high sierra missing