Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: TextEdit does not display entire document

Upgraded to macOS 10.13.1. Now TextEdit does not display the entire contents of previously existing .rtf documents. The document opens but only about 1/4 of previous content length is there. Contents are truncated at exactly the same place whether I open older backup copies from an external drive, or older versions via time machine. Document contents do remain however, and display properly if I open the file in Pages or Word. I've tried copying and renaming the file, and of course rebooting.

Posted on

Reply
Question marked as Helpful

Nov 12, 2017 8:09 AM in response to stenknep In response to stenknep

I experience the same problem. On further testing I found this workaround.


Try adjusting the document page width.

Move the mouse pointer to the right edge of the window where scroll bar appears.

Try dragging the right edge outward or inward

The scrollbar should snap back up allowing the scroll.


I don't know what causes this. There may be an issue with scrolling.

There’s more to the conversation

Read all replies

Page content loaded

Question marked as Helpful

Nov 12, 2017 8:09 AM in response to stenknep In response to stenknep

I experience the same problem. On further testing I found this workaround.


Try adjusting the document page width.

Move the mouse pointer to the right edge of the window where scroll bar appears.

Try dragging the right edge outward or inward

The scrollbar should snap back up allowing the scroll.


I don't know what causes this. There may be an issue with scrolling.

Nov 12, 2017 8:09 AM

Reply Helpful (2)

Nov 12, 2017 8:18 AM in response to dominic23 In response to dominic23

Thanks dominic23. This worked. I had to adjust the width several times to get to the end of the document, but with each adjustment the scroll bar moved up a little.


I then modified the document, saved and re-opened, but still have to go through the whole width adjustment procedure again.

Nov 12, 2017 8:18 AM

Reply Helpful

Nov 12, 2017 11:11 AM in response to stenknep In response to stenknep

Thank you for the feedback.

Tonight when I have little bit of time, I am going to try what Macjack suggested.

I will post the result here.


Another quirk I experienced was Smart Link menu option was turned off inadvertently.

I toggled the option and it seems working now.


Thanks again.

Nov 12, 2017 11:11 AM

Reply Helpful

Nov 12, 2017 11:28 AM in response to macjack In response to macjack

Thank you for the suggestion.

Tonight after taking few screenshots I will dump the .plist and test.



After noticing the problem, I have done all post upgrade routines like resets, repairs and start up in safe mode.

So far I have noticed only two bugs with the upgrade.

Both of them are in TextEdit.

They are:

1) Scroll bar not showing exact location where documents in a folder should be

2) Some hyperlinks not going smart when you copy and paste


Best.

Nov 12, 2017 11:28 AM

Reply Helpful

Nov 27, 2017 3:25 AM in response to macjack In response to macjack

Moving this along... I upgraded to HIgh Sierra over the weekend and ran into this issue.


I find that previewing the document (space bar from finder) yields the same problem.... a different apparent file endpoint each time I look at it. That leads me to think its an SSD problem (new mac was the upgrade).


The last entry on this thread was two weeks ago... has anyone (say Apple!!!???) found anything else?

Nov 27, 2017 3:25 AM

Reply Helpful
User profile for user: stenknep

Question: TextEdit does not display entire document