Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Can't use BusyCal or Fantastical - error 403

I've addressed this to the developers of BusyCal and Fantastical. We all feel this must be an Apple iCloud error as both apps give me the same results.


I am versed in generating the App Specific Passwords and have done so to get emails from backup apps and such.


To allow either of these calendaring applications to use my iCloud for sync I generate an app specific password. However when I enter the pw each returns to the enter pw screen. Eventually Fantastical will show a dialog box saying it has "encountered an error while communicating with the server. Error: Request failed with status code 4023. https://caldav.icloud.com"


I have used BusyCal successfully with these app specific passwords until about 3 days ago when both my Mac began asking for then refusing my previously working app specific password and any newly created ASP.


So I downloaded a trial of Fantastical and encounter the same problem.


I don't find Apple Calendar to be viable but it WORKS (no special password needed so no surprise).


While troubleshooting I have:

Signed completely out of iCloud on a computer - letting it remove from my computer the calendar, keychain, etc.


Deleted The entire ~/Library/Cache folder

delete any file in Preferences ~/Library/Preferences/come.apple.calendar.*

and looked in Application Support and Assistance for any "calendar" items.


Then I re-sign into my iCloud and tried again to no luck.


Restarted each computer.


I'm quite frustrated and hope someone knows workable solutions.


thanks

qb


Message was edited by: qbpals I attempted to correct the Community selection which had defaulted to Safari. Could not "move it" to iCloud.

iMac with Retina 5K display, macOS Sierra (10.12.6), null

Posted on

Reply

Page content loaded

Nov 12, 2017 8:22 AM in response to qbpals In response to qbpals

Try setting up another admin user account to see if the same problem continues. If Back-to-My Mac is selected in System Preferences, the Guest account will not work. The intent is to see if it is specific to one account or a system wide problem. This account can be deleted later.


Isolating an issue by using another user account


If the problem is still there, try booting into the Safe Mode using your normal account. Disconnect all peripherals except those needed for the test. Shut down the computer and then power it back up after waiting 10 seconds. Immediately after hearing the startup chime, hold down the shift key and continue to hold it until the gray Apple icon and a progress bar appear. The boot up is significantly slower than normal. This will reset some caches, forces a directory check, and disables all startup and login items, among other things. When you reboot normally, the initial reboot may be slower than normal. If the system operates normally, there may be 3rd party applications which are causing a problem. Try deleting/disabling the third party applications after a restart by using the application un-installer or by using the developer’s uninstall instructions. For each disable/delete, you will need to restart if you don't do them all at once.





Safe Mode - About El Capitan
also Sierra


Safe Mode Startup – El Capitan. also Sierra


If it works in the Safe Mode, try running this program when booted normally and then copy and paste the output in a reply. The program was created by Etresoft, a frequent contributor. Please use copy and paste as screen shots can be hard to read. On the screen with Options, please open Options and check the bottom 2 boxes before running. Click “Share Report” button in the toolbar, select “Copy to Clipboard” and then paste into a reply. This will show what is running on your computer. No personal information is shown.

Etrecheck – System Information

Nov 12, 2017 8:22 AM

Reply Helpful

Nov 12, 2017 8:56 AM in response to Eric Root In response to Eric Root

@Eric - very concise suggestions but neither allowed BusyCal or Fantastical to connect using a newly generated App Specific PW. Not in Safe Mode nor with a brand spanking new admin user account.


To confirm once I created the new admin user and logged in for the first time I opened Sys Prefs->iCloud and successfully signed in using my account. And I made sure that my Apple Calendar had all my events that had been added by my previous years of using BusyCal (including since the requirement of App Specific passwords).


As a side not I will say my MacBook Pro with Touch Pad has screen rendering quirks without whatever drivers loading. Not that this has anything to do with the CalDav 403 error. Just made doing anything with applications difficult.


Bottom line is I am still unable to use BusyCal (as I could until about 4 days ago) nor can I test a trial version of Fantastical.

Nov 12, 2017 8:56 AM

Reply Helpful

Nov 13, 2017 4:33 AM in response to LACAllen In response to LACAllen

@LACallen - I have not changed my Apple ID password. I know it and have mentioned signing into iCloud when I created the new admin account on my MBPro to test Calendar (then BusyCal and Fantastical).


And on my actual user account I have logged out of iCloud and back in as a test.


If you are thinking I should change / update to another password as a test I suppose I could do that.


For the ASP's: I have tried both and already existing ASP that I had recorded and used with BusyCal in the past. But I've also generated several new ones and tried new ones in an attempt to get BC and FC to talk with the CalDAV service.

thank you

qb

Nov 13, 2017 4:33 AM

Reply Helpful

Nov 13, 2017 5:00 PM in response to qbpals In response to qbpals

My thought was.. when you change your account password, all ASP's are "revoked"


In troubleshooting, it was possible your sequence of events might have had you referencing an ASP you created before changing your Apple ID password.

Nov 13, 2017 5:00 PM

Reply Helpful

Nov 13, 2017 5:14 PM in response to LACAllen In response to LACAllen

@LACAllen - wow - I did not know that ASP's got "revoked" with a change of password. Glad to know that tip for the future.


Sadly I've not changed my Apple iCloud PW in a few "months" and certainly did not change it right before BusyCal started asking for the ASP pw on each Mac.


thanks for the idea and the info I hope I will remember for the future.

qb

Nov 13, 2017 5:14 PM

Reply Helpful

Nov 13, 2017 5:17 PM in response to qbpals In response to qbpals

No problem. Sorry it isn't your solution.


When you think it out... an ASP is simply a one time verification code, added to your current password, scrambled again and kept as a single entry password. Apple's servers recognize it as a verification code plus your current password when sent by a 3rd party app.

Nov 13, 2017 5:17 PM

Reply Helpful

Nov 13, 2017 5:19 PM in response to qbpals In response to qbpals

This morning (Monday morning) I spent about an hour on the Apple help phone line. Got escalated once, they did a remote session and eventually had me send along a collection of system info files. I am due for a callback 9am Thursday so purrrrhaps I'll be informed of a solution. I will report back.


Also while talking to Apple support I recalled another quirk of my iCloud account access. As we know when logging into APPLEID.APPLE.COM one is typically confronted with the 2 step sign in. I NEVER get any 6-digit code via my other devices (and I have 3 Macs and 2 iPads). NEVER. I always have to click the "Did not receive" and then "Call me with..." Which is a pain as I do not use a cell phone and thus can only be called when home. Perhaps if Apple gets this ASP thing working I can get the notification working.


cheers

qb

Nov 13, 2017 5:19 PM

Reply Helpful
User profile for user: qbpals

Question: Can't use BusyCal or Fantastical - error 403