Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: AppStore update requires iOS 11.1.0 or newer

Yesterday, I was updating apps on my iPhone (with iOS 11.1.0), when it said a couple of times that an app requires iOS 11.1.0 or newer. (or download a prior version -- isn't that what I already have?)


So, this morning I upgraded to 11.1.1, and there are two app updates, but they now require iOS 11.1.1 or newer...


Granted the latest update of the apps says they added "iPhone X compatibility," which probably doesn't matter as I have a 7 plus (purchased new in August 2017, when my 6 plus split open along its side...a month after I had paid it off through carrier financing.)


PS: I later got a refurbished 6 plus after sending it in for battery repair. The 6 plus is a 64GB Gold, while my new 7 plus is a 256GB Red.

iPhone 7 Plus, iOS 11.1

Posted on

Reply

Page content loaded

Nov 12, 2017 9:41 AM in response to TheDreamer68 In response to TheDreamer68

iOS 11.x requires all apps to be 64 bit. You're referring to apps that the app developer has not updated to 64 bit and will not run on your phone unless the app developer updates them. Given the app developers have had months and months to accomplish this, it would seem apparent they may not update the apps and thus they won't run. Your best option is to reach out to the app developers and ask them if they have any plans to update their apps. If they don't, they're now useless.

Nov 12, 2017 9:41 AM

Reply Helpful

Nov 12, 2017 9:58 AM in response to TheDreamer68 In response to TheDreamer68

"Granted the latest update of the apps says they added "iPhone X compatibility," which probably doesn't matter as I have a 7 plus"


If they compiled the application with "Development target" (an xcode per-app setting) set to "11.1" then 11.1 is what it will require. The developer will then have access to extra API functionality for the newer functionality and devices.

Nov 12, 2017 9:58 AM

Reply Helpful
User profile for user: TheDreamer68

Question: AppStore update requires iOS 11.1.0 or newer