Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Installing "legacy Java SE 6 runtime"

I updated my mac laptop to mac OS High Sierra. In order to run my Photoshop CS3 program i have been asked to download "legacy Java SE 6 runtime" How do I do that?

MacBook Pro (Retina, 15-inch, Mid 2014), macOS High Sierra (10.13.1)

Posted on

Reply
Question marked as Apple Recommended
Answer:
Answer:

Download Java for OS X 2017-001

Posted on

Question marked as Helpful

Jan 4, 2018 2:43 PM in response to Kappy In response to Kappy

Some programs require legacy Java SE 6 runtime to work. The newer versions will not allow some programs to function at all. They will say: "To open “xxxxxxx” you need to install the legacy Java SE 6 runtime."


The issue is how to install the older version too, so the programs that require the old version will work.

There’s more to the conversation

Read all replies

Page content loaded

Question marked as Helpful

Jan 4, 2018 2:43 PM in response to Kappy In response to Kappy

Some programs require legacy Java SE 6 runtime to work. The newer versions will not allow some programs to function at all. They will say: "To open “xxxxxxx” you need to install the legacy Java SE 6 runtime."


The issue is how to install the older version too, so the programs that require the old version will work.

Jan 4, 2018 2:43 PM

Reply Helpful (8)

Jan 24, 2018 5:40 PM in response to CountryGirl56 In response to CountryGirl56

Having same issue and I've gone to this link. But do not see the Legacy Java SE6??? Just this....Keep your software up to date. If you need Java, download the latest version of Java for OS X directly from Oracle https://www.java.com


I have done the latest version download and still have the same issue....What am I missing??

Jan 24, 2018 5:40 PM

Reply Helpful (1)

Feb 4, 2018 6:53 PM in response to bernadettemertensmcallister In response to bernadettemertensmcallister

Did you figure this out? I am having the same issue! I uninstalled the newer version of Java and have been trying to download and install the SE6 but it keeps saying a newer version is installed, but its gone.

Feb 4, 2018 6:53 PM

Reply Helpful

Feb 4, 2018 11:18 PM in response to jeanettefromgretna In response to jeanettefromgretna

Hi,


Yes, I figured it out; the problem was that I was trying to use an older (2014) SE6 package... the 2017 one is available here:

https://support.apple.com/kb/dl1572?locale=en_CA

Install that and you should be ok!

Feb 4, 2018 11:18 PM

Reply Helpful

Mar 1, 2018 2:46 PM in response to Kappy In response to Kappy

The link in your post no longer seems to work. There are some YouTube videos showing the exact same link used to correct the problem of legacy Adobe CS programs not being able to run, however the download button no longer seems to function.

Mar 1, 2018 2:46 PM

Reply Helpful

Mar 12, 2018 9:08 PM in response to Kappy In response to Kappy

Thank you! After searching over an hour, most of the other answers pointed to a page mentioning that SE 6 is very old and therefore not available, I found your answer, downloaded that Java installer and now I can continue using Adobe Illustrator CS3. Thank you again

Mar 12, 2018 9:08 PM

Reply Helpful
User profile for user: bernadettemertensmcallister

Question: Installing "legacy Java SE 6 runtime"