Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Download Older OS

MBP 15" i7 2.3 mid 2012 MD103LL/A


Finally happened, my wife spilled coffee on keyboard, just a few drops she said the next day when I was informed it was acting 'funny'. I opened it up disconnected the power, pulled the HD, and put a fan on it. She was in the middle of a book project and hadn't backed up for a few days. Data on drive was hand transferred to her new MBP and at some point she did something that hosed the OS which I discovered after reinstalling the HD in the old MBP.


I starts up and seems fine but can't find OS. What I need to do is D/L OS. Can I do that on a different (and much) newer MBP? When I finally found where to get them I was presented with Yosemite and Mavericks as having been 'purchased' and avail for D/L in AP store. How do I get it/them to the HD of the old MBP while it's connected as external drive? I have seen messages about 'system being to new' and 'install on this computer'


Is it possible to D/L direct to the external drive, reinstall that back in to the old MBP then run the installer? IIRC the orig OS on this was Lion but that doesn't seem available.


Thanks for any help.

MacBook Pro, OS X Yosemite (10.10)

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Use a product such as DiskMaker X to create an installation thumbdrive from the installer.


(154995)

Posted on

There’s more to the conversation

Read all replies

Page content loaded

Nov 12, 2017 11:58 AM in response to Niel In response to Niel

Thanks. Available are Yosemite dated 12/18/14 and el Cap dated 1/14/16. The latter has "install" button and returns a "this copy of OSX Install is too old to be opened on this computer" with a quit button. Yosemite had a D/L button and is currently doing just that, though I do not see where it is being placed at this point. DSL here not fast so ...

Nov 12, 2017 11:58 AM

Reply Helpful

Nov 12, 2017 4:32 PM in response to Niel In response to Niel

Thanks again!


...but... anything but copying the install.app pops up the "too old to install on this machine" message. Copied to HD.

Reinstalled the HD and get flashing ? folder. Have to open back up and pull power from battery as button will not function. Machine did start itself up after reassembly when magsafe was connected. cmmd+R flashes a globe/map and then the ? folder flashes. How can I get the installer to run?

Nov 12, 2017 4:32 PM

Reply Helpful

Nov 12, 2017 6:21 PM in response to Niel In response to Niel

Thank you, this seems to have done the trick. I haven't to do anything like this since probably 10.1 and am quite rusty. There are some sticky keys it appears (n&m) which was fun when I ran DU and repaired/formatted a vol named n(100+) but the Captain is installing at this moment. Again thanks for the assist!


Mark

Nov 12, 2017 6:21 PM

Reply Helpful
User profile for user: MarkMc19

Question: Download Older OS