Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: iMovie crashes at launch, what to do?

Dear Apple community


I need your help. Imovie keeps crashing when I try to launch it. I'm an experienced iMovie user and this has never happened to me before.


I just updated my system to macOS High Sierra version 10.13.1 and this is the first time I use imovie after the update. I'm working on a project I started in the previous version of iMovie and macOS. It worked fine the first couple of hours, then suddenly it crashed and kept crashing when I tried to restart the program.


I have tried shutting down all other applications and restarting the computer with no success.u help will be greatly appreciated. I have a deadline.

MacBook Pro (15-inch, Late 2016), macOS High Sierra (10.13.1)

Posted on

Reply

Page content loaded

Nov 12, 2017 1:15 PM in response to PhilipHP In response to PhilipHP

Here is an extract of the crash report (Can't fit it all in here)


Process: iMovie [2335]

Path: /Applications/iMovie.app/Contents/MacOS/iMovie

Identifier: com.apple.iMovieApp

Version: 10.1.8 (311956)

Build Info: iMovieX-31195006019000000~1

App Item ID: 408981434

App External ID: 824158953

Code Type: X86-64 (Native)

Parent Process: ??? [1]

Responsible: iMovie [2335]

User ID: 501


Date/Time: 2017-11-12 21:25:44.721 +0100

OS Version: Mac OS X 10.13.1 (17B48)

Report Version: 12

Bridge OS Version: 3.0 (14Y661)

Anonymous UUID: 421A7090-25A9-160A-5AD6-B79868E57E81



Time Awake Since Boot: 5700 seconds


System Integrity Protection: enabled


Crashed Thread: 39 Dispatch queue: com.apple.root.default-qos


Exception Type: EXC_CRASH (SIGABRT)

Exception Codes: 0x0000000000000000, 0x0000000000000000

Exception Note: EXC_CORPSE_NOTIFY


Application Specific Information:

-[QCCGLRootContext minimalSharedContextForCurrentThread]: Inconsistent state

abort() called


Application Specific Backtrace 1:

0 CoreFoundation 0x00007fff2df502fb __exceptionPreprocess + 171

1 libobjc.A.dylib 0x00007fff548bdc76 objc_exception_throw + 48

2 CoreFoundation 0x00007fff2df50249 -[NSException raise] + 9

3 QuartzComposer 0x00007fff389e8672 GFException + 278

4 QuartzComposer 0x00007fff389eb5b3 GFThrowException + 292

5 QuartzComposer 0x00007fff3899197f -[QCCGLContext minimalSharedContextForCurrentThread] + 243

6 QuartzComposer 0x00007fff3899155f -[QCOpenGLContext startRenderingPatch:options:] + 61

7 QuartzComposer 0x00007fff389bfdb8 -[QCRenderer initWithRenderingContext:patch:] + 374

8 QuartzComposer 0x00007fff38a3644a -[QCRenderer initOffScreenWithPixelFormat:size:colorSpace:patch:] + 1078

9 QuartzComposer 0x00007fff38a3685b -[QCRenderer initOffScreenWithSize:colorSpace:composition:] + 155

10 Flexo 0x000000010e9232f1 -[FFIMTrailerInfo newThumbnailOfSize:] + 1361

11 Flexo 0x000000010e923477 -[FFIMTrailerInfo thumbnail] + 71

12 Flexo 0x000000010e923630 __50+[FFIMTrailerInfo preloadThumbnailsForTrailerIDs:]_block_invoke + 272

13 libdispatch.dylib 0x00007fff5547a6cd _dispatch_call_block_and_release + 12

14 libdispatch.dylib 0x00007fff55472e88 _dispatch_client_callout + 8

15 libdispatch.dylib 0x00007fff5547fda5 _dispatch_queue_override_invoke + 880

16 libdispatch.dylib 0x00007fff55474a7a _dispatch_root_queue_drain + 515

17 libdispatch.dylib 0x00007fff55474826 _dispatch_worker_thread3 + 101

18 libsystem_pthread.dylib 0x00007fff557361ca _pthread_wqthread + 1387

19 libsystem_pthread.dylib 0x00007fff55735c4d start_wqthread + 13

Nov 12, 2017 1:15 PM

Reply Helpful

Nov 12, 2017 1:32 PM in response to PhilipHP In response to PhilipHP

It may be a corrupted plist file.

I don’t use iMovie but following what is common in FCP X

I’d try starting iMovie while holding down command and option (that is the standard way to clear preferences in FCP X).

Nov 12, 2017 1:32 PM

Reply Helpful

Nov 12, 2017 3:08 PM in response to Luis Sequeira1 In response to Luis Sequeira1

Thank you for the tip Luis. I must admit the issue some how resolved it self after, I gave the computer some rest and then just tried a regular launch again. Have no idea what happened, but glad I got to finish my video before deadline.

Nov 12, 2017 3:08 PM

Reply Helpful
User profile for user: PhilipHP

Question: iMovie crashes at launch, what to do?