Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: HELP! Messages will no longer longer on Mac

Hi folks,


For some reason, I cannot seem to be able to use Messages on my Mac anymore, accept for Bonjour.

When I go onto the 'accounts' section in its prefs, it says iMessage is inactive, but I'm not able to active it when I click on it. Also, I cannot delete the iMessage account; the minus sign won't allow me to click and highlight it.
When I try to add an account by using the plus sign, I can choose Google, Yahoo, AOL, and other; iCloud/Messages isn't listed.

Any idea where I can find the pref to trash it? Will that work like it did back in the iChat days?


Also, very interesting...

When I boot from my other internal drive, Messages works perfectly! Unfortunately, I don't like to use that drive as my boot drive. If I try to drag one version of Messages to the other hard drive, it won't overwrite it.

Posted on

Reply

Page content loaded

Nov 13, 2017 9:19 AM in response to DaDrainer In response to DaDrainer

Might be a corrupt .plist.


Do a backup, preferably 2 backups on 2 separate drives.


Quit the application.


Go to Finder and select your user/home folder. With that Finder window as the front window, either select Finder/View/Show View options or go command - J. When the View options opens, check ’Show Library Folder’. That should make your user library folder visible in your user/home folder. Select Library. Then go to Preferences/com.apple.iChat.plist. Move the .plist to your desktop.


Restart the computer, open the application and test. If it works okay, delete the plist from the desktop.

If the application is the same, return the .plist to where you got it from, overwriting the newer one.


If that doesn’t work, repeat the above but delete the com.apple.imagent.plist.


Thanks to leonie and Ralph Johns (UK)for some information contained in this.

Nov 13, 2017 9:19 AM

Reply Helpful

Nov 13, 2017 1:19 PM in response to DaDrainer In response to DaDrainer

Hi,


I would use this Users Tip When the iMessages account will not Login



User uploaded file

9:19 pm Monday; November 13, 2017


 iMac 2.5Ghz i5 2011 (Sierra)
 G4/1GhzDual MDD (Leopard 10.5.8)
 MacBookPro 2Gb (Snow Leopard 10.6.8)
 Mac OS X (10.6.8),
 iPhone 6 iOS 11.x and an iPad (2)

Nov 13, 2017 1:19 PM

Reply Helpful
User profile for user: DaDrainer

Question: HELP! Messages will no longer longer on Mac