Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Safari "Allow all auto-play" not working on Youtube playlist.

I was using chrome regularly and decided to switch to safari after the macOS High Sierra update. While using chrome, I used youtube as my source of music and there was no problem of it playing a playlist in the background while I was on other tabs. But when I switched to Safari, I noticed that even though I set my youtube website settings as "Allow all auto-play", a playlist wouldn't keep playing a video after another. What should I do to change this? I want to use youtube in safari as the way I used to in chrome.

MacBook Pro with Retina display, operating system is 10.13.1

Posted on

Reply

Page content loaded

Feb 5, 2018 3:56 PM in response to hanbeomlee In response to hanbeomlee

Hello,

Apple has recently decided to control spam and ad videos and hence the autoplay might not be working on your Safari.

You can do the following and it should be fixed:

Open Youtube > Click Safari > Settings for this website > Change 'Auto-Play' setting to Allow always.


Should work! 🙂

Feb 5, 2018 3:56 PM

Reply Helpful
User profile for user: hanbeomlee

Question: Safari "Allow all auto-play" not working on Youtube playlist.