Related Article

If you can't send or receive messages on your iPhone, iPad, or iPod touch

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Red exclamation in Messages

Working on iMac message app and red exclamation point pops up - will receive, but not send - other devices working fine - just nothing sending from iMac message app. Internet works fine. What else can I do

iMac, iOS 11.1

Posted on

Reply
Question marked as Helpful

Nov 14, 2017 10:07 AM in response to thutty In response to thutty

Thanks for the update, thutty! We appreciate you providing that information.


Since the previous steps have not solved the issue, I would next recommend turning Text Message Forwarding, and iMessage, off on both your iPhone and your iMac, restarting both, then setting everything back up first on the iPhone, then on your iMac.

Sign in with your Apple ID - Apple Support outlines how to sign into your Apple ID for various services, including iMessage, on both the iPhone and the Mac. You can use those same steps to sign out, as well. Likewise, the following steps from Use Continuity to connect your Mac, iPhone, iPad, iPod touch, and Apple Watch - Apple Support will show you how to set up Text Forwarding on your devices, and you can use those same steps to turn it off, as well:


Set up SMS and MMS messaging

Use this feature with any Mac, iPhone, iPad, or iPod touch that meets the Continuity system requirements. Make sure that your devices are set up as follows:

  • Each device is signed in to iCloud with the same Apple ID.
  • On iPhone, go to Settings > Messages > Send & Receive. Make sure that the Apple ID at the top of the screen is the same Apple ID that you're using for iMessage on your other devices. Add a check to your phone number and email address, so that you can be reached by iMessage at both. Do the same on your iPad or iPod touch.
  • On iPhone, go to Settings > Messages > Text Message Forwarding, then choose which devices to allow to send and receive text messages from this iPhone. If you're not using two-factor authentication for your Apple ID, a verification code appears on each of your other devices: enter that code on your iPhone.
  • On Mac, open Messages, then choose Messages > Preferences. Click Accounts, then select your iMessage account. Make sure that the Apple ID shown here is the same Apple ID that you're using on your other devices. Add a check to your phone number and email address.




Have a lovely day!

There’s more to the conversation

Read all replies

Page content loaded

Nov 13, 2017 12:43 PM in response to thutty In response to thutty

Hey there, thutty!


Thanks for visiting the Apple Support Communities. From your post, I understand that you are having trouble sending iMessages from the Messages app on your iMac. While you can receive messages just fine, if you try to respond or start a new message, you get a red exclamation mark. I'd be happy to help!


Based on what you've described, I would first recommend quitting the Messages app. You can do this from the Messages app by pressing Command+Q or clicking Messages in the Menu bar and choosing Quit Messages from the drop down. Then, open the Messages app again while holding the Shift key on your keyboard. Once opened, try sending a message.

If the red exclamation mark pops up again, I would next suggest restarting your iMac. To restart, click the Apple  menu, and choose "Restart..." from the dropdown. After the computer boots up, open Messages and try sending.

Should you continue to be unable to send, test Messages in safe mode, and a new user account. You can get information on why these steps are helpful, how to boot to safe mode, and how to set up a new user, in the following articles:

Use safe mode to isolate issues with your Mac - Apple Support
How to test an issue in another user account on your Mac - Apple Support
If the issue persists, don't hesitate to respond back. If you do, please include the current OS X or macOS version installed on your iMac (found by selecting Apple  menu > About This Mac), and details on the results of your troubleshooting. Also, please advise whether you are using Text Message Forwarding, which uses your iPhone's SMS text service to send and receive messages from non-iMessage users (such as Android phones) on your Mac.
Cheers!

Nov 13, 2017 12:43 PM

Reply Helpful

Nov 13, 2017 7:43 PM in response to thutty In response to thutty

Unfortunately, safe mode did not work either; re-booting did not work.


Operating system is macOS Sierra Version 10.12.6


Yes, using text message forwarding...

Nov 13, 2017 7:43 PM

Reply Helpful
Question marked as Helpful

Nov 14, 2017 10:07 AM in response to thutty In response to thutty

Thanks for the update, thutty! We appreciate you providing that information.


Since the previous steps have not solved the issue, I would next recommend turning Text Message Forwarding, and iMessage, off on both your iPhone and your iMac, restarting both, then setting everything back up first on the iPhone, then on your iMac.

Sign in with your Apple ID - Apple Support outlines how to sign into your Apple ID for various services, including iMessage, on both the iPhone and the Mac. You can use those same steps to sign out, as well. Likewise, the following steps from Use Continuity to connect your Mac, iPhone, iPad, iPod touch, and Apple Watch - Apple Support will show you how to set up Text Forwarding on your devices, and you can use those same steps to turn it off, as well:


Set up SMS and MMS messaging

Use this feature with any Mac, iPhone, iPad, or iPod touch that meets the Continuity system requirements. Make sure that your devices are set up as follows:

  • Each device is signed in to iCloud with the same Apple ID.
  • On iPhone, go to Settings > Messages > Send & Receive. Make sure that the Apple ID at the top of the screen is the same Apple ID that you're using for iMessage on your other devices. Add a check to your phone number and email address, so that you can be reached by iMessage at both. Do the same on your iPad or iPod touch.
  • On iPhone, go to Settings > Messages > Text Message Forwarding, then choose which devices to allow to send and receive text messages from this iPhone. If you're not using two-factor authentication for your Apple ID, a verification code appears on each of your other devices: enter that code on your iPhone.
  • On Mac, open Messages, then choose Messages > Preferences. Click Accounts, then select your iMessage account. Make sure that the Apple ID shown here is the same Apple ID that you're using on your other devices. Add a check to your phone number and email address.




Have a lovely day!

Nov 14, 2017 10:07 AM

Reply Helpful (1)

Jan 11, 2018 3:52 PM in response to thutty In response to thutty

I am still having this problems - seems to happen when the iMac is rebooted or restarted...

Jan 11, 2018 3:52 PM

Reply Helpful
User profile for user: thutty

Question: Red exclamation in Messages