Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: TextEdit forgets Preferences

Not a huge deal, but it's annoying:


Occasionally TextEdit forgets my settings for "format", and "open and save". I like to have it open in plain text, and display HTML files as code.


It keeps going back to the default rich text format setting. Not every time I open it, but once every few days. This has only started lately. What's up?


I'm running macOS High Sierra 10.13.1 on an iMac.

IMAC (RETINA 5K, 27-INCH, LATE 2015), macOS High Sierra (10.13), null

Posted on

Reply

Page content loaded

Nov 13, 2017 12:50 PM in response to mfisher81 In response to mfisher81

Greetings mfisher81,

Thank you for using Apple Support Communities. It seems like TextEdit is not remembering your preference settings. One thing that you can do is move the com.apple.TextEdit.plist to the desktop. It is located in Macintosh HD > Users > username > Library > Preferences. From the Finder window if you hold the option key and click Go on the menu bar Library will become available. When you restart the computer it will repopulate the file, then set the preferences you would like and test if it retains the settings.

Take care.

Nov 13, 2017 12:50 PM

Reply Helpful

Nov 29, 2017 1:48 PM in response to mfisher81 In response to mfisher81

Hey mfisher81,

Thanks for the update. Since the issue has returned it sounds like there is something causing this to happen. Sometimes there can be items that interfere with the way other apps work that run in the background. One thing you can do is remove login items that launch when you log in to the computer. This will help further isolate what may be causing this to happen or allow TextEdit to work as expected.


Add or remove automatic items

  1. Choose Apple menu > System Preferences, then click Users & Groups.

  2. Select your user account, then click Login Items at the top of the window.

  3. Do one of the following:

    • Add a login item: Click the Add button User uploaded file below the list of items, select a document, folder, app, server, or other item, then click Add.

    • Remove a login item: Select the name of the item you want to prevent from opening automatically, then click the Remove button User uploaded file below the list.

macOS Sierra: Open items automatically when you log in


Cheers.

Nov 29, 2017 1:48 PM

Reply Helpful
User profile for user: mfisher81

Question: TextEdit forgets Preferences