Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Final Cut Express

I am still running an old version of Final Cut Express. After upgrading to High Sierra, it won't open. It says I need an update, but there appears to be no update for Final Cut Express. Is there a work around?

Posted on

Reply

Page content loaded

User profile for user: foxdm

Question: Final Cut Express