Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: CVS files not correctly displayed in Numbers

I Have csv files from a bank, till 8 nov. 2017 they were displayed correctly in numbers.

Files downloaded after nov. 9th are not formatted the right way, it seems numbers doesn't recognize the ";" as a separater. Same problem on MacBook Pro and Imac

I can't see a difference between these files ( with Hex viewer ).

In Excel they open normal.


Numbers : ver. 4.3.1 (5249)

OS : 10.13.1

Posted on

Reply

Page content loaded

Nov 13, 2017 1:10 PM in response to DanielLamair In response to DanielLamair

Not sure what is going on there.


However, for things like this I use this CSV to Tabs on Clipboard Automator Services (Dropbox download).


To install just double-click the downloaded .workflow package and give permission at System Preferences > Security & Privacy. Also make sure 'Automator.app' is checked at System Preferences > Security & Privacy > Privacy > Accessibility.


Thereafter to use all you have to do is find the downloaded csv file in Finder, right-click or option-click it, and in Finder's File > Services menu choose 'CSV to Tabs on Clipboard'. You would then choose the ; at the prompt.


Then click once in a Numbers cell where you want the data, and type command-v or choose Edit > Paste and Match Style from the menu.


I find this easier than File > Open a csv file in Numbers, then having to move the data where I want it. Also this Service can handle many delimiters that you are likely to encounter, including ; .


SG

Nov 13, 2017 1:10 PM

Reply Helpful
User profile for user: DanielLamair

Question: CVS files not correctly displayed in Numbers