Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Mac messages - cannot send sms

Hey all,


I used to be able to use my mac to send sms and imessages, but now it seams I am only able to send imessages.
When I send via sms (e.g., to a non-iphone), i get a red exclamation mark and "Not delivered".


What changed?

Am I doing something wrong?


Cheers.

MacBook, Mac OS X (10.7.4), Upgraded to 4gb memory and 250 HD

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Hi,


OK, so the iMessages part is syncing again.

Go to the Text Forwarding section in the iPhone Settings for Messages and turn the option Off.


Wait then turn it On Again.

Select the Mac again and you should get an new Code Number on the Mac to enter back on the iPhone to link them up again.


It is important that the iPhone is on the same LAN as the Mac, and if you are using two devices to route on your LAN that they are in the same Subnet.



User uploaded file

9:35 pm Tuesday; November 14, 2017


 iMac 2.5Ghz i5 2011 (Sierra)
 G4/1GhzDual MDD (Leopard 10.5.8)
 MacBookPro 2Gb (Snow Leopard 10.6.8)
 Mac OS X (10.6.8),
 iPhone 6 iOS 11.x and an iPad (2)

Posted on

Page content loaded

Nov 13, 2017 1:21 PM in response to andrevieir In response to andrevieir

Hi,


It sounds like the link between iPhone and Mac for SMS is no longer working.


On th iPhone turn the Option off then restart it and link back to the Mac.

You should get a new Code to link the two.



User uploaded file

9:21 pm Monday; November 13, 2017


 iMac 2.5Ghz i5 2011 (Sierra)
 G4/1GhzDual MDD (Leopard 10.5.8)
 MacBookPro 2Gb (Snow Leopard 10.6.8)
 Mac OS X (10.6.8),
 iPhone 6 iOS 11.x and an iPad (2)

Nov 13, 2017 1:21 PM

Reply Helpful

Nov 14, 2017 9:44 AM in response to Ralph Johns (UK) In response to Ralph Johns (UK)

Thanks Ralph


I turned of iMessages in the iphone. Shut-dow. Turned it on. Activated iMessages in iphone.


I got a message in my macbook saying that I activated iMessages in the iphone, however i still cannot send sms messages from macbook ;(


Should I call Apple customer care? I am no longer in the warranty period.


Thanks

Nov 14, 2017 9:44 AM

Reply Helpful
Question marked as Solved

Nov 15, 2017 1:00 PM in response to andrevieir In response to andrevieir

Hi,


OK, so the iMessages part is syncing again.

Go to the Text Forwarding section in the iPhone Settings for Messages and turn the option Off.


Wait then turn it On Again.

Select the Mac again and you should get an new Code Number on the Mac to enter back on the iPhone to link them up again.


It is important that the iPhone is on the same LAN as the Mac, and if you are using two devices to route on your LAN that they are in the same Subnet.



User uploaded file

9:35 pm Tuesday; November 14, 2017


 iMac 2.5Ghz i5 2011 (Sierra)
 G4/1GhzDual MDD (Leopard 10.5.8)
 MacBookPro 2Gb (Snow Leopard 10.6.8)
 Mac OS X (10.6.8),
 iPhone 6 iOS 11.x and an iPad (2)

Nov 15, 2017 1:00 PM

Reply Helpful (1)

Nov 15, 2017 1:37 PM in response to andrevieir In response to andrevieir

User uploaded file for the User uploaded file Points and for the User uploaded file Points.



User uploaded file

9:37 pm Wednesday; November 15, 2017


 iMac 2.5Ghz i5 2011 (Sierra)
 G4/1GhzDual MDD (Leopard 10.5.8)
 MacBookPro 2Gb (Snow Leopard 10.6.8)
 Mac OS X (10.6.8),
 iPhone 6 iOS 11.x and an iPad (2)

Nov 15, 2017 1:37 PM

Reply Helpful
User profile for user: andrevieir

Question: Mac messages - cannot send sms