Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: MacBook isn't receiving iMessages

My MacBook Pro isn't receiving iMessages sent to my phone number (which is working as usual) for my iPhone 6S and when I send iMessages from the MacBook Pro, they are received from the email address linked to my iCloud account. Is there any way to change the account settings, so I can send iMessages from my phone number on my MacBook?

MacBook Pro (Retina, 13-inch,Early 2015), iOS 10.1.1

Posted on

Reply

Page content loaded

Nov 14, 2017 1:37 PM in response to sammasonjones In response to sammasonjones

Hey, sammasonjones,


Thanks for visiting the Apple Support Communities! From your post, I understand that you would like to be able to use iMessage on your Mac with your iPhone mobile telephone number. I'd be happy to help!


You can add your phone number to Messages using the following steps from Use Continuity to connect your Mac, iPhone, iPad, iPod touch, and Apple Watch - Apple Support :

Turn your phone number on or off for your Mac

After you set up your phone number, you can turn it on or off for Messages and FaceTime on your Mac.

  1. Open Messages or FaceTime. If asked, sign in with the Apple ID you're using with Messages and FaceTime on your iPhone.
  2. In Messages, choose Messages > Preferences, then click Accounts and select your iMessage account. In FaceTime, choose FaceTime > Preferences, then click Settings.
  3. Turn your phone number on or off:
  4. If you want recipients to see your phone number and not your Apple ID, select your phone number from the “Start new conversations from” or ”Start new calls from” pop-up menu.

User uploaded file

Text messages that you send and receive on your iPhone can also be made to appear on your Mac, iPad, and iPod touch. Learn more.



Have a wonderful day!

Nov 14, 2017 1:37 PM

Reply Helpful
User profile for user: sammasonjones

Question: MacBook isn't receiving iMessages