Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Can't Re-Associate my iMac to Apple ID

Hi, and sorry – it's a long one.


I can no longer sign into iCloud or iMessage / FaceTime via iMac (OS X 10.11.6). The problem began with just iMessage, but has escalated to the point that I can no access my Apple.ID or iCloud from the iMac.


I do not have this problem on either iPhone 6 or MacBook Pro (OS X 10.11.6).


So far, I've tried the following:


Non-Invasive


⁃ Checked OSX 10.11.6 is fully updated.

⁃ Signing in from Safe Boot.

⁃ NVRAM and SMC reset.

⁃ On/Off switching of Location, Date & Time, and Firewall.

⁃ Various resets of Apple ID passwords and security questions.

⁃ First Aid from Recovery Mode. Exit Code 0, squeaky clean).

⁃ Signing in from a newly created secondary Admin account on the same partition.



Invasive:


Signing in from a repartitioned drive.


Deletion from ~/Library/Preferences of the following plists:


  • com.apple.ichat
  • com.apple.icloud
  • com.apple.ids.service
  • com.apple.ids
  • com.apple.identityserviced
  • com.apple.imfoundation
  • com.apple.imessage
  • com.apple.imservice
  • com.apple.madrid
  • com.apple.imessage.bag
  • com.apple.imagent.plist
  • com.apple.security


Removal of revoked certificates and deletion from Keychain of entries related to:


• IDS(user)Auth-Tokens

• ids:message-protection

• iMessage

• iMessage-protection.


From Terminal:


• killall identityserviced

• killall imagent

• killall securityd

• killall securityd_service


Ultra-invasive:


⁃ 3 litres of strong coffee and a half a bottle of Jack Daniels.


I then disassociated the iMac from my Apple ID, thinking I could simply add it back again and (perhaps) the problem would disappear. Who was I kidding? A whole new world of pain opened. Now I can't even log onto iCloud (so no Mail now, either).


User uploaded file


Before I'm asked: I can't reinstall OS X from Recovery Mode since I can no longer log in to my account via the iMac.


I do have a couple of copies of the OSX 10.11.6 image which I copied from the original download by aborting the install and locating the image file. But before using that, I'd need to be sure it's not going to compromise any PACE, iLok, or licence signings. It's my studio machine. Besides, I don't think it will solve anything since this seems to be an Apple issue, not an OS X problem (no problem on the MacBook, iMac functions perfectly apart from iClutter).


At some point in the chain it seems my iMac has been blocked/compromised by Apple. As stated, I have full functionality with the MacBook and iPhone.


Apple Support is giving me the traditional run-around, so hoping for some help here – maybe the Linc Davis co-operative is listening in ,-)


Any ideas?


Anyone want to buy an iMac? I'm going back to pen and paper.

iMac (Retina 5K, 27-inch, Late 2014), OS X El Capitan (10.11.6), 32GB/ 1TB SSD/ Core i7/ 4GHz

Posted on

Reply

Page content loaded

Nov 14, 2017 8:17 AM in response to AndyXII In response to AndyXII

Thanks Tim, but taking it to the Apple Store is the last option on my list. As I've already stated, the point of this post is to attract the attention of those who have some constructive pro-active suggestions on what I might try that I haven't already exhausted from MY end. Let's not make this a 'switch it on, switch it off, call support' thread. Thanks anyway, fella ,-)

Nov 14, 2017 8:17 AM

Reply Helpful

Nov 14, 2017 8:23 AM in response to AndyXII In response to AndyXII

I understand. One thing you haven't mentioned... You have re-set your router, right?

If you haven't, do that before you do anything else.

If it still doesn't work, connect to the hotspot on your phone from that Mac and see if it will let you sign into iCloud while on that network.

Honestly, this doesn't sound like anything being 'blocked' by Apple, or even necessarily anything borked on your iMac to me. It sounds like a network problem.

Nov 14, 2017 8:23 AM

Reply Helpful

Nov 14, 2017 8:57 AM in response to KiltedTim In response to KiltedTim

Thanks fella. Nice call with the Hotspot... hadn't thought of that. Unfortunately,.. nada; but it goes into my list of future check list 😉. Just going out to buy a new Ether cable. The studio is in a separate building sans ether port. Maybe if I drag the beast into the main house, I can get in off of a direct connection.


One result. I force quit the iMac, rejecting the Saved State message on reboot. I'm back into my Apple ID account - though that might be a result of a message I fired off this morning to the unfortunate friendly Apple rep who you get channeled to instead of an Apple technician.


It hasn't woked for iMessages or FaceTime, though. I'm going to surf the web for any sob stories of deleted licenses, PACE or iLok problems from reinstalling OSX, and if I see anything positive, I'll try that.


One thing: I don't see any certificate in Keychain relating to iMessage. Should there be (do you have one)?

Nov 14, 2017 8:57 AM

Reply Helpful
User profile for user: AndyXII

Question: Can't Re-Associate my iMac to Apple ID