Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: High Sierra don't see new hard drive or thumb drive

I work in IT for 16 years now (worked as Apple certified technicians from 2001 to 2005) and this latest Apple OS upgrade totally confuse me yet... I suspect this is due to the introduction of APFS structure maybe.


This morning I installed a brand new SSD drive into a 2016 Mac Mini (yes I know, the take apart is a PITA), I created a USB installation disk out of the High Sierra official install on another Mac at work. When I first booted my Mac Mini, Disk Utility doesn't show any internal hard disk (not initialized or anything), so I first thought that my SSD Drive was DOA from the box... so I took apart my Mac Mini again (GRRR) and tested the SSD into a portable USB3 enclosure. I first connected it to my everyday MacBook Pro 2014 (with High Sierra installed), I got the prompt "You connected an initialized disk, would you like to initialize it", so it brings me to Disk Utility... SSD Drive is invisible! Nothing worked to make it visible. So I connected it to a Windows 10 PC on my desk (yes, usually Windows is the solution to all your Mac's issues) and SSD disk showed up correctly in Disk Manager... I didn't touch it at this point and disconnected it. I finally decided to connect it to another Mac Mini 2016 I have at work, who are still on Sierra 10.12 and guess what... SSD Drive showed up correctly and wanted to initialize in Disk Utility! So I took my SSD Drive again with me and I connected it to a few High Sierra computers I have at work (we have 60x Mac at work) and all High Sierra won't mount the SSD disk, but all Sierra (or under) mounted it without any issue.


You know what? I finally ended by initializing and formatting the SSD drive over USB interface on a Sierra iMac and then I put it back into my Mac Mini 2016 and booted on the USB install disk of High Sierra and now it wanted to install on the SSD without any issue.


Since I reproduced this issue on a dozen High Sierra computers (MacBook, iMac and Mac Mini), what happening exactly here?


I also had the exact same issue a week ago with a uninitialized USB thumb drive... where it never showed up on High Sierra and worked perfectly on Sierra or under!

MacBook Pro with Retina display, macOS Sierra (10.12.2), 13 in, i7 CPU, 16 GB, 512 GB SSD

Posted on

Reply

Page content loaded

Nov 14, 2017 8:12 AM in response to SimmZ2008 In response to SimmZ2008

go here and describe the issue:

developer.apple.com


i'm in IT too, if computers didn't have problems I would be recommending a perfectly paired Bordeaux to go with the free range antelope medallions right now instead of trying to get AirDrop to work.


Let the developers know the problem and maybe they can sort it out.

Nov 14, 2017 8:12 AM

Reply Helpful

Nov 14, 2017 8:34 AM in response to JimmyCMPIT In response to JimmyCMPIT

Thanks Jimmy, I will let developers known about my issue. But since I were able to reproduce the problem on several disk and on more than a dozen of High Sierra computers, I assume this is probably a "known issue" but I found very little information/answer about this issue while Google-ing up the question before posting it here... I found that very surprising. Maybe that High Sierra isn't widely adopted by Mac owners in the world, that's a possibility! 😕


Other than that, I confirm that I have very bad times with AirDrop and High Sierra myself too... my wife have the 2012 MacBook Pro (non-retina) at home, while I have my 2014 MacBook Pro (Retina) and we can't see each other by any way and we are both on High Sierra... I finally gave up and sent file by email to her!!! 😠

Nov 14, 2017 8:34 AM

Reply Helpful
User profile for user: SimmZ2008

Question: High Sierra don't see new hard drive or thumb drive