Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Couldn't upgrade to HS on iMac fusion drive

I downloaded the OS HS from apple store and during installation I got stuck on the following error:

"The path /System/Installation/Packages/OSInstall.mpkg appears to be missing or damaged"


I've read a lot but so far haven't been able to solve the problem. I also found out that HS has issues supporting fusion drive.


Info:

- iMac 12,1 21.5 mid 2011

- In 2015 I replaced the original HDD with a DIY fusion drive (120GB ssd + 4TB HDD)

- using OS 10.12.6 - Sierra

- using apple trackpad + bluetooth keyboard

- I have a TM Backup but it's months old

- I have a bootable usb with El Captain

- Don't have access to another mac

- Only have a windows laptop but no adm rights (work laptop)


diskutil shows this:

disk0 GUID_partition_scheme *120.0 GB

disk0s1 EFI EFI 209.7 MB

disk0s2 Apple_CoreStorage FUSION 119.2GB

disk0s3 Apple_Boot Boot OS X 134.2 MB

disk1 GUID_partition_scheme *4.0 TB

disk1s1 EFI EFI 209.7 MB

disk1s2 Apple_CoreStorage FUSION 4.0 TB

disk1s3 Recovery HD 650.0 MB

disk2 Apple_HFS Fusion Drive +4.1 TB

Logical volume on disk0s2, disk1s2

disk3 GUID_partition_scheme +2.1 GB

disk3s1 Apple_HFS OS X Base System 2.0GB


** My goal is to come back to Sierra, so I can perform a new TM Backup. **

I understand that since the installation didn't go thru, it shouldn't be that difficult, am I right? **


What I've tried so far:

✅1. From the error screen. Utilities > Disk Utility > First Aid on Fusion Drive. The following error appears: "First Aid could not unmount the volume to repair"

✅2. From the error screen. Startup Disk > Chose "Fusion Drive macOS, 10.12.6" > Restart. After 15 min beach ball computer restarts and brings me back to the original error

✅3. Tried again the attempt 2. but this time after choosing "Fusion Drive macOS, 10.12.6", the following error appears: "building boot caches on boot helper partition failed". I found this, but haven't tried yet (here)

✅4. Hard Reset. Reboot holding shift key --> computer restarts and after progress bar comes to 100%, it hangs there until I hard reset it.

✅5. Hard Reset. Reboot holding cmd+R combination --> White screen with a crossed circle. diskutil says I have a Recovery HD but it doesn't show up here.

✅6. Hard Reset. Reboot holding option+cmd+R combination --> computer restarts and brings me back to same error (macOS could not be installed on your computer. The path system...)

✅7. Hard Reset. Reboot holding shift+option+cmd+R combination (internet recovery) --> connect to wi-fi > once the progress bar count down ends I get the following options: restore from TM; Reinstall Mac OS X (lion); Get Help Online; Disk Utility;

In Disk Utility:

- Open Disk Utility > can't mount ssd nor HDD.

- Open Disk Utility > can't unmount Mac OS X Base System (disk3).

- Open Disk Utility > ssd > verify disk > "storage system verify or repair failed"

- Open Disk Utility > hdd > verify disk > "storage system verify or repair failed"

- Open Terminal > can't unmount Mac OS X Base System (disk3). (diskutil unmountDisk [force])

- Startup disk > Choose startup disk > no option available

✅8. Hard Reset. Reboot holding option key --> two HD icons appear with "mac OS Installer" written as label. I tried choosing both but no luck. After pressing enter, it gets stuck on apple symbol with no progress bar under it.

✅9. Also tried Terminal from error screen: can't unmount Mac OS X Base System (disk3)


Any help will be greatly appreciated.

Thanks in advance.

iMac (21.5-inch Mid 2011), macOS Sierra (10.12.6), DIY fusion drive

Posted on

Reply

Page content loaded

There are no replies.
User profile for user: vitorzb

Question: Couldn't upgrade to HS on iMac fusion drive