Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Cannot delete certain messages from Apple Mail

I cannot delete certain messages.


All messages from senders I once delegated to the "Archive" will land there.


If I delete them, they come back. My archive is crowded with messages I don't want and that I cannot delete.


When I get messages from those senders into me in-box and I delete them, they don't go to trash, but go to archive.


Another silly fail for Apple Mail. How can I stop this madness?

MacBook Pro with Retina display, macOS Sierra (10.12.6), 512 Gb SSD, 16 Gb RAM,

Posted on

Reply
Question marked as Solved
Answer:
Answer:

I don't use the archive button through a web browser. the only thing I do when I access gmail through web browser is to mark spam messages as I'm not using the apple mail junk folder as it doesn't work.I rebuilt the mailbox - no result.

I found that I get better results for SPAM by using SpamSieve as a "replacement" for the Mail app's junk folder.

Only the newer ones - that also don't allow me to chose "archive" as the mailbox for archived mail, but only have the option "gmail all mail" . Why? I suppose this is the problem.

Again, the email folders that you configure on the Mailbox Behaviors tab are Gmail's folders, not something that Apple creates. The tab basically allows you to "point" to the Gmail folders for each of the email features (Inbox, Drafts, Spam, etc.) Gmail defaults to the "All Mail" folder for archived messages. This may be something that Google changed recently, I don't know. I mainly use my Gmail account as a SPAM "catcher."


Which folders you have in Gmail are initially created by your Gmail account. You then have the ability to add or make changes to these as needed by going through your Gmail user account.

Posted on

Page content loaded

Nov 14, 2017 10:44 AM in response to Ocean 17 In response to Ocean 17

Ok, your "mailbox behaviors" settings are exactly the same as mine for my Gmail account, except for the "Trash Mailbox" setting. Mine is set to: [Gmail]/Trash


The Mail app "maps" the mail "folders" provided by the email provider by default. It mostly does a good job doing so, but it can misinterpret the provider's folders on occasion. Gmail is known to be somewhat problematic.


Do you experience the same issues when you access your Gmail account via a web browser?

Nov 14, 2017 10:44 AM

Reply Helpful

Nov 14, 2017 10:55 AM in response to Tesserax In response to Tesserax

I don't use the archive button through a web browser. the only thing I do when I access gmail through web browser is to mark spam messages as I'm not using the apple mail junk folder as it doesn't work.


The older accounts do not show this crazy behavior.


Only the newer ones - that also don't allow me to chose "archive" as the mailbox for archived mail, but only have the option "gmail all mail" . Why? I suppose this is the problem.


Once I marked A SINGLE EMAIL from a sender into archive, ALL FUTURE MAIL from that sender gets stored there.


I rebuilt the mailbox - no result.

Nov 14, 2017 10:55 AM

Reply Helpful
Question marked as Solved

Nov 14, 2017 11:08 AM in response to Ocean 17 In response to Ocean 17

I don't use the archive button through a web browser. the only thing I do when I access gmail through web browser is to mark spam messages as I'm not using the apple mail junk folder as it doesn't work.I rebuilt the mailbox - no result.

I found that I get better results for SPAM by using SpamSieve as a "replacement" for the Mail app's junk folder.

Only the newer ones - that also don't allow me to chose "archive" as the mailbox for archived mail, but only have the option "gmail all mail" . Why? I suppose this is the problem.

Again, the email folders that you configure on the Mailbox Behaviors tab are Gmail's folders, not something that Apple creates. The tab basically allows you to "point" to the Gmail folders for each of the email features (Inbox, Drafts, Spam, etc.) Gmail defaults to the "All Mail" folder for archived messages. This may be something that Google changed recently, I don't know. I mainly use my Gmail account as a SPAM "catcher."


Which folders you have in Gmail are initially created by your Gmail account. You then have the ability to add or make changes to these as needed by going through your Gmail user account.

Nov 14, 2017 11:08 AM

Reply Helpful

Nov 14, 2017 11:53 AM in response to Ocean 17 In response to Ocean 17

I'm sorry that this is causing so much trouble.


The only thing I can suggest, at this point, is to:

  1. Delete the Gmail account in the Mail app.
  2. Log into your Gmail account with a web browser and configure all of the mail folders as you see fit.
  3. Then add the Gmail account back to the Mail app.
  4. Finally, look at each of the email account tabs in the Mail app to verify all of the default settings match what you want.

Nov 14, 2017 11:53 AM

Reply Helpful

Nov 14, 2017 1:07 PM in response to Tesserax In response to Tesserax

Thanks, this worked.


Now I even have the "archive" folder for archiving things.


The only thing is that ALL email now disappeared from the Archive folder, not only the ones that I erased.


It's been three decades, but designing an easy to work with email application seems to still be a challenge.

Nov 14, 2017 1:07 PM

Reply Helpful
User profile for user: Ocean 17

Question: Cannot delete certain messages from Apple Mail